AST1300 UEFI GOP Motherboard integration


I have separated pci-e AST1300 card. Gigabyte GC-IVA.

I have tried to update vbios and uefi gop with ASpeed own packages. aspeedtech support downloads
Actually they have a nice package that containing all. There is directories:

UEFI - *.efi files, UEFI_ROM - *.rom files, VBIOS - *.396 (rom) files, VBIOS+UEFI ROM - *.rom files

There problem is that VBIOS+UEFI ROM flash failed. I think there is enough space for both.
VBIOS is 32,8kb, UEFI 45,6kb and UEFI+VBIOS 78,3kb. It is little bit akward to choose between UEFI and normal VBIOS. If my MB get cmos cleared there is now picture to set up bios and to daily use UEFI is more comfort.

My MB is Supermicron X10SRA ( without IPMI and VGA ). There is also brother X10SRA-F that has AST2400 IPMI / VGA controller. So my bios have those modules in it.



It is better idea to replace those modules or add AST1300 as a new module to the bios to get UEFI and Legacy support?


ps. sorry about my english skills.

I suppose integrating the AST1300 bios in your mainboard bios possibly won’t help for a separate PCIe graphics card from a different manufacturer.

The AST bios files do come with flashing tools. Did you try to make a backup of your cards bios with the dos- or EFI- flash program? What you get there might give you a hint which file you’ll need to update. (Are you sure it’s worth the effort?)

I tought that is possible because of there is same series chipset module already. AST2500.

I have tried both UEFI_ROM and VBIOS, and both works. But combinated File is too big, maybe? Or some reason it is not flashing it.

dump vBIOS with GPU-z and let me see it

I checked the download vBIOS package, and see only three possibly apply to your card in the legacy/BIOS+UEFI folder
- uefi_2300_396.rom: AST1300/2300, MCLK=396Mhz << Is this the one you used? If yes, how did it fail?
- uefi_2300_dvo.rom: AST1300/2300 + DVO, MCLK=396Mhz
- uefi_2300_ite.rom: AST1300/2300 + ITE66121, MCLK=396Mhz

The problem shouldn’t be the .396/.dvo/.ite- files, they should be standard, digital out (mostly DVI), and support for an HDMI chip.

More confusing for me are the four different folders:


But when looking at the files there isn’t too much difference:
It’s Efi driver, Efi driver with a (‘GOP-in-OROM’) header (makes it look like OROM?), Orom and Orom and Efi driver combined after each other with the same ‘EFI GOP-in-OROM’ header before the Efi driver.
Read with drvver (version itself seems not to be right, it’s from the 1.09 package, EFI driver from 1.02 was 0.24.74 and reads correctly)
UEFI => EFI GOP ASPEED - 0.08.8c
VBIOS => OROM (drvver doens’t give anything)


(But I just played it with this related to an old P9D-I with an AST 2300 as BMC, never tried the bios-file in reality! [This thing's funny anyway: OROM and EFI driver(why?) in CSMCORE, EFI driver separate (as it should be) and an additional OROM in padding?])

uefi_2300_396.rom works, also ASTVBIOS.396.

BUT with uefi_2300_396.rom no picture at boot with Video mode legacy,
ASTVBIOS.396, no picture at boot with Video mode UEFI.

I use mostly UEFI, but if CMOS in mobo is reseted it is automatically legacy video mode and I can’t do the bios settings without picture. So I need another GPU to make bios settings … and that is akward.

.dvo is digital output? What about .ite?

Which uefi_2300_396.rom did you use? From the folder ‘VBIOS+UEFI ROM’ (78kB) or from the folder ‘UEFI_ROM’ (46kB). The first one might/should work in both modes.

ASTVBIOS.396 is a legacy rom and not supposed to work in UEFI mode.
uefi_2300_396.rom from the folder ‘UEFI_ROM’ (46kB) is a UEFI GOP with a header that makes the file look a little bit like a legacy rom, but it’s still an UEFI GOP which is not supposed to work in legacy mode.
(@Lost_N_BIOS Do you know the meaning of this type of ‘GOP camouflage’?)

Did you backup the old AST1300 bios?
If so: Can you attach the backup?
Did you try to flash the larger uefi_2300_396.rom from the folder ‘VBIOS+UEFI ROM’ (78kB)?
How big/what type is the SPI chip or picture of the SPI chip?
Messages from the flasher?

Yes, I tried. But it says verification error. Only reason I can think of it is running out of bios memory range? because < 50kb files is just fine.

I can send the exact message afterwards. I think the chip is inside the AST1300 chip because there is no casual bios chip on the BCP.

And then I got idea to put the .efi to the bios.

Looking at a picture there are at least two chips that could be SPI: The two Chips with MX on it (red and green dot).
The syntax seems to be “Flash NewROMFile BackupROMFile” did you get a ‘BackupRomFile’ from your first flash?

Here is the original backupped vbios.

EDIT: The original bios only works with legacy mode. (16.7 KB)

BUT with uefi_2300_396.rom no picture at boot with Video mode legacy << This to me says you need to make some BIOS changes, to option rom/ boot filter settings, and change video to Legacy and UEFI Boot.
Send a copy of your BIOS too now, lets check it out. Manufacturer link is fine for now, so I can just look at the settings in general and the base default applied settings.…C600/X10SRA.cfm > Update Your BIOS. Direct link is not possible.

@Lost_N_BIOS As far as I undrestood he flashed the SPI of the separate VGA card only. If he flashes with the legacy rom (32kb) the card has picture at boot in legacy mode, If he flashes the UEFI- driver (46kB) the card has picture in UEFI mode. He couldn’t flash the combined module (78kB)- SPI size?
Seems unclear to me if one could integrate the Bios of the separate VGA card in motherboard bios. The motherboard seems to have modules for AST 2400 (same bios used for another board subtype with AST2400 as BMC? on board). They might be exchanged with modules for AST1300/2300, but if this works?
(My P9D-I C222 has an AST2300 as BMC. 1 UEFI driver in CSMCORE, 1 as ‘normal’ efi driver, one legacy bios in CSMCORE and one legacy bios in padding…- as far as I could find. Exchanged them to a later version but never tried this bios in reality)

@raun0 Could you possibly make a picture of the card, especially the 2 chips close to the PCIe connector (just out of curiousity)?

^ You explained it just how it is! Sorry my about my english :slight_smile:

Cips are:

Red - dot: MX IC 25L512E MI-10G
Green - dot: MX IC 25L512E MI-10G
Last one: 3170A PFGG

Red and green each 64kByte SPI flash. Maybe one is needed for NVRam but with a 32 kB bios there would be enough room for that on the same chip.
All three Dos Flash.exe are different versions. Did you use always the same flash program? Maybe they’re ‘wired’ to specific addresses/ chips? It’s not very likely but maybe worth a try to use the flash.exe provided in the specific folder and flash legacy and Uefi after each other with the corresponding provided flash?

Your backup is a normal legacy bios 0.96.00 as far as I can see. Your mainboard bios is ‘easier’ there is just one legacy rom and one Uefi driver for AST2400. But “playing” with your boards bios does by no means guarantee success and there’s always a chance to brick it… Maybe Lost_N_BIOS has an idea?

What is the reason that you want to update, by the way?

@lfb6 - He said at post #6 that he flashed in uefi_2300_396.rom, but “no picture at boot with Video mode legacy” (This vBIOS = Llegacy + UEFI vBIOS) - that is why I think actual BIOS settings may need changed, CSM enabled/Disabled, or option rom settings changed as mentioned.
But, he now agreed with you, so I’m still confused - which is it, did he flash this vBIOS to graphics card as he said he did, or not?

I also assumed he meant he was flashing this into a graphics card? Is that not what’s going on here? If not, and this is going into the motherboard BIOS, then I definitely want to see the board BIOS for this too.
I would do that too, even if this does not involve motherboard BIOS, update it’s vBIOS/GOP modules. Aside from this other stuff, if may help as well, but depending on BIOS settings and vBIOS used, BIOS settings will need to be adjusted

@raun0 - yes, please update to latest BIOS before trying to address this any further, if you are using old BIOS now, this issue may be fixed in new BIOS. Is the above link your correct BIOS, before I download to check the default settings?

@Lost_N_BIOS Yes, we talk graphics card bios.

The combined legacy/uefi file (78kB) and the Uefi driver with header have the same name. The SPI is 64 kB and he confirmed that he couldn’t flash the 78 kB file so I’m pretty sure he flashed just the Uefi driver with header from the folder UEFI_ROM. With this module he had video on boot in UEFI mode but not in legacy mode, so that’s pretty conclusive.

I assume so, about the vBIOS. Sorry then, I misunderstood your post at post #6, sounded like you flashed in the file I mentioned above (uefi_2300_396.rom) and it worked, you said it did but no video in legacy?
UEFI Driver and or w/ header has nothing to do with this, as far as what I am talking about. I am only talking about the vBIOS file >> uefi_2300_396.rom << you said you flashed this to the graphics card, correct? And then video only worked in UEFI Mode, but no image in Legacy mode, correct?

No video in legacy mode does not conclude anything, that could be stopped by motherboard BIOS settings (if all set to UEFI only), that is why I asked for your boards BIOS or for you to confirm the link lfb6 posted is the correct board so I can check the BIOS settings.

Sorry @lfb6 - obviously I thought it was raun0 I was replying to