Hi Folks,

Can someone please enable AHCI mode for the JMB362 Controller on the mobo? in the BIOS, ASUS has restricted it only to "IDE Mode".
the option is available under Advanced > Onboard Devices Configuration > JMicron 36x ATA Controller
i do not need it functioning under IDE Mode so if this can be permanently switched to AHCI mode it would be great.

I have attached the latest version of the bios.

thanks in advance. (507 KB)

AT4NM10T-I has NM10 Express chipset and also according to manual it has Ahci support,Jmicron 36x ATA controller has nothing to do with it.
Assuming you are using the right ports,which there are 4 sata ports right under the NM10 Express chip itself,south (bottom).Ahci option should show up in bios main page,under Storage Configuration,Configure SATA as ___ (IDE)(AHCI)(DISABLED)
Use sata0 port
Latest bios version is 0501 (dated 2013/03/01)

using MMTool v3.22_1B_21Fix-BKMOD shows PCI Option ROM 8086:27C3 Intel Raid SATA v.

Online Hex Editor so you can identify the roms
AMI (non-UEFI) BIOS Modding guide
How to update the CPU microcodes on a non-UEFI guide
platomav’s Intel, AMD, VIA & Freescale CPU Microcode Repositories
EFI LAN BIOS + Intel GopDriver modules

Hi there,

thanks for sharing the info. NM10 only has 2 SATA ports and they can be configured to AHCI no issues.
Extra 2 SATA ports are provided by the JMB362 chip on the motherboard which does support AHCI but ASUS has limited it only to IDE Mode.
I have tried modding the BIOS using the MMTool with the latest version AHCI patched Jmicron ROM but no luck its still stuck on IDE Mode.
I guess the switch needs to be enabled via BIOS and checking it via AMIBCP doesnt show any hidden options.

so need the help of experts here to accomplish it :smiley:

both bios and motherboard supports ahci.
can you confirm that you are using SATA0 port and still not seeing achi option in bios settings like details given above?

Yes Port 0 and 1 work on AHCI without issue. Port 2 and 3 are on IDE mode and not on AHCI. these ports are provided by the JMB362 controller. i require AHCI to be enabled for these ports also…

@Lost_N_BIOS had done similar patching for ASUS AMI bioses…