Asus g75vw insert new vbios

Hi Guy’s,

I’ve replaced the gtx 660m in my g75vw with a gtx 670mx from a g75vx.
I’ve got a extracted rom from a g750vx and tried to insert the vbios in my dumped rom.

However, I always get a black screen.

I don’t know if I have done it right tho.

I openend up my dump in mmtool, went to the replace tab.
Selected “link present” in the for option rom only.
Selected 10de,1213 (wich should be the device id of the gtx 670m, since I don’t need that one).
However, the device id of the 670mx is 0x11a1. So I don’t know if the replace is a good idea?
Should I delete the 1213 module en insert the 11a1 one and fill in the right device id?

thnx in advance!

p.s. just to be clear. The g75vw and g75vx have no bios on the card itself. it’s integrated in the main bios. (but I suppose I’m just stating the obvious)
But it’s the first time I came across a notbook with a separate discrete gpu that doesn’t have a spi chip itself.


Allright, some updates.
my insertion seemed to do the trick.
However, only with An external screen, hdmi as well as dp. In Windows, When I installed the drivers, same thing. It cannot detect my internal screen. I’ve read quite a few succes stories. But those People seem to be using the regular 40 pin fhd screen at 60hz. While I am using a 50pin 120hz fhd screen (3D). Both the g75vw as the vx are available in 3D and none 3D. Same board but there are 2 seperate spots next to eachother for the coresponding connectors. Only one is solderd on. I’ve got this panel:…view_14168.html

It’s An edp panel. I don’t know if the other connector is lvds or edp. However, I’m a bit puzzeled right now.


As I expected the the other connector should be lvds. However I find several contradictions online.
Techpowerup writes that both the 660m and 670mx don’t physically connect to any Port. So I would guess that optimus would be used and data get’s copied to the igp framebuffer. Howerver the ipg seems disabled in these machines.

I found another person having the same issue in the same machine. (Also with 3D display) the same happens on the asus G73SW. With gtx 460m, it works both internal and external, with gtx 560m only external.

@ns_ripper - Yes, delete 10DE 1213 and insert 10DE 11A1, you don’t need to set any info/ID etc, it’s already coded into that module.
Since this is not the same model system the display output settings may be different in the vBIOS, so it may not work at all. If you want 100% working chance you need to find dump of BIOS from your exact model that was sold with the newer card.

Some settings may need adjusted in the internal vBIOS (not for the card, but for the CPU), this is what sends out signal to displays as you already found out. iGD/dGPU cannot be disabled for this reason in 99% of laptops systems.
I’ll need a motherboard BIOS dump from each model, or at least stock BIOS for each, then I can look into this.

It may also be that you simply need to update GOP part of the vBIOS, or GOP/vBIOS part of the main BIOS, and no settings changes are needed, hard to say, lots of things at play there
Additionally including the panel difference possibilities between the two (I’ll see this at board vBIOS in settings tool)

Hi Lost_N_BIOS, thnx for the help!

The g75vw never had a 670MX, only a 660M and 670M. However, since I knew that people had sucessfully upgraded tot 670mx’s, I ordered one as well on ebay.
I will provide you 2 full dump’s this evening. (Currently at work right now).
When the 670MX is plugged in, and I use an external screen I see no igp in windows.
I will check this evening if the same happens with the 660M (when the internal display works).

I’m sure we can probably figure it out, it’s just much easier if that model did in some instances sell with that card.

Thnx Lost_N_BIOS, you just gave me some hope again.

Seems like these guy’s where having similar issues. But this was on genuine g75VX’s (where the card orginally came in).…nything-like-it


I allready have this:…ZwAbHy2QLJJqDIZ

This is for the VX. I Used the g75vx.rar to extract the bios.
However, the other 2 VX files are from different motherboard revisions. Maybe there is a difference, however asus only provides one on their site. (so it doesn’t make any sense).
I’ll provide you my own full dump of my VW this evening.

p.s. if you have a gmail address, I could add you to the share. Might be easier to collaborate?

kind regards

I need stock BIOS for both laptops models mentioned here, and then your dumped BIOS too if you want (we can do via FPT, but more work for you that way because you’ll need to unlock BIOS lock and SMI lock too maybe before you can FPT flash mod BIOS)
Please provide me links to both at Asus, for the system BIOS versions you used. The google folder adds to confusion I don’t need, nothing there helpful for what i need to do I mean.


I always use my trusty ch341a for dumps. Only annoyce is that I always need to solder and desolder. My soic clip has been broken for a while. I’m surprised that my original chip stil works after like 10 x hot air sessions xD

Stil didn’t had the time to get into my basement to provide my own dump to you. Busy and tiering last 2 days.

Kind regards

I’ve added my bios to the drive folder.
However it’s the 6Mb one. Only difference from the retail is that I unlocked some hidden menu’s.

Still haven’t been in my basement yet to upload my full dump. Quit smoking a week ago, and I seem to feel tired all the time. So I often went to bed at 8pm. (dunno if it’s related or not).

i finally added my full dump: mijn_g75vw_dump - kopie.Bin…ZwAbHy2QLJJqDIZ
@Lost_N_BIOS any ideas yet?

it’s good that I found you, and for 2 months now I’ve been suffering with this asus g75vw I have a video card gtx670mx that does not read bios
if you can edit my bios please

I installed your BIOS on asus g75vw but gtx670mx is not registered there if you edited my BIOS I would be very grateful

I guess I’ll stick to the 660m

@ns_ripper - Sorry for delay! Please put all files into a single archive, and link it by itself on any site
I hate googles mess of folders and don’t want to dig through files trying to see what to download and what not to download (I didn’t check any of your links, since it’s already confusing here) * Edit, checked that link, it’s a mess as suspected
I need your original BIOS once only, however you dumped it or modified it does not matter to me (g75vx), or just the original vBIOS module + the g750vx BIOS or it’s extracted vBIOS module only, that is all. I will send you back fixed vBIOS module only, or vBIOS+GOP then you put back into BIOS
Actually, since GOP module may need carried over as well, just put both entire BIOS into an archive by themselves and I will remove modules as needed.

@uktam11356953 - please wait, do not install any BIOS from here, you will loose your serial/UUID/MAC ID if flashed improperly (probably too late now ) Why did you flash any BIOS from here, when it’s obvious he was asking for help and hadn’t fixed this yet???
Once we confirm all is working properly I will have you dump your current BIOS via FPT and send to me and I will make you new one to flash.

What mess? It’s a folder with 5 files.
I described them all while the conversation progressed.

G75vx.rar is a dump of someone’s vx (I have a vw). From that dump i extracted the 670mx bios.

mijn_g75vw_dump - kopie.Bin Is my dump.

Mod.rom is my bios region with the 670mx bios allready injected.

However, All the vx’s With 670mx I found in forums and the succes stories of upgrades g75vw, used the 30-pin edp connection and standard non-3d screen. All the ones with 3D screen (50-pin lcd’s) Seem to sport a gtx660m.

The other 2 75vx archives are g75vx biosses from 2 different motherboard revisions someone posted somewhere else.

So you only want mijn_g75vw_dump - kopie.Bin (My dump) and g75vx.rar a vx dump.

I am on limited internet, and only want to download what is needed, and I don’t know what is what in there and I hate google and that type of folder formatting. Please package what I asked, it’s simples
Most people that upgrade are not editing vBIOS and GOP like I will be doing, so much better chance of success here. I will be changing all the settings to match your original vBIOS/GOP, so it should work exactly same.
* Edit - I grabbed the files, please wait and I will get you new vBIOS/GOP done
*Edit 2 - sorry, I was thinking onboard GFX output needed edited here, this is not something you changed by editing/swapping vBIOS, so should always have remained the same
Let me look at these vBIOS and see if I can figure anything out for you

Did you already try both C5D7EAAD-B218-482C-A909-E3B8CDB00E94 and C5D7EAAD-B218-482C-A909-E3B8CDB00E96? << Last one is the one you have extracted (but legacy form instead of UEFI one, and the 2012 version too so older)

You are using UEFI mode correct? This BIOS does not have any legacy vBIOS modules, only GOP/UEFI (talking about onboard graphics output, not the GFX card vBIOS)
Ahh! This may be part of the issue, I see you extracted legacy vBIOS from CSMCore (A062CF1F-8473-4AA3-8793-600BC4FFE9A8), you need one of the GUID’s I mentioned above instead!


Please wait, I will make you some new BIOS with those, and with those updated to latest GOP version too

* Edit 19 - very confusing! Is this file, mijn_g75vw_dump - kopie.Bin << one you already edited, in regards to this GFX issue? If not, it already has GK104 vBIOS UEFI/GOP in it at the two GUID’s I mentioned above 94/96
So, if you have not edited this already, it should be compatible as-is with GK104, but you may need updated GOP in those vBIOS modules. I’m not doing anything here on this until you clarify what this file is and how/if you edited it etc.
If you did edit this file for the vBIOS, what all did you insert, where (What GUID) and how? Sorry, I thought this file was menu edited/updated only, didn’t think you inserted vBIOS or anything yet. So, as I mentioned, this and your folder is confusing
Did you insert both 94 and 96 GUID + also do the one at CMSCore too, or not? Too confusing to dig around and try to compare stuff, I thought this was unedited aside from menu mods, other general updates etc.

* Edit 900 - OK, sorry for my confusion, I compared and see now. I mistakenly seen those as GK104 and they are really >> GF104B Board - 13140008 @ DE 10 13 12 >> 670M
I am not familiar with Nvidia too much, so didn’t catch that until I compared modules.

*Edit 1000 - @ns_ripper - here, please test both these BIOS. One is as-is swapped, and the other I updated the GOP/EFI modules to latest in the two EFI/GOP vBIOS modules.
All three have these modules swapped C5D7EAAD-B218-482C-A909-E3B8CDB00E94 and C5D7EAAD-B218-482C-A909-E3B8CDB00E96 + The one you were swapping @ CSMCore A062CF1F-8473-4AA3-8793-600BC4FFE9A8 (This is legacy only)…436606701073910

Thnx for the effort.
I Will try them today. However, I’m afraid it Will be more complex. I allready tried flashing the vx full dump in my vw also. The vx came in 670mx and 660m flavour. Aside from the gpu option, the only difference between vx and vw is That the vx has a thunderbolt controller in the motherboard.

After flashing the vx bios, I had the same issue. External display works, while the internal display doesn’t get detected.

Did Some googling again. Gk107 (gtx 660m), does actually have lvds lines and can be used as stand alone. (So no optimus needed)

Found someones xorg (Linux) log:

(–) NVIDIA(0): Valid display device(s) on GeForce GTX 660M at PCI:1:0:0
(–) NVIDIA(0): CRT-0
(–) NVIDIA(0): LGD (DFP-0) (boot, connected)
(–) NVIDIA(0): DFP-1
(–) NVIDIA(0): DFP-2
(–) NVIDIA(0): DFP-3
(–) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
(–) NVIDIA(0): LGD (DFP-0): Internal LVDS
(–) NVIDIA(GPU-0): LGD (DFP-0): 330.0 MHz maximum pixel clock
(–) NVIDIA(0): DFP-1: Internal TMDS
(–) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
(–) NVIDIA(0): DFP-2: Internal TMDS
(–) NVIDIA(GPU-0): DFP-2: 165.0 MHz maximum pixel clock
(–) NVIDIA(0): DFP-3: Internal DisplayPort
(–) NVIDIA(GPU-0): DFP-3: 960.0 MHz maximum pixel clock
() NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
) NVIDIA(0): device LGD (DFP-0) (Using EDID frequencies has been
() NVIDIA(0): enabled on all display devices.)
(II) NVIDIA(0): Validated MetaModes:
(II) NVIDIA(0): "LVDS-0:1920x1080+0+0,DP-0:NULL,DP-1:NULL,HDMI-0:NULL,VGA-0:NULL"
(II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
) NVIDIA(0): DPI set to (75, 75); computed from "DPI" X config option
(–) Depth 24 pixmap format is 32 bpp
(II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
(II) NVIDIA: access.
(II) NVIDIA(0): Setting mode "LVDS-0:1920x1080+0+0,DP-0:NULL,DP-1:NULL,HDMI-0:NULL,VGA-0:NULL"
(II) Loading extension NV-GLX

That might explain, why I only see the Nvdia gpu and no igp. However, that does not explain why the 670mx is not detecting the internal lvds panel. Maybe the vbios is restricted to edp only or only the edp is wired on the card.

You’re welcome, can’t wait to hear how it goes!

VX full dump to your system would not work for many reasons, so I’d expect to hear that


While we are at it.
There is something else about this laptop I can’t figure out. When I put it in raid mode, I don’t get the dialog for the shortcut keys to get into the raid bios. So I can’t setup a raid array. Any ideas? Since I have to desolder and resolder my spi chip, we might tackle this in one step. (So I don’t need to torture that ic too much anymore)

Get SOIC8 test clip, they cost $3

BIOS contains both legacy and UEFI RST modules, so booting mode shouldn’t matter there. OROM UI and BANNER is enabled and OROM UI Delay is set to 2 seconds, so you should have at least 2 seconds.
Maybe graphics is not displayed quick enough for you to see it, did you try blindly smashing CTRL+I all through startup. Do you see Asus logo? Is this Win10 system? Fast boot is disabled, but I do see Quiet boot enabled, so this may be cause. Can you see Quiet Boot option at Boot page of BIOS? If yes, disable and try again.

@Lost_N_BIOS bad news.
both give no image internal and external.

al least no post. didn’t try to boot.

Try booting into windows too, so we know if that fails as well. Try UEFI mode if possible, with both