ASUS H61M-E Mod with NVMe module ** NEED HELP **

Hi everyone.

I’m having issue to flash a modded of my pretty old Asus H61M-E
Here is the original .CAP File : https://mab.to/cnHax3e3S

I’ve opened it with MMTool 5.02 and, on CSMCORE section i added the nvme compressed modules (4 modules) that i include in this Zip File : https://mab.to/RReOJzFO8

here is a picture where i can see the module added to the bios structure :


Once i go for save the modded rom to a new file, MMTool save it but report a Signature (unsigned) warning.


when i go for flash from Admin command line windows the modded bios, as suggested, i first flash the original Bios and immediately after, flash the .ROM renamed modded file with Afuwinx64 /GAN option.
Modded and .ROM renamed file here : https://mab.to/UxjBlxl6J



At this stage, the file hang up reporting a bios file size not correct.


I wish someone can help me or, gently, provide me a correctly flashable file to get the Boot from my M.2 SSD.

Thnak’s in advance for help.



picture of the M.2 SSD installation

@toxstoxs :
Welcome to the Win-RAID Forum!
Who gave you the advice to insert 4 different NVMe modules into the BIOS? That doesn’t work (2 of them cannot be used by your system, the 2 others may interfer with each other).
For users like you I have written >this< guide. Please follow my instructions regarding the insertion of the NVMe module. If you are unsure regarding the result, post your request into the linked thread and attach your modded BIOS. Then we will do a look into it and tell you, whether the BIOS is correctly modded and ready for being flashed or not.
Regards
Dieter (alias Fernando)

Hi. @Fernando

I been trying the guide you linked me as well…
here is the inserted module into CSMCORE


and this is the modded (following your guide) BIOS file (still reported with alert message about UNSIGNED)
https://mab.to/0fvVSiOJT

but still get the same error while attempt on flash it.

thank’s

EDIT by Fernando: Unneeded fully quoted post removed (to save space)

@Lost_N_BIOS

Is it possible to kindly hope in your help?

regards

@toxstoxs - Many things wrong here, luckily you didn’t brick the board with /GAN (although that may be one correct way to flash mod BIOS on this model, I am not sure)
This is Aptio IV BIOS, so normally you should use V4 MMTool 4.50 if possible (tested, worked fine), but if not sometimes it’s OK to use V5 on V4, I’ve done so may not be a big issue here.
I tested this mod with UEFITool, MMTool 4.50 and 5.02, all files hex identical post mod so any one would be OK to use, so no issue there

But, you can’t simply rename an encapsulated BIOS (.CAP) to .ROM, this is why the size error, luckily for you it did not flash it, very lucky since /GAN usually will stuff it right in and brick things.
And as Fernando mentioned you should only insert one NVME Module >> NvmExpressDxe_4.ffs

There is two ways to do this edit, as-is on the encapsulated file, or extract body from capsule, edit and then put back via hex (best method)

For flashing I would try this method first though, so /GAN not used unnecessarily (actually, I personally prefer FPT method because it works and isn’t 'Iffy" like AFU method can be)
Download the attached files in this guide and pay attention only to the flashing stuff, so you can get that version of AFU.
Then flash stock BIOS using that AFU, then without reboot, flash the mod BIOS (once you have a proper mod BIOS, current one is not).
https://linustechtips.com/main/topic/592…r-motherboards/

Or use Ai Suite method outlined here
[Guide] How to flash a modded AMI UEFI BIOS

Here is properly done Asus H61M-E-1303 NVME BIOS Mod
DO NOT use this file FPT flashing!!! This file only for use with AFU or EZ Flash, if EZ Flash will take it, try that first - additionally, DO NOT flash stock extracted BIOS body or encapsulated BIOS file with FPT, you must dump BIOS with FPT then edit, then reflash it
http://s000.tinyupload.com/index.php?fil…845998984241087


You may end up having to do the flash via FPT - go to this thread and in the section “C” download the V8 ME System Tools Package
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows folder. Select that Windows folder, hold shift and press right click, choose open command window here (Not power shell).
FPT Must be ran from an admin command prompt only, and Intel ME drivers must be installed first (unless you use DOS version)
At the command prompt type the following command to dump the BIOS region so you can modify it for reflashing >> FPTw.exe -bios -d biosreg.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help.
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)
https://www.windowscentral.com/how-add-c…creators-update
https://www.windowscentral.com/add-open-…menu-windows-10
https://www.laptopmag.com/articles/open-…ator-privileges


That biosreg.bin file is what you need to modify for using this FPT mention (insert once, and only NvmExpressDxe_4.ffs) and reflash using command >> FPTw.exe -bios -f modbiosreg.bin

You can only reflash this after you disable BIOS lock per the below guide, start at step 6, I’ve done 1-5 for you (Pay attention to the warning in this guide, in bold red font, also mentioned above)
[GUIDE] Grub Fix Intel FPT Error 368 - BIOS Lock Asus/Other Mod BIOS Flash

BIOS Lock variable to edit >> 0x88
Rename your efi file to >> Shellx64.efi

So at grub prompt you will type the following >> setup_var 0x88 0x0

bios mod link is broken

@subhash

The hoster obviously doesn’t store these files anymore - no wonder after nearly 2 years.
Nobody among the current Win-RAID team is able to repair such links to an extern hoster.

@subhash you could try to dump your bios with IntelFPT. send it here.