Asus P5K-E WiFi/AP + Intel RAID 1 + 3 TB disks

Hello everybody,

First of all I’d like to thank everybody that maintains and has contributed to this forum, finding informations was painless and was able to figure out most of the basic stuff.
I’ve just a few doubts left that I hope someone will help me clarify.

My current situation is the following:
- motherboard Asus P5K-E Wifi/AP -> https://www.asus.com/Motherboards/P5KEWIFIAP/ (P35 based)
- ICH9R
- already upgraded to latest bios version (1305)
- Intel MSM OROM version 7.5.0.1017
- 2x1TB RAID 1

I have bought a couple of 3TB disks to make a new 2x3 TB RAID 1 and replace the old 2x1TB but found out that my current OROM does not support the 3tb disks.

Now:
- I’ve understood that I have to mod the BIOS to replace the OROM with the 11.2.0.1527 and then flash it. Then I should be able to build a RAID 1 array out of the 2x3TB disks.
- I have also to use the 11.2.0.1006 RST drivers

Questions:
1) Has anyone tried this with this exact motherboard or similar? the closest I could find in the success stories is the one with the P5E, but didn’t tested >2TB disks and a user that tried with the Asus Rampage Formula
2) I’ve read that in some cases the OROM was too big to include it in the BIOS. How can I find out if my board/bios/OROM setup is affected?
3) has anyone experienced data loss/corruption using the BIOS modding procedure?
4) assuming that all the above works, I’ve also the need about having the OS on the very same RAID volume, but I’ve read that there are limitations:
- OS needs GPT partition table to see volumes>2TB
- non UEFI BIOSes are unable to boot from GPT partitions.
What I don’t understand is: if I create the RAID array with the RST BIOS tool, making a 3TB volume, then create i.e. three primary partitions of 1TB size (non GPT) and install the OS on the first one, will this be enough?

thanks in advance

Hi,

I have the P5Q3 Deluxe (P45/ICH10R) in my second PC. I was only able to update my OROM to 10.1.0.1008 because the BIOS does not accept modules above 85 KB of size. For your issue with your partitions I think you’re right. Making 3 1 TB sized ones could be the solution. In my actual PC I have a 6 TB RAID-0 array and it was not seen under Windows Vista/XP until I installed ASRocks 3TB+ unlocker which came with my MoBo.
Think you have to try it out…

Regards hanson

Edit: Maybe you should create the partitions before installing with a parted magic linux boot cd.



was this because there was no space left in the BIOS image and compression was ineffective or because there is a technical BIOS limitation? Also, when did you notice this? Did MMtools told you so? by trial and error?



just for my understanding, did you boot out of your array or you had another disk for OS?

thanks

@ Prorad:
Welcome at Win-RAID Forum!

Both statements are not 100% correct.
1. Only Intel RAID ROMs from v10.5.x.xxxx up are able to see >2 TB sized RAID volumes.
2. You can use any Intel RST RAID driver, but the Intel RST driver v11.2.0.1006 probably is the best in combination with the Intel RAID ROM v11.2.0.1527.
As hanson already has written, you may not be able to get any Intel RAID ROM with a size of >100 KB working. Some ICH9R/ICH10R Chipset mainboard BIOSes only have limited space for OROM modules.
Nevertheless I recommend to update the original Intel RAID ROM of the latest mainboard BIOS to v11.2.0.1527 and to flash it, but you should prepare an USB flash drive with the original BIOS for the case of a flash failure…

I don’t know anybody, who has the same mainboard and tried to update the Intel RAID ROM to v10.5 or higher.

Maybe you will get a message "not enough space", when you try to replace the original MSM RAID ROM v7.5.0.1017 by the Intel RST RAID ROM v11.2.0.1527. In this case you should try to get the Intel RST RAID ROM v10.1.0.1008 into the BIOS. This way you will not get > 2TB sized volumes detected by the OS, but a better performance with your RAID system.

I don’t no anyone, who lost data because of a modded BIOS. Nevertheless I always recommend to backup the important data before doing any BIOS flashing.

I am not sure about that.

Regards
Fernando

@Fernando thanks for your feedback. The MMTools didn’t gave me any error while updating the OROM, so I think I just have to try. I’ll let you know the outcome (if I’ll ever get my motherboard back alive :smiley: )

Hi,

I didn’t get any error during replacing the modules. I could successfully insert all of them up to 12.x. But the computer does not post (hangs during RST notification screen) correctly and the RAID configuration tool is not useable in case I used any module above 10.1.0.1008. In this machine I use an array of 2 TB so I have no idea about the behavior with your 3 (6) TB RAID 1.

Regards hanson

Edit: It was not a problem of insufficent space I think but of the BIOS structure itself. I deleted the OEM logo, several unused Orom’s to free space but thze result was same: nothing above 10.1.0.1008 worked. Anyway you should test it because for some ICH9/10R boards it’s ok

Well, in the end i tried and it worked. I flashed the suggested orom with the latest firmware and now I have a nice 3 tb raid 1. A couple of notes:

- booting from a 3 tb volume is possible but you lose the last tb of space. This because the disk must be initialized as mbr instead of gpt, and with mbr there is no way Windows will allow you to create a partition after 2 tb. Don’t know if gparted will, though.
- This is dumb but fooled me for a day: the Intel menu will not show up unless you connect at least two disks. At first I thought it wasn’t working because I was testing only with one disk.

@Fernando do You want me to add this to the success stories?

Thanks for your feedback. It is fine, that you succeeded with the OROM update and now can use the full space of your HDDs.

Of course I will do that.

That upgrade is probably just right for me, for using 2x3Tb in my RAID1 configuration on P5K-E (currently 2x1.5Tb).

But where do I find the Intel OROM update, and how do I use it?

Best regards,

Patrick from France

@ Transatlantic:
Welcome at Win-RAID Forum!

If you have the ASUS P5K-E mainboard with the latest BIOS 1305, the currently in use Intel RAID ROM is the MSM v7.5.0.1017. It has an uncompressed size of 64 KB.

You can find the different Intel RAID ROM versions within the start post of >this< thread. Since your BIOS is a non-UEFI AMI one, you can modify it by using the MMTool v3.26 according to >this< guide.
Here is a picture after having opened the BIOS:

P5K-E BIOS.png


The problem is, that you will need an Intel RST RAID ROM v10.5.x.xxxx or higher to get >2 TB sized RAID volumes supported, but all the related Intel RST RAID ROM modules (v10.5.1.1070, v10.8.0.1303 or - the best - v11.2.0.1006) have an uncompressed size of 119 KB. So I am not sure, if you will get any Intel RAID ROM module working, which is able to handle >2 TB sized RAID volumes.

Maybe hanson or someone else is able to help you.

Regards
Fernando

@ Transatlantic:

As hanson already reported about the P5K-E WIFI/AP BIOS, there is enough space within the P5K-E BIOS to replace the 64 KB sized Intel MSM RAID ROM v7.5.0.1017 by the 119 KB sized Intel RAID ROM v11.2.0.1527 (I just tested it successfully). Nevertheless I am not sure, that it will work and support your RAID1 array after having flashed it. Only a test flash of the modded BIOS will give you the answer, but you should prepare another USB flash drive with the original BIOS (for being usable in the case of any problem).