Asus Q302L BIOS update problems

Last week I upgraded my laptop to an SSD. After installing Windows, I started doing driver updates and started with BIOS. I downloaded version 205 since it already had version 203 and installed it using EZ Flash. Upon reboot, it wouldn’t POST, stuck on the static ASUS screen. I ordered a ch341a device and followed the guide posted on this forum and used a BIOS file someone else posted and got the laptop working again. Upon further review, the BIOS from ASUS were only 6,146KB. I’m not sure if the current BIOS are correct since I got them from someone else with the same laptop number, but they’re good enough to boot.
I am experiencing a delay upon boot before the initial POST screen and when I tried to re-download the BIOS, both version 203 and 205 are 6,146k and when I tried to update them through Windows and same result as above. It is functioning again by repeating the initial process.
Where do I go from here?

Did you dump your BIOS chip before you programmed anything to it? If not, then all your board specific details will be gone, maybe some can be reinserted from stickers inside and outside the casing, but not all. And for right now, you have someone else’s details in there, since you used someone else’s dumped BIOS
Please link me to where you downloaded the BIOS you programmed in. And, for now, please check ME FW version info, this may be shown on your BIOS main page, if not HWINFO64
Then on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version. If you see, or N/A, or no ME section where I described in HWINFO64, then this may be the reason its slow to startup

BIOS you download from Asus is only a partial upgrade BIOS, this is why it’s 6MB vs 8MB or 16MB complete BIOS dump (this is normal) As to why this is happening when you flash, not sure. Before this, did you get a lot of BSOD?
If yes, maybe you have memory that is going bad, test overnight, or all day while you work etc, with Memtest86+

I would suggest you update BIOS through EZ Flash only, not in windows.

This is the initial read I did after connecting the ch341a:!AsKgyXOq2AN2jHDYFVJplCM5tXnF?e=1YkHHH

This is the currently installed BIOS…08&d=1509599816

I did not see the “ME Firmware Version”, but I am linking some additional pictures of the bios screen and HWINFO screens and one from Sys Info!AsKgyXOq2AN2jHHM4y1TJVwLedjO?e=TrmtKy!AsKgyXOq2AN2jHJm-Gcktg2vtmJt?e=PBI9Mc!AsKgyXOq2AN2jHNXZdyEWuUYdxZT?e=r4lfJ3!AsKgyXOq2AN2jHRCRBYJ6yZy_17o?e=ZVjkR4

As far as BSOD, I haven’t had many of those at all.

@Techsavvydad - What is your exact model? I see Q302LA and Q302 on Asus Site, no Q302L. It also does not match the model you mentioned in your first post. Never mind, I see now in your old BIOS it’s Q302LA

The file you programmed from badcaps must have messed up ME FW then, it looks “OK” but I can’t tell for sure just by looking at it.
Obviously it’s ME FW messed up/broken, since you do not have ME FW showing in your HWINFO image. And, it says right in that thread, “I tried your BIOS and it does not post” why would you use this file???
Maybe it’s OK since you got it working though, maybe some failed write with programmer messed up the ME FW? What is your chip ID (look at the chip, don’t rely on software), and what software version are you using to write?

Did you test your memory for 8-12+ hours yet with Memtest 86+? If not, please do soon, so we can rule that out as possible cause of your initial update/loops.
It could have just been random glitch, bad luck, that stock BIOS did that, it can even brick when updating stock BIOS. But, for it to keep doing that each time you try to update that’s a problem.
Saying that now, it could be an actual bug in the 205 BIOS, do you have that same issue if you update from 203 to 204?

Wow, that site is terrible for file sharing! So, about 45 minutes later and a hundred starts and stops, I finally was able to get your 8MB non-zipped BIOS dump downloaded. I had to give up on trying to view all the images, but I did see HWINFo64 one
Please don’t upload anything there for me again

Here is fixed BIOS 205 - erase chip, blank check, open BIOS file, write/verify -…734411944797892

Then update only to 204, unless you want to risk same thing happening with 205 again. If it persists not matter what when trying to EZ Flash to 205, then I would email Asus and ask them to double-check it’s OK
To be sure I understood you correctly, after the BIOS bricked with 205 update, you recovered it with BIOS from badcaps and programmer and all was OK or semi-OK, and then you tried 205 BIOS again with EZ flash and same issue happened again. Correct?
If yes, sounds like 205 BIOS is maybe bugged, or the EZ flash module in your 203 BIOS is bugged possibly? I wouldn’t keep trying to use it, at least not via EZ Flash from 203.
If you want, I can make you 205 BIOS with your board specific info in it so you can program in, then you will know if 205 is buggy or not. << This = Done ^^

If ME FW still missing in HWINFo after this, then something is bad in your original ME FW settings, and we’ll need to find another good dump as source and try again.
I updated and cleaned ME, so settings transferred from your original dumped BIOS ME FW

I actually had a couple of different BIOS downloaded, and I must have gotten them mixed up, oops.

I used v1.29, and the chip itself says Winbond 25Q64FVSI(C?) 1427.

Not yet, will try to test it tomorrow or overnight.

On the ASUS website, I only see 203 and 205 for the Q302LA. The Q302LAB also skips 204, but the latest for it is 213. I wasn’t clear on the difference, so I just went with the BIOS for the Q302LA.

My apologies for that… It was actually my personal Onedrive storage with a share link.

Thank you!!!

I recovered both times with BIOS from badcaps and programmer(v1.29). The first time it bricked was when I tried with EZ Flash. The 2nd time I tried to use Winflash.

This is what you linked above? Thanks!

Ok, I’ll give this a try and let you know my results.

@Techsavvydad W25Q64FV you need to use software 1.30 or 1.34 and choose W25Q64BV or your writes will fail. I believe 1.18 may also work, but I have not personally confirmed.
ASprogrammer will work with exact ID ( And here is general CH341A software package with 1.30 and 1.34 -…695330485827902

Yes, I noticed that about 204 missing, looks like the pulled it off the server too (I tried to download it) Maybe we can find in google later, if needed.
“You just went with Q302LA” What do you mean by that? What is the exact model, look on the sticker on the bottom of the case, if it’s Q302LAB then you need to use that BIOS, if it’s Q302LA then you need to use that one.

I think it’s my internet is crap, lots of sites I can’t download from easily, while others work just fine

Yes, I went ahead and made you a fixed 205, program on with 1.30 or 1.34 software (or ASProgrammer) and we’ll see if 205 is bugged or not.

I am running the memtest now. I did try to flash the BIOS you attached but it bricked again, so I restored the previous BIOS and got it booted again. I did this with flashrom in Linux since I just installed it on one of my systems.

The exact model number on the bottom of the laptop is Q302L. It does have a serial number (F1N0CJIRR01T03E) but the only place I could find to enter it only showed that it has been out of warranty for 4 years, and I already knew that…

Edit: Just finished the Memtest twice, and no errors either time.

So, sounds like 205 BIOS may be bugged then! Memtest86+ must be ran for 8-12+ hours, not 1-2 passes, if you want to be sure there is no memory issues.
That leaves us here… If you want me to make you a 203 BIOS with all your system info back in there and fixed/updated ME FW.
If you do that, to avoid auto-frelashing of 205 BIOS by windows updates, you’ll need to disable driver update option of windows update.

If you could get me a fixed 203, that would be great! Thanks! I’m running the Memtest again a few more times as well.

Edit: The Memtest has run for a total of 10 hours with no errors.

@Techsavvydad - Great, then no memory errors, at least we know that!

Here is fixed 203 with all your info back in -
If this now also fails, then we know something messed up carried over in your ME FW that I put into updated 205, because also inserted here
If we find that to be the case I will have to use some other BIOS as source and redo the ME FW and make you another 203/205 so you can test.

@Lost_N_BIOS I just flashed the new 203 BIOS and it boots immediately AND shows Intel ME in HWINFO. Should I even try to update to 205 now the normal way with EZFlash or just leave it on the 203 BIOS?
Thank you so much for all your help!!!

@Techsavvydad - Great to hear it! You’re welcome

If you want, you can try one more manual update to 205 properly, using built in BIOS flash tool (EZ Flash), or however you normally update BIOS on this system (not in windows)
If it fails, then as we suspected at post #8, there is something wrong with the 205 BIOS. If so, then program back in the 203 I made for you and leave as-is

See here, for how to stop windows update from eventually automatically applying 205…cb-8e2555ca041f

Or, you can do this way if you are not using “Home” Edition
gpedit.msc —> Computer Configuration —> Administrative Templates —> Windows Components —> Windows Update —> enable "Do not include drivers with Windows Update

Hi @Lost_N_BIOS ,

I’ve stuck in the same situation. Some days ago I updated ASUS Q302L laptop with Q302LAAS.205 BIOS via setup EZ flash utility. Previously it had 203 BIOS. Now boot process is sticking on the static ASUS screen. There is no ability to enter setup or continue loading. It has ME dated May 09 2013. I dumped Winbond 25Q64 chip and decided to port your provided ME to that image. I’ve tried many times to boot with 205 but unsuccessful. I restored setup settings to default no changes …

P.S. I successfully installed BIOS 206 from TP300LA on Q302LA (has the same hardware) it boots normally and started Windows 10. But I’m losing my Windows 10 OEM license in this case (hardware changes detected).

Could you contact ASUS support team inside ?

@Techsavvydad - Issue with BIOS 205 reconfirmed! ^^^

@tarask1n - Next contact you have with Asus, send them link to this thread so they know you are not alone in experiencing this exact same issue
Please send me your original 205 bricked BIOS dump, I will make you correctly re-done 203 BIOS like I did for user above (this will have all your board specific details in it such as serial, UUID, LAN MAC ID, windows license etc)

Sorry, I do not have any contacts at Asus, you will have to reply back to them in email and send them link to this thread so they know your case is not a one time random issue.

@Lost_N_BIOS Thank you for your participation, I’ve easily restored all my laptop’s manufacturer specific information, etc. from the dump flash and return back 203 BIOS. It works ok.

I’ve contacted with ASUS and clearly described them that situation, provided link to that thread and got a service ticket N200111514. I proposed them to remove link to 205 BIOS temporaryly from their site to prevent appearing new bricked devices. But they e-mailed me via bot that they don’t have any problem with that update and proposed me to send my laptop to the nearest service center. I can’t waste a time to wait while my laptop should be investigated or not, because it is out of warranty and I will pay for shipment.

I’ve started my own investigation and on my own risks prepared and flashed to my Q302LA laptop BIOS from TP300LA model. On ASUS site it has 206 version dated 06/25/2019 which is similar to 205 version for Q302LA.
The Q302LA.203 BIOS


The TP300LA.206 BIOS into Q302LA laptop


All working fine, but in this case I lose my WIN10 OEM license, because my laptop now is determined as TP300LA with the same Serial Number )

I’m pretty sure that there is a bug in BIOS 205 for Q302LA, but ASUS personal do not try to hear (possibly not trust) my humble person.

@tarask1n - I’m sure that reply must come from tier 1 minimum wage workers that do not care, sad to see. Yes, I agree, no need to send it in, confirmation that “other than your system” is affected is this thread (Thus we know for sure BIOS 205 is rubbish)
And we tested 205 fixed just like you did, it’s broken BIOS, I don’t know something wrong with BIOS not working well with ME FW, EC FW, or just the BIOS itself is broke, but clearly you are not alone and there is an issue with 205 BIOS

You can transfer your serial, UUID, MAC ID, windows keys, NVRAM and all that into the other BIOS, but due to moving NVRAM a lot of other edits would also need done (Setup, AMITSE, AMITSE/SetupData would all need swapped as well)
Best to stay on 203 and update it with stuff, if you don’t know how to do that I can do it for you. I can also probably unlock all the hidden BIOS settings for you too, I’ve not looked at this BIOS for that, but it’s my specialty so I’m sure I probably can on this model too.

Once enough people start reporting it to the low-level tech guys they’ll have to pass it along to the BIOS team, then they will find and resolve the issue. Until then, nothing we can do except wait for 206 on this model or update 203 to be better than 205 anyway

@Lost_N_BIOS - thank you very much for your supporting words.
I’ve encountered some difficulty with restoring setup settings for 203 BIOS.
This is the link with dump flash after 205 BIOS update failure. nonwork_205_BIOS
It will be greate if you can help in restoring proper setup settings for 203 BIOS.
Thank you in advance.

@tarask1n - Sorry, I’m not quite sure I understand what you mean/need? Do you need fixed (proper model) 203 BIOS like I made for Techsavvydad?
If yes, please confirm the above linked dump is from your board after the first time you bricked board using 205 BIOS while on 203 before that (ie not other model BIOS, or not programmed in stock BIOSof any version then dumped etc)

@Lost_N_BIOS - Yes, you are exactly right. This linked dump is from my board after failed attempt to upgrade to 205 BIOS.

@tarask1n - Thanks for confirmation, Please give me images of the stickers inside your back casing (if any), sticker on the bottom outside of the case, and images of any and all stickers you see on the backside of the board, be sure to check on, around the memory slots, and under the memory too.
Your serial is removed, and your LAN MAC ID is missing too. See if you can find this in your router logs, it may not be on a sticker

Or, do you have any dump of the BIOS, using any method (even software), before you tried the 205 BIOS??