Asus Rampage II Extreme modding the OROM for RAID

Hi,
After so many web searched and I’ve finally landed in your site and it’s immensely helpful. Thanks for taking your time in composing and releasing these info to the public in an easy to follow format.

I’ve ASUS Rampage II Extreme mobo having WD Velociraptor (10000 RPM) 300 GB running in RAID0 for OS and another 1 TB for storage. I’m planning to add another two 3 TB disks for storage, but the BIOS were not detecting the full capacity but rather just 746 GB only. I guess this is due to the limitation of OROM in my mainboard.

Based on the pass/fail thread I could see Asus Rampage II Extreme has been successfully tested only till 10.1.x.xxxx version. I’ve the following questions now

1) If I’m try to mod the OROM to a later version from RST(e) series PCI ROM modules, say 12.6… Will my mod succeed in the first place?
a) If it fails, will the system POST and I be able to flash the BIOS again to some lower version through USB BIOS Flashback to make my system work again?
2) I’m a bit concerned with the cost of SSD drives, so I haven’t went through that route. So the recommendation of RAID0 stays the same even for normal hard drives?

@ enthukarthik:
Welcome at Win-RAID Forum!

The modification of the BIOS itself may be successful, but I doubt, that an inserted > 100KB sized Intel RAID ROM will work properly with your system, unless ASUS meanwhile has offered a BIOS with more space for the OROM modules.

Yes, I am pretty sure, that you will be able to reflash the currently used BIOS.
In case of a failure I recommend to contact the ASUS support and ask for a new mainboard BIOS, which is able to support > 100 KB sized Intel RAID ROM modules.

Generally the RAID0 advantages and disadvantages are the same with SSDs and HDDs.

Regards
Fernando

Thanks for your input.

From MMTool … which is the PCI ROM size → Source Size or Size in ROM ??

Based on your input

1) The best option is to go with 10.1 version PCI ROM
a) What is the corresponding RST drivers that will provide the best performance for Win 8/8.1 installation?

Uncompressed source size.

It is not the best, but the safest option.

It depends on the SATA mode (AHCI or RAID) of the system drive and the Intel RAID ROM version you get working. You may find some tips within the start post of >this< thread.

I have a Asus rampage 2 extreme, someone has already tried it? I have a new rom file to flash BIOS with 8086-2822_10511070 PCI option rom. Can it destroy the board?

@ olib:
Welcome at Win-RAID Forum!

Please let us know more about your X58/ICH10R chipset system:
1. Which Intel RAID ROM version is actually within the BIOS?
2. Why do you want to update the Intel RAID Controller?
3. Which OS are you running?
4. How many and which sort of HDDs/SSDs are connected to the Intel SATA ports of your board?
5. With which SATA mode (AHCI or RAID) is your system drive running? If it is "RAID", have you created a RAID array? If yes, which sort (RAID0/RAID1 etc)?

Not really, but you may not be able to boot into your RAID array, if the Intel RAID ROM cannot be loaded.

Regards
Fernando

Hello,
1. Bios is 1306 and rom v.8.0.0.1038
2. Because I have two 3TB WD drives, and red if done ctrl + i and disks show only 746.5 GB.
Screen:

3. Windows 7 pro + sp1
4. 6 disks: 1 SSD 128 Gb transcend, 1 Hitachi 160 gb, 2x samsung 640 gb in raid 0, 2x 3tb WD red.
5. I use AHCI

@ olib:
Thanks for the quick answers!

Are you sure about that? Your screenshot looks as if your SSD is running in RAID mode as well (but outside an array).

Yes, I’m sure - I use AHCI mode. Even in raid mode goes SSD well. But the picture is done in Raid mode. When AHCI mode does not work CTRL + I, so I can´t create a RAID
I set in the BIOS as: AHCI mode. In Windows SSD shows me this:

So you’re saying that only RAID array could not work? A board nothing happens? So I could flash back to the old original Bios with original (v8.0.0.1038) PCI option rom file?

@ olib:

AFAIK your mainboard has 6 Intel SATA ports and 1 JMicron SATA port. As long as you connect all your 6 storage drives (5 HDDs and 1 SSD) to Intel ports, you only have the following options:

  1. You set the Intel SATA Controler within the BIOS to “RAID”.
    Consequences:
    • All 6 storage drives (inclusive your SSD) are running in RAID mode and are using an Intel RAID driver.
    • Your RAID0 array is running fine and managed by the Intel RAID Utility.
  2. You set the Intel SATA Controller within the BIOS to “AHCI”.
    Consequences:
    • All 6 storage drives (inclusive the formerly RAID0 members) are running in AHCI mode.
    • You will not have access to the data of the RAID0 array.
    • The Intel RAID ROM module of your BIOS doesn’t matter. It will not be used at all.

In the BIOS I have the following options: AHCI, RAID and IDE. Can you suggest me how should I make it work to the two 3 TB WD went in RAID 0 (5.44 TB)?

The only possibility to get it fully working is

  • a) to have an Intel RAID ROM v10.5.x.xxxx or higher within your mainboard BIOS and
  • b) to set the Íntel SATA Controller within the BIOS to “RAID”.
The only little disadvantage you will have is, that your SSD running in RAID mode will not give you the same performance as if it would run in AHCI mode. Theoretically you can avoid the RAID mode of the SSD, if you connect it to the JMicron SATA3G port, but I do not really recommend it, because the third party SATA Controllers are much slower than the SATA ports, which belong to the mainboard’s chipset.

So I create a BIOS v.1306 with Intel RAID ROM v10.5.x.xxxx. With him I will flash the BIOS. I only have a board with SATA II ports.

Ok. When I wrote SATA3, I meant SATA3G (my bad, it’s already corrected).

Can i use this: Intel RST RAID ROM v10.5.0.1034 or Intel RST RAID ROM v10.5.1.1070 ?
Or can i use the newer than 10.5 … if the problem is with 10.5 …? Thanks.

If I were you, I would try to get the Intel RAID ROM v11.2.0.1527 into the BIOS, because this would be the best option (together with the Intel RST driver v11.2.0.1006).
Nevertheless you should already prepare an original BIOS and a modded one containing the Intel RAID ROM v10.5.1.1070, which can be flashed in case of problems with the Intel RAID ROM v11.2.0.1527.

EDIT:
I just have done a look into >this< BIOS modding success/failure table and realized, that it is obviously impossible to get any >100 KB sized Intel RAID ROM module into the BIOS of an ASUS Rampage II Extreme. The latest Intel RAID ROM version, which works fine with this mainboard, seems to be v10.1.0.1008 (uncompressed size: 85 KB)

Edit:
So only can i try this: v10.1.0.1008 which is 85 Kb and is less than 100 Kb ?

Should the problem and get back to you. So while big thanks. Much you helped me.

Please look into my last post, which has just been edited by me.

You can try any later (and bigger sized) Intel RAID ROM version, but the chances to succeed are not great.
The problem for your system will be, that you may not be able to get an Intel RAID ROM version inserted, which will support >2 TB sized RAID volumes (minimum: v10.5.x.x.xxxx).

I tried delete OEM Logo: 61 Kb. Rom v11.20.1527 has 116 Kb. Rom v.10.10.1008 has 85 Kb. Full bios will be then about 31 Kb smaller.
Is it BIOS (up to 2MB) or the PCI option rom (must be less than 100 Kb) ?