asus ROG h250i with skylake - any way to enable hidden bclk menu in bios?

Asus ROG h250i gaming board
New to this, but I cant help myself with trying to mod stuff. Modded the bios with amibcp5 and flashed it back with AFUDOS from a usb boot stick.

I’ve got a 6500 cpu on this board and was hoping to bclk overclock it slightly.

Using amibcp5, I can see a overclocking menu hidden in the bios but I can not get them to showup on the bios.
Ive tried changing to “user” and “enable” on all the overclocking menu but no luck.

Being a non k chip I understand there is no overclocking of the multi but the bclk should still be adjustable?

This is the bios I’m using atm :…

Any idea would be appropriated

You mean you use AFUDOS from a decade ago, and three entire BIOS series types, to flash a modern BIOS??? Why do people do this!

You probably need to use old or modified ME FW, unsure if B250 ME FW can do bclk overclock. YOu will for sure have to use old CPU microcode.
How high can you push Bclk in windows with XTU? I can unlock your BIOS no problem, but making Bclk work may be huge hassle, lots of testing, reflashing, and in the end may still not work.

Check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Right after you do that, try to write back the BIOS Region dump and see if you get any error, if you do show me image of the command entered and the error given >> FPTw.exe -bios -f biosreg.bin
^^ This is important step, don’t forget ^^

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)…creators-update…menu-windows-10…ator-privileges

Or here is simply registry edit that adds “Open command window here as Administrator” to the right click menu
Double-click to install, reboot after install may be required…134606820377175

Never mind, I checked your BIOS, and the settings for bclk are missing at OverClocking Performance Menu, only label is there or entry that shows you current Bclk.
Nothing you can do here.

Thankyou for your efforts!

The dos flash was very clunky, but after trying a few differnt ways that was the only one that worked. Next time I will use your pointers.

Its a shame that I can’t bclk overclock it as some people with older boards(z170)and h270 are getting 4.3ghz+ from the humble 6500 cpu. But thats how the cookie crumbles.
I’ll check out the old bios for it to see if they have any more OCing code but I guess it is unlikely.

Thanks again - so good to find someone who shares such knowledge .

It’s mainly this chipset holding you back, but yes possibly some BIOS too. You need Z170 or something like that, even B250 is not good for this. So, you are sure some H270 can Bclk OC? If yes, show me proof thread/CPU-z image and what BIOS they are using if you know, I can take a look
If you find old BIOS that still has the bclk stuff there where we discussed let me know, then I can port it back to your current latest BIOS and it may work then (once we figure out ME/Microcodes needed)

@datsfreak - You’re welcome, sorry I couldn’t help though