So it has Bios version 602

- Intel RST

- Vroc

I have a ASUS M2 X16 CARD V2 installed with (4) Intel SSD NVMe setup for RAID 10 with Windows 10 Pro for Workstations

I have been looking around here is everything here to mod the BIOS to the latest?

I would appreaciate any advice or help…thanks…

Latest 0702 bios modded with Microcode 60 and newest Intel raid and lan modules:!MyxhHA7S!Sg0KfvM2dcqFC…v89cFaglYKJK1Oc

Don’t forget to use Asus Flashback to flash the bios!!! The file comes renamed for Flashback after decompressing it…

Thanks…VERY MUCH…The flash went fine and all is working GREAT…THANKS AGAIN…

The only thing is drivers for the…there is really nothing there that matches it?? (YET)

Because it does come up as…in the BIOS…i thought it might be a typo for ??

DISREGUARD…it is…in the BIOS…my eyes…

There’s a 6th generation driver for RSTe in this thread (

Intel RST/RSTe Drivers (latest: v17.5.2.1024 WHQL/v6.1.2.1008 WHQL)

U can also update the firmware of your Aquantia 10G with 3.1.90:…id=4125&lang=fr


Thanks for the information…

How do I keep up with the NEWEST MODULES for the INTEL RAID AND SUCH…I am not sure where to keep an eye out so I know where they are??

U can come to this web to see the updates of the several modules and microcodes…

Meanwhile, this is the latest 0702 with Microcode 64 and newest Raid and Lan modules:!NqYElKLQ!ZS0qazQDxks9P…tZ1yn_VsgUv3Fl0

I thank you ONCE AGAIN for your help…

So I cannot get the Flash to work…

I am using a USB 2.0 32gb and it is formatted as fat32

Computer is off…I put it in the Bios Flasback Port

Press the Button and it flashes (3) times Blue and then just sits there as a solid Blue

I even let it sit like that for a 1/2 hour and then when I rebooted…nothing was changed in the BIOS…

@scorpion Try with another pendrive (capacity 8GB or less).
I got the same issue as you when I used too big microSD card in my USB card reader as Flashback pendrive.

Well the only thing open was Walgreens Pharmacy so I got the smallest 16gb


Thanks for the suggestion…guess I will keep that one for BIOS UPDATES ONLY!!

Is there a BIOS UPDATE for the new Intel RAID ROM/EFI BIOS modules: v17.7.0.4404

With the v17.7.0.1006 drivers?

Here it is:!k6ISGIZJ!CzceB1MiPY0T4…w7opEfR66h9Emug

Includes MC 60 which is a bit better performer than MC 64.

I hope it does not seem like I am just using others help here…at one point I did do BIOS MOD myself
But since I use both VROC and RST I feel a bit better know that sombody with more experience does the BIOS MOD…



You are welcome!!!

Here the mod for the new 0802:!I65H0YRI!oUPNoEVNsqlZV…8-ZgxWOU6Npd1RY

Includes all the latest modules (Intel Raid 17.7 among them) and Microcode 60, which performs better than MC 64 (latest at this moment).

I cannot get this BIOS to upgrade

- Tried a different USB Drive (2)

Is ther another way to do this…

I dont want to mess with the BIOS that is there…do i flip the BIOS SWITCH and try the other BIOS???

@scorpion - test flashing stock BIOS (or previous known flashable mod BIOS) with your USB at hand as it is now using flashback, if that works but new mod BIOS wont, then something wrong with the BIOS you are trying to use
@vmanuelgm - will have to check BIOS possibly, maybe forgot and didn’t put in signed capsule this time? Sorry, I couldn’t check, I can’t download from Mega.NZ 99% of the time


The bios I linked is not the one with HPET parameter made by u, Lost_N_Bios, but the stock one with the latest updates in that moment and MC60 using UBU, so it should work ok.

In my rig I am using the 0802 HPET made by u, Lost_N_Bios, and whenever there is a new update or microcode I use UBU to update your HPET mod without any problems until now.

Only problem right now is the new Microcode 65 posted in this forum (I have a 50654 7980xe) is not working with my OS’s (both Linux and Windows) since they won’t load with it. I have to use previous Microcodes in order to boot the OS’s. The bios does POST without any problems, but OS’s won’t work.

I tried Microcode 65 both in your HPET mod and the stock bios with negative result.


Try another usb pendrive and format it with fat32. The bios file name has to be R6EO.CAP and this file has to be recorded in the root of the pendrive.

I usually follow some special steps to ensure a proper flashing via Asus Flashback, I have been using them several years ago and all the mainboards worked ok in this aspect.


1. Put the bios file with the correct name for Asus Flashback in a fat32 formatted pendrive (usually use trustable brands) in its root. I previously put the pendrive in the special usb port needed for Asus Flashback (there is only one USB port in the mainboard for Flashback so u have to check your manual).

2. Restart and go to bios to load standard settings, then save and exit.

3. I wait for BIOS post or load Windows or Linux and turn off the rig.

4. I then disconnect the power from the power supply, press the switch on button in the case to remove electricity from mainboard, and then press the clear cmos button.

5. I put the power cord and switch on power supply and motherboard, enter bios and load again standard settings, save and exit, wait for POST or load Windows or Linux and then switch off.

6. Then (I previously put the pendrive in the Flashback usb port) I push Asus Flashback button until the bios and Flashback button start to blink, wait until blinking is off and then start the pc again and enter bios and load standard settings, save and exit. The Asus Omega, after a bios flash, will POST and automatically will switch off and on and then u can wait for POST and switch off or load OS and switch off.

7. Finally, remove power cord, clear cmos, put the power cord back, switch on the pc and enter bios to load my OC settings or whatever settings I want.

8. Sometimes the flashing will include some ROG parts which must be updated too, so u have to wait several reboots to go on with the steps.

That’s it!!!

EDIT: Turns out that MC65 is a beta and not intended to be use in normal release bios’s, so 64 still the latest stable one.

Thanks to all…you are not going to believe how "AMATUER MY" MISTAKE WAS" the primary partition on the USB Flash was not marked as Primary so of course I could never BOOT off of it.

So I have taken care of that and marked that USB for BIOS FLASH only…thanks to all…