Asus RX 580 UEFI/ CSM Bug

Sorry when I’m posting off topic stuff here, but I know this forum has some legendary persons registered and my problem might be BIOS related.

Yesterday I replaced my ASUS R9 290 DirectCU II OC 4GB with an ASUS ROG Strix Radeon RX 580 OC. I was wondering why I can access my UEFI but the screen remains black until Windows login so I cleared CMOS and found the affected option. When I enable the option Windows 10 WHQL Support (Default: Disabled) and leave BIOS, every further try to access UEFI will end up with a black screen. I can properly boot to Windows but the screen will be black until Windows is loaded.

There are 5 things I noticed:
1. When I enable Windows 10 WHQL Support, 2 new Options are visible: Secure Boot and GOP Configuration. When I open GOP Configuration there is no option, just a grey Text with “Unknown driver”, "Unknown device"
2. When I enable Windows 10 WHQL Support and leave BIOS, I get a summarization of the changes I applied and an hidden option called CSM Support gets disabled too.
3. With my old card I had no problems while Windows 10 WHQL Support was enabled
4. I have no visible option for FastBoot, but I checked my bios file with AMIBCP and there is an option MSI FastBoot and FastBoot both disabled.
5. The R9 290 has a lower VBIOS version

Also some User on reddit wrote this:



The requirements are given: CSM disabled, card has GOP support, but it’s not working…


Both cards have GOP support, see screenshots, so whats exactly going on here? Can someone help?
Thanks in advance!


EDIT:
My Rig:
CPU: Ryzen 7 2700x
Mainboard: MSI x470 Gaming Pro Carbon (mod version v2.3 (latest) with unlocked cbs/pbs from 1usmus from ocn forum)
OS: Windows 10 Pro x64 Version 1803

graka.PNG

graka_old.PNG

Dump BIOS from both cards and post here, maybe new card has older UEFI BIOS and it needs updated, or maybe old card has GOP and UEFI and new card only EUFI (So you need to add GOP+UEFI)

I used GPU-Z to save bios file of both cards. It seems that the file name is important to identify the codename of the GPU so I expanded the file name.

https://ufile.io/ddouw

You can name whatever you want, it’s OK. Here is info from both BIOS. Both do already have legacy GOP image and UEFI/EFI, so new one should be working like the old one, unless your motherboard has some issue with the new BIOS versions, which it shouldn’t since it’s brand new?

Originalinfo1.png

Original-Info-2.png



I went ahead and updated your 580 BIOS in case that helps, it’s 2017 original version now updated to 2018 GOP BIOS.

Updated.png


https://ufile.io/9d8nc

If that still does not help, you may need to jump in this thread and see if someone can give you some advice
AMD and Nvidia GOP update (No requests, DIY) (44)

Seems to work man. You are the best! :slight_smile:

Sweet, great it’s working! And you’re welcome, happy all flashed well and solved the problem!

Edit: I don’t need this anymore. But just to confirm to anyone who Google’s to get here. This indeed seems to be a problem with the GOP on the ASUS RX cards.

Hi,

I was hoping you would be able to help me too please! I have a very similar card. ASUS RX 580 Dual 8GB. I think that there might be a problem with the GOP on these ASUS cards. I have attached my ROM.

https://ufile.io/8qx5v

Thank you!

@4a6d65 - do you need updated vBIOS still, or not?

If you have the BIOS, I need it…

ASUS RX 580 DUAL OC 8GB

@Je2854 - there is two vBIOS links above, is neither correct one for your card? If not, is your card working OK now? If yes, you can dump vBIOS with GPU-z, let me know if you need help on how to do that.

was looking to see if the Asus RX 580 Dual OC 8GB bios worked? I’m having the same issue on an x58 mobo. The download links for the previous bios updates, up top, are no longer working too.

I ended up doing it myself. This program is great, very easy to use and worked first try!

deleted

deleted


can you help me? i have the same uefi bug, i have an asus rx 580 08gb dual
this is my bios image https://drive.google.com/file/d/1XiiKjsx…iew?usp=sharing
i have tried the gop updater but no help i still cant see bios when cms is disabled. also would the strix bios be able to flash onto the dual oc model?

.

Hello my friend,

I also have the CSM bug with my Asus ROG Strix RX580 TOP 8GB GPU. If I update motherboard BIOS, CSM is enabled and then my screen works only after booting to Windows and to disable, I must replace GPU with an old (9800GT in my case) legacy GPU, disable CSM and then replace GPU. Can you update my firmware with latest GOP BIOS, too? I attach it

@kostas-k your attachment is missing. It hasn’t been mentioned, but all the previous bioses appear to have been modified for mining. Assumedly, yours is the same.


https://www.techpowerup.com/vgabios/?arc…ize=8192&since=

There’s 4 verified vbioses for the TOP model. Take note of the ram type you have (hynix/samsung/micron) and use the appropriate vbios.

Take a dump of your existing bios first just in case

Yuo are correct, forgot to press "Upload"

Here is my file, stock and not modified, if you can update I would be grateful, I have Samsung RAM

On one file, I see version VER015.050.000.001.000000
AS09.bin, while mine has RS06, you think it’s the updated one?

stockRX580TOP.zip (110 KB)

@kostas-k your bios is 67DFHB.15.50.2.1.ASB2

curiously, I couldn’t find any reference of it on the internet. Never seen one that wasn’t AS## either. Maybe the B is beta? Or it’s hex? Did you buy this new or was there a chance the vbios was modified by a previous owner?

Either way, there’s 2 verified t8g/samsung vbioses in the techpowerup vgabios db, and 5 unverified (2 of which are immediately identifiable as modified based on 1750/2000 timings, and another with a different samsung string). Of the remaining two unverified, they vary in temp target (assumedly normal vs quiet vbios).

Do you have an igpu/other gpu or ability to externally flash (eg ch341a+soc8clip) in case things go sideways? If so, it might be easiest to just flash a different t8g/samsung vbios and see if it works for you.

edit: hmm took another look and your bios is for the newer “K4G80325FC” vs “K4G80325FB”