Asus X99 WS/IPMI - All Core Turbo

Could anyone help me enable all-core turbo for my Xeon and Motherboard? I have tried several guides, but none seem specific to this board. There was an earlier post, which looked promising - however the link to download the modded bios is dead. ASUS x99-ws/IPMI Xeon Turbo Mod


Asus X99 WS/IPMI
Bios 4001
Original bios is available here:…

Xeon E5 2695 v3

Pictures Below




I don’t mean to double post, but thought it was worth explaining the bios modification efforts attempted thus far. In short, I’m following guides in detail - but no cigar. The mods appear to take, but CPU microcode version remains locked at the same version 43. See picture below. Any tips?

Work completed thus far:

1. Followed this guide here: [GUIDE] Haswell-E/EP Xeon CPUID:306F2 Turbo Unlock

2. Removed two microcode references from bios

3. Deleted their contents as described in the guide

4. Ran UBUTool to rename

5. Flashed bios using USB flashback

6. Motherboard correctly reported a change in bios, and prompted me to hit F1 to restore defaults

7. Within the bios, and within Windows, Microcode shows no change (still revision 43).

Any pointers?

I am pulling my hair out trying to unlock all core turbo. I’ve tried all the guides that I can find, and spent a whole 12 hours today fumbling around.

I am offering a $10/$15 bounty to whomever can help get all core turbo on my system - guidelines below. This is hard work, so if someone is willing to help out then I think it’s only right to pay for his/her next beer, coffee or lunch.

1. Only one person can collect (whomever first sends the working bios file gets $10)
2. Paid over paypal or venmo
3. Needs to unlock all cores
4. Happy to help or provide more information (I have an EE degree, but am outgunned here)
5. $5 bonus if delivered tomorrow, September 10, 2020 (for a total of $15)
6. Offer expires in two months (November 9, 2020)

Anyone can win, but I am flagging down a few folks that seemed most knowledgeable about my motherboard: @raun0 @Lost_N_BIOS and @jordanpchome

Again, this is my way of admitting defeat and saying thanks to those that help.


@oddworld - I tagged jordanpchome and asked them to re-up that file in the other thread you linked at post #1

In reply to your post #2, if you edited and removed the microcodes for your CPU, then you would not see it show up in BIOS, so something went wrong or was none done correctly at step #2. You didn’t attach your mod BIOS attempt, so I can’t check to tell you what happened there.
Windows is another story on it’s own, you’ll need to stop windows from using and updating to it’s own microcode via this method - Intel, AMD, VIA & Freescale CPU Microcode Repositories Discussion (19)
Or, maybe, from that guide, maybe it’s OK to let windows load out a microcode, and only the BIOS cannot have microcode for your CPU? I’m not sure, but it sounds that way
But, BIOS should not show microcode for your CPU or version 43 if you remove it.

Also, that guide shows removing ALL microcodes, I don’t think that is needed, so I did not do, only removed the one for your CPU.
If you think it’s needed for all to be removed and the BIOS below fail, then I’ll redo and remove all

Here is properly modified BIOS with microcodes removed for your CPUID 306F2.
You will need to either load the v3x4-0.10b-i306f2-rc9.efi/.ffs from USB or tell me you want to use BIOS method and I will insert into BIOS for you if you are not sure how or where to do that.
If you want me to do this, link or attach the exact ffs you want used, I know there is several so I wont insert anything until you link or upload the one you want used. Actually, never mind this, I went ahead and made BIOS for you with this too, from the guide/thread you linked
If you still see 306F2 in BIOS after USB Flashback, then it’s possible that USB Flashback is skipping the microcode areas. If this is the case, we’ll have to dump with FPT, edit, then wipe and reflash the BIOS region…343966871923458

Awesome, thank you. I need to head to the office for a few hours but will be back soon. For now, I wanted to update you about recent efforts to mod the bios (linked below).

1. Took a deep breath, and attempted the modded bios again from the top

2. This was the result (…885559518335882)

3. Would not complete POST (error code 99 = Super IO Initialization). I exclusively used USB flashback from here on out.

4. Removed and reinserted CPU (E5-2695 V3 ES), RAM and GPU.

5. Would not POST again. Hung at code = 99.

6. Disconnected PSU and CMOS battery. Shorted leads to allow caps to drain. Tried again. Hung at 99 again.

7. Removed Xeon E5-2695 V3 ES. Replaced it with Xeon E5-2667 V3 Engineering Sample. See data and specs here in this screen shot.

8. Would not POST again. Still showing POST code 99. Flashed the same modded bios just to confirm no error in the flashing process. Same result.

9. Flashed Asus unmodified bios. All back to normal.

10. The E5-2667 V3 Engineering Sample is still installed. Probably will keep it that way since I need single thread performance right now.

Will be back in a few hours - and very much appreciate your time and assistance.


@oddworld - You’re welcome! I was just coming to add these to my post above >> here is two more BIOS, in these, I removed ALL ucodes for all CPUs, then fixed FIT.…516013885683831
This is similar to the guide, but ucodes not removed in same manner (properly done with MMTool, since both areas are PEI volumes, it’s not ideal to edit those how the guide shows, usually = brick)
I say test the first two I sent you, then if not luck, and or you still see 306F2 in BIOS, try these, then if you still see 306F2 in BIOS we know for sure flashback is not wiping out microcode area and replacing with new (we’ll have do do with FPT)

I am out of time now, I’ll check your mod later, but I assume if you followed that guide this is the issue (PEI volumes should not be rebuilt with UEFITool), so you can’t edit microcodes how the guide shows
Additionally, FIT needs fixed each time you edit the microcodes, which that guide does not even cover. This does not usually brick, but it’s not good to leave it broken (MMTool breaks it too, well, it’s OK but poorly recreated) - So this probably wrong too.
I will check it later tonight and let you know what I see, if anything. I can’t tell if broken due to PEI rebuild, so we’ll just have to assume it’s a brick if you edited the microcodes modules and reinserted with UEFITool, since both modules are in PEI volumes.

And finally, jordanpchome added new link in the other thread too, so you can try that BIOS if all these fail.

Not sure if ES is an issue here or not, but if those run with stock BIOS I guess they should be OK here too, maybe?

I’ve tried two out of three modded bioses. System seems to successfully POST and am able to go into the BIOS to poke around. Upon exiting, I see the windows logo flash and the machine hard resets. Any idea why?

Here’s more detail:

- Deleted DLL files in Windows referenced in your link
- Bios is showing CPU signature 306f2 and Microcode Patch = “Not Loaded”
- Windows hard resets instantly
- Reboots into Windows Repair mode just fine
- Further attempts to boot into windows hard reset

I flashed back to stock bios to eliminate error. I still couldn’t boot.

Windows was pissed that I deleted these:

C:\Windows\System32\mcupdate_AuthenticAMD.dll → for AMD CPUs
C:\Windows\System32\mcupdate_GenuineIntel.dll → for Intel CPUs

I restored the files, and booted fine using the stock bios.

Question - what should I do next to eliminate ucode patching in the OS? I am running Windows Server 2016 1607. It’s basically Windows 10 1607, without the Candy Crush.


I think its working??? I don’t know. Microcode patches are not applied in the bios. Within Windows, they’re showing revision 43. Is that okay?

See the attached stress test. All cores are running at 36x for a few seconds, after which they drop to 35x. Is that normal?

Happy to provide more detail. I flashed @Lost_N_BIOS file (the one that included V3X4).

Finally, @Lost_N_BIOS please send me a PM with details for how to send some cash your way - assuming I actually got it working, and have not lost my mind.

@oddworld - As mentioned, and as you found out, deleting the microcode in Windows may not be required and may be the way you are supposed to load out a microcode for this method to work.
So, glad you figured that out, and put those back And sorry for mentioning initially, I later went back and contradicted that stuff, maybe I didn’t clarify my thoughts as best as I should have on that
You need to load a microcode from BIOS or windows, and it’s skipping the BIOS one that allows this to work.

3 out of 4 BIOS tested does not tell me enough, need to know which BIOS you tested and result of everything too. Also, might as well test the last BIOS too, for sanity’s sake
Then finally, tell me which one or ones are working best/properly, and which are not, so I can more easily do this mod for others later.
I’m asked often, but I tend to shy away because none of the many guides or methods are clear, at all, and I do not have x99 board to play around with this myself.

Yes, from your image it looks like it worked, all cores turbo’d to 3.6, you’d have to disable some power save features and maybe leave others enabled, for it to not go down to 1.x and stay more at 3.6, but that will take you some tinkering to sort all out (or read the long anadtech thread maybe)
Some boards I know disable speedstep, C1E, and EIST, as well as all C states except C3/C6 (Some only C3 needs to be left enabled), some you may be able to disable all C States. I think this depends on CPU gen too, but I’m not sure.
3.5xx instead of 3.6xx is due to the bclk never being/staying at 100.00 exactly anymore, due to ME FW and Intel’s poor decisions

What was your score and how did that same kind of screenshot look before, with just stock BIOS and this CPU, do you have one?
If not, make one with stock BIOS, when you have some free time, so we can compare, thanks

I’ll shoot you a PM, thanks

Just sent $15 and I am now closing the bounty - appreciate your time and assistance.

It sounds like I should play around with the other BIOS files. What attributes or features should I consider when trying to compare them?

@oddworld - Thanks, you’re welcome and I was happy to help!

I mainly asked you to test all four BIOS, to see if they all worked properly, to see if all those methods I used are OK and make this work, or only certain ones.
As for settings, did you make the changes mentioned in the guide linked at post #2? I’d start with those, and then get a stock BIOS test like you linked image of above, then compare same with all four BIOS. Then, if all four work same, we know this can be done any of those ways.
I do assume at least two of those BIOS will not work properly for the all core turbo, unless you load that V3x4 .FFS from a USB. Only the ones with the V3x4 inserted into BIOS should properly load max core turbo, without anything having to be on USB stick

@oddworld - was hoping to hear back from you, but it’s OK and don’t feel forced into more testing than needed here.
But, I would like to at least know your thoughts and testing experiences with the BIOS at post #3 or #5 with FFS inserted, both worked same or not? Trying to learn if it’s OK to remove only 306F2 (BIOS at #3), or if all microcodes need removed (BIOS at post #5)

Sorry - it’s still on my “to do” list. I have one hell of a week ahead of me at work (16 hour days for the next 7 days), so might need some time for me to flash BIOS again.

@oddworld - Ohh, no worries or rush, plus I think you flashed three of those BIOS initially anyway, didn’t you?
If yes, you can probably answer what I need to know now, did the ones with only 306F2 removed work just the same as the ones with all microcodes removed?

That’s correct.

@oddworld - So, what is your thoughts there, do you think either way worked (306F2 only removed = first set of BIOS, or all removed = last set of BIOS)?
I already know we need to insert the V3x4 FFS if not booting with it from USB method.


I am currently running the one with SHA256 hash: 396f760655b8a354f58e1d0672c904addcc8dd4c76ab38c5cf73078eef84047c

Had a hard reset the other day. Not sure whether power settings or other OC issue. If I am honest, I need time to test the others due to work schedule.

Sounds like you also may need to test for stability, with something like Prime95 or other stress tests for several hours, you may need to adjust voltages a little.


Two questions worth running by you.

1. I have a v4 Xeon - any idea whether core unlock is available on it, or does the mod only apply to v3?

I’ve got two of these:

Intel QK3S (E5-1660 v4)
8 Cores @ 3.2 GHz; 20MB L3 Cache

2. Also, I assume there’s no way to uncap the core ratio - is that right? BIOS locks mine to 36x, which I believe is the highest 1C ratio (but your mod applies the ratio to all 8C).

This is all fascinating, and you are a genius.

@oddworld - on V4’ I am not sure, you’ll have to read over at the huge Anandtech thread and see what they’ve said about V4 there.
Same for max ratio, I think they discuss this there, I don’t think there is a way to push it past the Intel locked max, but it’s possible maybe they’ve found a way to do 1-2 bins past there, I am not sure.
Sorry, I have never had X99 board, and have never kept up with this mod, and am only rarely asked to help with it, so I know very little about it

Thanks. I agree with your impressions. Just wanted to make sure I was not leaving core multipliers on the table.

@oddworld - From your testing, and your reading on this subject, do you think for sure this has worked, and that not all cores are supposed to hit/stay at max, or is this supposed to cause all cores to be at max always?
Did you set #3 from this guide to 32, that makes it sound like all would be 32 always. Is that how this is described, and shown in others benchmarking results when you look around at others discussions on this?