Best 7 series Intel MEI driver (best performance) : dual boot system. Now PCI Simple Communications Controller

Which driver is the best for me with the following specs? Just the last one? Maybe I am wrong and I would like to know which one can give me the best performance. However prior to know the driver file, I would like to clarify some things about my Windows 7 setup (I also have windows 10 installed, but regarding the Intel ME issue, this setup is not problematic as the Windows 7 setup)

i7 2600k 4.8 GHz
MSI Z77a GD-65 (z77 chipset)
two ssds, each one with a differente OS:
OCZ Vertex 2 120 GB SATA2 (windows 7 sp1 x64) + Samsung 850 EVO SATA3 (512GB windows 10 x64)

Now my windows 10 SSD is disconnected (not recognized by my system). But it will be likely connected soon.

My ME firmware (I got this info when going into the bios) is Intel ME FW Version (I got some errors when trying to get the version using MEtool in windows 7. maybe cuz i don’t have any Intel ME driver installed in my current work OS → windows 7)

So, do you advise me updating the Intel ME FW version?

Now the Intel MEI device just appears in my device manager (@ Windows 7) as “PCI Simple Communications Controller”. I have tried using MEInfo tool (i downloaded the right one according to my chipset version, 7 series) and it brings me this error message:

It is important to remark that I have my windows update disabled, so maybe that’s the reason I haven’t any driver installed (my setup is a raw w7 sp1 wo/ any hotfix after SP1 ).

(see attached file or follow the url below)

So according to my situation, this error message, and my confioguration (one drive with windows 10, with ME MS default drivers installed):

1) Should I update my Intel ME FW ?
I have read that new Intel ME FW has been released and it brings ME support for Windows 10 (see…1586-1-5mo.html ). I am a consumer user. Is that strictly required? I am strictly using my computer for gaming. Any performance / input lag boost ? I think that this FW update won’t be causing troubles with the other windows setup (windows 7)

2) Which driver should I install? I think this is an easier question :smiley:

thanks in advance

i wait for your help

best regards


Driver: Intel MEI Driver v11.0.0.1167
Firmware: Intel ME 8 Consumer 1.5MB Firmware v8.1.65.1586
All info and links: Intel Management Engine: Drivers, Firmware & System Tools

And yes - you should update to latest firmware/driver…
First install driver then update your firmware!

hello caleb59 and hello to all other forum members,

when i saw the problem skartskard was describing i thought that this is nearly the same problem i have after successfully updating my ME Firmware to Version This means i get error codes when using MEManuf.

I have updated my ME Firmware with a tool-collection found in an asus forum, it is called FTK_0.12.0 because it was not possible for me to update the firmeware with the tools offered in this forum. Maybe this is caused by a bios update i´ve done a few weeks after updating the firmware the very first time to version from The error-message from the manuf-tool is easy to understand, i have no vsccommn.bin-file. So i tried to get some info from the pdf-files included in the tool-collection from section B1. But i dont understand what exactly has to be done to get this special file or where is possibly could be saved on my system.
When i use the me-analyzer it gives me no error-codes, MEInfo too, no error codes.

So, my questions are:
1. Is my management engine ok and working properly?
2. Am i using the wrong tool for getting a passed ok from memanuf.exe?

I would be very thankfull if someone could tell me what i have done wrong or how i could fix this problem because i want to know if my system is ok or if i will get any problems. So far my system is running absolute stable, no issues with mouse or other connected devices. Furthermore i have no yellow questionmarks or something else in the devicemanager. If further info is needed please let me know. I have attached a few files which could be helpfull.

so far best regards

ME-Analyzer OK.JPG


MEManuf error codes.JPG