BIOS Unlock for Gigabyte (Clevo) A7 X1 with Ryzen 5900hx

Dear colleagues,

I kindly request your help on unlocking the BIOS options of my laptop.
It has a Ryzen 5900hx and Insyde BIOS.
Unfortunately the manufacturer has not released any firmware file yet for this laptop so I can only provide BIOS dumps if you could let me know the best procedure to do so.
I have used H2OUVE GUI and have seen there are quite some menu options to unlock.
Please find attached the file results after using BACKUP_Tools.
Could you please advise?
Many thanks

Edit by Fernando: Thread title customized

results20.rar (65.8 KB)

@JessCT
Backup tools are barely works for AMD. I need your bios dump actually to point you how it can be unlocked, or you may just try your luck searching for "Setup Menu Insyde Full Show" setting in H2OUVE.

@Sweet_Kitten
Thanks. I can provide the BIOS dump. Can you let me know what’s the best procedure for doing that? A dump using Dump BIOS ROM from H2OUVE GUI would be ok?

Also, please find below what I have discovered so far using H2OUVE GUI 64:
- Using the load runtime option from H2OUVE’s File menu, seems I have access to my present BIOS menus by clicking on the Setup option and also all I can click on the Variables option and see a whole bunch of variables
- Seems as if I could make some menus visible as by the Setup Menu Full Show here as per the attached image:

Is it worth trying this option? Which process should I follow?

Many thanks for the support

1.JPG

Yes.

Make a variables copy by running “GET VARS” from this archive, share them with me and when I edit them, will send em back.

Much appreciated @Sweet_Kitten
Please find attached the requested file.
Many thanks

vars.txt (143 KB)

And the BIOS ROM? I need it to know which variable is responsible for what.

@Sweet_Kitten
Apologies, newby mistakes.
Edit:
After some struggle they forum has allowed me to post the dump. Please find bios dump
I have used the BIOS dump option from H2OUVE menu.
Many thanks

@JessCT
JessCT.zip. Download, run “SET VARS.bat” and reboot to BIOS.

Many thanks, will try it ASAP.

@Sweet_Kitten
Many thanks for your kind support. The variables mod worked flawlessly.
Now the problem I have is that I couldn’t find a setting for configuring the memory voltage to 1.35 v (I bought new memory modules from Crucial that require this voltage).
Do you know (or any of our forum colleagues) if that kind of setting is possible on Insyde BIOS for laptops?
Now my system is not booting because I tried to increase the memory speed setting without incrementing the voltage so I understand I’ll have to open the laptop and remove the CMOS battery unless anyone knows other possible method to reset the BIOS config.
Again many thanks

@Sweet_Kitten
A new update. After CMOS reset (battery CMOS disconnect) system is again working ok.
I finally found the setting for RAM voltage which on this BIOS is VDDIO and also VDDP may have an influence. Now VDDIO is 1.35 and VDDP is 0.950 and system is booting correctly with the JEDEC memory settings at 2666 Mhz.
Now problem is any modification I do on memory timings, causes the system to hang and not being capable booting into BIOS and hence forcing a CMOS reset.
Even modifications made to relax timings even more cause the hang. For instance, keeping JEDEC settings of 2666 Mhz and CAS 19, I relax the CAS to 20, the systems hangs on boot which leads me to think there’s some issue with the memory training even when making timings more relaxed.
Does anyone have experience on this?
Many thanks and regards

Dear friend,
Thanks for rising this wonderful topic.
I got this A7 X1 two month ago, the only thing I complained is it’s bios.
It is too shallow, only a few options we can select.
And most importantly, it seems not supporting S3 sleeping, but only go S1 which means only the monitor gets turned off. Also in Windows control panel there’s few power options, we can not choose max or minimum speed.
You posted you could now unlock some of the bios options, how it goes with the problem? Can you upload the new bios files and let us know how to install it, please? Many thanks.

ACPI S3 is disabled in this BIOS by deafult.

This is not that simple.
Most manufacturers now use protection in their devices to prevent its firmware from being changed. And Clevo is no exception. Therefore, the process includes purchasing a hardware SPI chip programmer, reading chip and sending its contents to me for modification. But if you do not need to unlock the entire BIOS, but only change one of the settings, you can just use the H2OUVE utility to manage them.

Thanks Kitten.
Now I understand why Gigabyte has got no plan for bios update at all.
I will seek more information on the chip programmer and H2OUVE tools and try to understand how they work.
Thanks again and I might need your kindly help in the short future.

Gigabye BIOS file here,

https:// 1drv.ms/u/s!AgRAMt-pCwg7kJtQzQqqR58pFQOOIg?e=3lgtPd

Hello, thanks for the tool, unfortunately I change a parameter in the bios related to the sata controller and now the laptop refuse to post.
I disconnected the battery but the laptop refuse to post.
How long does the battery needs to be disconnected? Else how do I manually flash a working bios?

Can I flash a bios directly to the chip using a spl programmer or is not possible.
Sending the laptop for rma is quite costly given that I’m not in the us


Thank you

Hi All, I have just checked and realised that Gigabyte have an update of the Bios version ( FB08 ) (see below), can anyone work using this file and unlock the bios option?

Many thanks in advance.

nb-bios-win10-win11-64bit-Ax-FB08.rar (11.7 MB)

@Sweet_Kitten Could I trouble you to look into my post and see if you can assist on this, I believe this will greatly benefit the community here.

Thanks!