black screen after bios downgrade

i posted my issue in a lot of forums and i didn’t get any help i hope i’ll find it here because i’m stuck without my laptop. well:
i tried to downgrade my lenovo Y7000 2019 PG0 gaming laptop’s bios which was the bhcn41ww to bhcn27ww the downgrade went without no issue but after first startup i got black screen and only power led and fan running nothing else. i tried to resolve the problem with removing CMOS battery and doing the drain (20 seconds holding power key) with no success. i heard about bios recovery using crisis tool or recovery keys but didn’t find nothing about the Y7000P 2019 laptop. by the way the bios backflash option was checked so i’m sure it’s not downgrading issue. 
when i try the crisis recovery method using combination fn+r and usb stick with bios renamed as bhcrisis.bin or crisis.bin or bios.bin i got nothing but a usb stick blinking and power led orange that all. so don’t know if i miss something about the filename or extension that i should use because i tried many as .bin .wph .cap and nothing happened
please could you help me with that i will really appreciate it as i’m working on board i can’t even go to customer service or something

Ok friend, pont me to your stock bios link please …

hello my stock latest bios working was the bhcn41ww.exe do you want me to send you link of that ??

I have got it , so there is a Bios Recovery Name :


You can try to rename the original bios .fd as .bin , then put it into an USB stick FAT32 format bootable (use Rufus to prepare it) and then
try the Recovery procedure :

Remove AC plug

Insert USB stick into USB port

Push Fn+Esc keys and keep pushed (I suggest to use the right hand)

insert AC plug

press power button (the laptop should power up immediatley) and release it

release Fn+Esc keys

The laptop should start in the same mode as previous state, but seconds after you should see the USB drive LED turning ON, then starting blinking.

If all the process is right, the new BIOS will be automatically flashed.

Just wait that the process ends, the internal FAN should stop and the laptop turn OFF.

Prefered left usb port.

Files :…cn41ww.rar/file

If it will not work then only asn SPI Programmer with Pomona Clip can rewrite you firmware back.

@BDMaster thanks friend i will give it a try. but just one thing is it the fn+esc or fn+r because when i use fn+r i get that power led turns to orange so i tought this is the combination i should use to go to recovery mode ? what do you think .?
well concerning spi programmer i have already ordered one CH341 + clip just in case but it will arrive in two months from now that’s why i hope a soft method would fix it ar first place

@BDMaster i found in the folder you sent me BIOS.FD and BIOS.FD.ROM which one should i use ? and should i rename it to BHCRISIS.BIN or BHCRISIS.FD or let it as it is BIOS.bin ??

@BDMaster unfortunately it didn’t work for me this method i tried all three files using filename BHCRISIS.BIN nothing happened only usb stick blinking for while and the power led goes orange blinking that’s all.

So you have to buy an SPI Programmer CH341A with Pomona Clip and then we can reflash the firmware, whrn you will get it let me know …

Here You can see the examples :…341A-programmer


thank you so much i have already ordered one. i will even look for it here in belgium outside if i can find one. i will let you know for sure

@BDMaster hello my friend i’m about to buy ch341a spi flasher i’ll be glad if you give me all instructions and files needed to flash my bios
the model i’m about to buy is in attached pic
thanks sir


Have upi got it ?

Then You have to download the ASprogrammer vers. 1.41 from here :

Make a Firmware Dump (copy) over all and upload it for me …
don’t erase nothing , but only read Eeprom and save the contents …
Let me know

i will do it in few hours friend i’m going to buy it now from someone i will let you know

@BDMaster hello my friend how to make a dump with asprogrammer ? Is it with "read" option ? And what should i name the file extension …??

@BDMaster well i’m trying to anticipate hehe. I have read the bios and saved as .bin file if it’s that what you need my friend…ew?usp=drivesdk

Ok friend,
it doesn’t matter the file extension (bin, rom, etc.) , it’s important the contents, you have to read and verify the Firmware Dump.
The HexEditor or UEFITool will read anyway the file :wink:

@BDMaster well my friend this is what i dumped in the first place maybe that is what you need
This is the link…ew?usp=drivesdk

Ok friend,
i cannot find a dump , it is on sale on relative sites, but i can give to you the original stock file :…IOS.fd.rar/file

your dump are unusefull as it has to be 16.384 kb

Let me know if this make to boot your laptop …

@BDMaster unfortunately i get error message when i try to read IC ID and it says as in the picture using ASprogrammer, i don’t knw what to choose as IC model
when i tried programming with CH341A Programmer software i get error message too it says "write operations timeout"
so what should i do to resolve this issue

i cant send private messages but that tool you gave me wont run on my laptop, I have a Predator PH317-54
here’s the dxdiag info
System Information
Time of this report: 5/25/2021, 18:27:38
Machine name: LAPTOP-T9OMHILP
Machine Id: {07DE13EB-9CF6-484B-A33A-803AA297FB8C}
Operating System: Windows 10 Home 64-bit (10.0, Build 19041) (19041.vb_release.191206-1406)
Language: English (Regional Setting: English)
System Manufacturer: Acer
System Model: Predator PH317-54
BIOS: V1.04 (type: UEFI)
Processor: Intel(R) Core™ i7-10750H CPU @ 2.60GHz (12 CPUs), ~2.6GHz
Memory: 32768MB RAM

thank you very much man, i appreciate your help from the start untill we fix it, i have fix it using the file you uploaded, it’s working now and i’m writing this reply from my laptop