Can a modded BIOS solve the Invalid SN of Lenovo Legion Y740

Sorry for my English as it is not my native language.

I’m facing the is with SN and Product number on my re-owned Y740.
As it’s out of warranty, I could not bring it to the genuine services for re-writing the SN and Product number.

I made some searchs and also made some bootable tools on the USB but most of the tools I found on the Internet were for the Thinkpad system.

therefore I wonder if I could write the SN and PN in the bios then flash it into the system?

Thank you in advance.

you actually dont need to mod the bios for this, lenovo is consistently half assing setting the variables when they do a motherboard replacement which i’m assuming happened to yours before you got it. you can use a tool called LVAR from lenovo.

Here is LVAR:

extract then use admin cmd prompt to cd into the directory you extracted it to, from there you can run LvarWin64V229.exe and it will output a list of available commands and variables. below is an example for setting model name of a Legion 5 (not your model)

to read current value:

LvarWin64V229.exe /r /pn 

to write new value:
LvarWin64V229.exe /w /pn /c "Lenovo Legion 5 15ARH05"

reboot after and thats it, if you go into bios and the info section shows "INVALID" on anything you'll need to correct those as well.

Thanks for your kind reply.

I dont know why I could not reply with a quote.

I tried the method but it returned the "Other error" after each CMD line.

What I tried:
- CMD run as Administrator
- Tried both /r and /w commands but they showed the same results of "Other error"
- Tried the 32bit lvar and it even did not show any response.
- Tried the older version of lvar I could find on the internet but they returned the same result

Please, any further hint to my situation?


disable secure boot from bios first, then try again. i forgot to mention that before. you can always enable secure boot again after edits if you like


Thank you for your fast response.
I tried disabling the secure boot but seem the same problem persisted. I disabled it in the bios as in photo. Did I make a mistake in the disabling process?

im not sure, that tool should work for you. see if admin powershell shows any further info/error. also try both the 32 and 64 versions of the exe, both are in the same folder.

edit: also, does it show you the help info if you just run the exe without any flags like this


| Lenovo Variable Tool |
| v2.26 Lenovo/LCFC 2017/08/18 |
LVAR.exe /? This help screen
LVAR.exe /? /v Display supported variables
LVAR.exe /r /xx Read xx variable and display it
LVAR.exe /r /xx /f 1.bin Read xx variable and save it to 1.bin
LVAR.exe /w /xx /f 1.bin Write 1.bin to BIOS
LVAR.exe /w /xx /c "1234 5" Write string "1234 5" to BIOS
LVAR.exe /w /xx /b "12 3 ab" Write binary data 0x12, 0x3, 0xab to BIOS
LVAR.exe /d /xx Delete xx variable
LVAR.exe /l /xx Lock xx variable, make it read only
LVAR.exe /u /xx /c "Password" Use "Password" to unlock xx variable
LVAR.exe /m /xx "1 a 10" /c "A0m"
Modify xx variable offset 0x1, 0xa, 0x10 (1 based) to data A, 0, m
LVAR.exe /m /xx "1 a 10" /b "11 00 ab"
Modify xx variable offset 0x1, 0xa, 0x10 (1 based) to data 0x11, 0x00, 0xab
Press any key to continue...

Yah the Help screen did show. But the /r and /w command came with Other error on 64bit exe. On 32bit exe it even did not respond.
I think I will re-install the windows and test it again :frowning:

@ndthtnt - Here, try this, drop in same folder as original LvarWin64V229.exe -…266324279333579
Use LvarWin64V229Mod.exe in CMD’s, see if “other error” bypassed and lets you do what you need.
I bypassed “other error” in this edit, so it will not go there now, should either proceed and or give you new error
I could not tell what would cause it to go to “other error”

You may need to use EMUEFI.EXE here instead?
@dglt - please upload package of that for him, or if you do not have let me know and I will upload

It may have to be dumped BIOS, edited, then flashed back.
Please add image of BIOS Main page. What caused this, or did you get the system and it was like this already?
Is ME FW functioning properly? Can you see ME FW version in BIOS main page, or with HWINFO64?

@Lost_N_BIOS i never used EMUEFI before so i dont have it. as for LVAR this is the first time i’ve ever seen “other error” show up, i’ve helped 5-6 people fix variables after mobo replacements myself included. lenovo seems to do this on all of them and leaves most of the info either blank or just incorrect.

@ndthtnt i did a read on all possible variables so you can get an idea of the format, i posted all commands and outputs here in a pastebin

@dglt - Here you go, it’s similar, but used for some other models (not sure what all can/can’t use this). You can set SN (have to edit batch file, or give him example command), and you can also set MFG state with this too
Here’s that tool and another tool set (maybe from you?) You have to use XP or DOS to make USB w/ those tools, but I already pre-extracted everything too…118246702250068

Yes, I’ve never seen “Other error” when anyone is using this tool either. Have you seen anyone use on this exact model before?
He wont/can’t get that “other error” with the above mod file I posted, but unsure what outcome will be now, some other error, or it will proceed with the changes?

@Lost_N_BIOS @dglt
Thanks for your help and sorry for being slow in responding due to some workload in the office time.
This condition was before I received the machine, therefore I really don’t know the exact reason(s).

I ran the CMD with new modded Lvar and it did show “Success”. However, after the reboot, the /sn and /pn were still not updated, just said “Invalid” as before.

What I did before testing with the modded Lvar:
- Disabling Secure boot
- Check the ME FW: it showed “12.0, Build 1307, Hot Fix 20” with HWInfo64, but no similar line in the main page of BIOS
- Trying running the /r /sn and the CMD showed lots of line with 0000000000000, not showing like “Not Found” as in the pastebin of @dglt . I don’t know if this is normal or strange therefore I also list it here.

I attached the photos of my BIOS and commands (I did rename the modded exe to lvar.exe for easier command. Both the original name and “lvar” performed the same result). Hopefully I could get further instructions from you :frowning:
THank you a lot.



@Lost_N_BIOS ive seen it working on Y740, a couple ideapad’s both intel and ryzen, a y520 and my legion 5i. i’ve never seen it return a bunch of zeros like that before either. is there possibly another bios option that might be interfering with the tool? platform trust/tpm? fastboot cfg lock? bios lock?

i know in my bios dump i can see these variables but tbh i dont know how manually editing them that way would work or if it would cause checksum issues, you would probably know that. this tool should work on that laptop, it works on the non-gsync model of the same laptop so it must be something else getting in the way.

have you upgraded or downgraded bios at all since owning the laptop? (if not you could try going up or down to a different version, and try again)
have you tried resetting bios to its defaults >> reboot >> disable secure boot >> try lvar again?

also, the number your trying to set as the serial number in your pictures is not meant for /sn which is a different number entirely and its longer. the serial number your trying to set belongs in /ln


C:\Users\mwf43\Downloads\AFTER-MOD\LenovoVariableEditor\LVAR>LvarWin64V229.exe /r /ln
00 01 02 03 04 05 06 07 - 08 09 0A 0B 0C 0D 0E 0F ASCII
------------------------------------------------- ----------------
00 |50 46 32 39 48 45 47 53 - PXX9XEXS ###(serial number you use on lenovo support)

try this:

##write the value with
lvar /w /ln /c "MP1NN7V1"
##then check the value right after with
lvar /r /ln

does it apply?

EDIT: @Lost_N_BIOS , does this look as if someone might of flashed the bios chip using the bios binary extracted right from the bios update(doesnt contain descriptors)? would that explain the descriptors being set to zero's?

@dglt thanks for your patience.

About the BIOS upgrade, I have upgraded and downgraded some BIOS versions but they returned the same result. I also tried restoring default value then disable the secure boot but again the same rusul came.

I also just reinstall a fresh windows 10. The problems were exactly the same as before (for both original and modded lvar) therefore I don’t think the problems came from Windows.

I could also use the laptop normally yet the benefits from Lenovo apps like the Vantage, Sense, etc were limited as it thinks mine is an ideapad.

Is there any further method that I could try on my machine? :frowning:

wait for Lost_N_Bios to respond, outside of using LVAR for this purpose i wouldnt feel comfortable telling you to try any other methods i’ve never tested myself. im wondering if the last owner just flashed the binary file from an update exe since you seem to be missing every variable, not just serial number. im guessing gsync probably doesnt work either? your model should have it since the model number ends in “g”.

you might want to grab the intel firmware flash tool and do a bios dump and link it here. do you know anyone else with the same exact model you could ask to do a bios dump, it would probably be easier to change only the serial number from a working bios than it would to figure out and populate your bios with all the correct info. also, i think vantage uses the SKU string to identify models. i also had to fix this after lenovo replaced the mobo because i too got stuck with the ideapad version of vantage.

in addition to doing the bios dump, can you grab RWEverything from here and use it to read SMBIOS structure, then save it and link that here. here is an picture of what i mean

@dglt Thanks for your reply.

Yah my G-sync does not appear in Nvidia control panel despite I changed to Discrete GPU in BIOS.

People I know don’t have the exact model like mine. They just use ROG or Alienware :(( Therefore a bios dump from a working Y740-15IRHg could be so hard.

Let me link my SMBIOS Structure here. (11 KB)

@dglt - Yes, probably, someone programmed BIOS with stock image, or some “Dump” someone said was a dump online but was actual fake dump made with stock image.
Best thing to do here since all is failing is dump BIOS, fix serial/UUID etc directly manually, then program back in. For that, we will need another users dump and to know that persons system info too.
I will ask only user I’ve helped with this model below, if either of you know someone else too, best to ask if they can help as well in case user below does not reply back.

@Hirosake - Can you help us fix this users BIOS here, by providing me an image of your BIOS Main Page, thanks!
You can send in PM if you want to keep your info private, but please do not blur out info, that’s what we need to fix here and I need to see your info to find in BIOS where it’s stored and how

funny, i was just thinking about hirosake with the same model. i know him from elsewhere on a legion discord, good guy

the smbios info is devoid of any identifiers


[System Information] (Type 1)
01 1B 01 00 01 02 03 04 EA F2 25 1F 29 3B E9 11 ..........%.);..
8B B6 9C 5A 44 2D 70 97 06 05 06 4C 45 4E 4F 56 ...ZD-p....LENOV
4F 00 49 4E 56 41 4C 49 44 00 49 4E 56 41 4C 49 O.INVALID.INVALI
44 00 49 4E 56 41 4C 49 44 00 4C 45 4E 4F 56 4F D.INVALID.LENOVO
5F 42 49 5F 49 44 45 41 50 41 44 42 56 5F 42 55 _BI_IDEAPADBV_BU
5F 69 64 65 61 5F 46 4D 5F 49 44 45 41 50 41 44 _idea_FM_IDEAPAD
00 49 44 45 41 50 41 44 00 00 .IDEAPAD..
Type 0x01 (1)
Length 0x1B (27)
Handle 0x0001 (1)
Manufacturer String1 - "LENOVO"
Product Name String2 - "INVALID"
Version String3 - "INVALID"
Serial Number String4 - "INVALID"
UUID 0xEA 0xF2 0x25 0x1F 0x29 0x3B 0xE9 0x11 0x8B 0xB6 0x9C 0x5A 0x44 0x2D 0x70 0x97
Wakeup Type 0x06 - Power Switch
Family String6 - "IDEAPAD"

[Base Board Information] (Type 2)
02 0F 02 00 01 02 03 04 05 09 06 03 00 0A 00 4C ...............L
45 4E 4F 56 4F 00 4C 4E 56 4E 42 31 36 31 32 31 ENOVO.LNVNB16121
36 00 4E 6F 20 44 50 4B 00 49 4E 56 41 4C 49 44 6.No DPK.INVALID
00 4E 4F 20 41 73 73 65 74 20 54 61 67 00 54 79 .NO Asset Tag.Ty
70 65 32 20 2D 20 42 6F 61 72 64 20 43 68 61 73 pe2 - Board Chas
73 69 73 20 4C 6F 63 61 74 69 6F 6E 00 00 sis Location..

i know a couple others with this model i can ask as well, does the region the laptop is meant for matter or is that something you can easily fix with a quick edit?

@dglt - I can’t comment on any of this until I have dump + Sys info so I can see what is where.
But to your last question, if you mean region as in where in the world, no that does not matter for this, only that it’s Y740

not sure if your aware but MP1NN7V1 shows you still have 15months of warranty, the previous owner must of got the extended plan. however, even if they repaired it you’d probably still need to fix variables since they seem to screw this up 100% of the time

your product page:…002yrm/mp1nn7v1

@Lost_N_BIOS i feel dumb, i actually have a dumped Legion y740-15IRHg bios from someone i was helping a few days ago. just a sidenote, this person changed a setting in advanced bios that made the bios menu unable to use the keyboard so im just letting you know. other than keyboard not working while in bios the system functions properly, i ended up resolving it use h2ouve vars but this dump is from before it was resolved.

i sent this person a message to get a new dump that isnt flawed, when i hear back i’ll post it but here is the above mentioned one for now .

edit: wrong link, here…310619780365509

EDIT 2: here is a clean fresh bios dump from a fully working system, no caveats.

clean working bios:…123935969296584

the dumped bios is version BVCN12WW in case its needed for whatever:


This what you needed? @Lost-N-BIOS