Can a modded BIOS solve the Invalid SN of Lenovo Legion Y740

@dglt - I remember that user/thread you’re talking about (locked myself from BIOS)
But, I can’t use their BIOS without knowing their system info, so it’s not really any help for now.
I think all I need Hirosake has given below We’ll just have to see if this model can be BIOS region flashed with FPT or not.

@Hirosake - Thanks, yes, that’s what i needed, thanks for the quick reply!

@ndthtnt - Please do the following, in order as shown -
Send me file from FPT Spoiler step #1 + Vars all in same max compressed zip, and let me know what error you get at FPT spoiler step #2
Also, let me know what BIOS version you are using, and link to the download page (not direct BIOS download), thanks

If you have already modified the BIOS in ANY way, you will need to re-flash it back to factory defaults using factory method (NOT FPT)!!!
Additionally, please remove all BIOS passwords, disable secure boot, and disable TPM or Encryption if you have enabled. Do this before moving on to below

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Step #1

Now you should be at the command prompt.
You are going to BACKUP the factory un-modified firmware, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "

>> Attach the saved "biosreg.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Step #2

Right after you do that, try to write back the BIOS Region dump and see if you get any error(s).
Command: " FPTw.exe -bios -f biosreg.bin "
^^ This step is important! Don’t forget! ^^

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

If the windows method above does NOT work for you…
Then you may have to copy all contents from the Flash Programming Tool \ DOS folder to the root of a Bootable USB disk and do the dump from DOS
( DOS command: " FPT.exe -bios -d biosreg.bin " )

Please download the following package, and run the command below from each versions folder that directly contains it’s exe.
Before doing this, make sure you have secure boot disabled in BIOS, any BIOS password removed, and TPM/Encryption disabled.
Once done, copy the entire folder somewhere, delete everything but any created vars.txt and then repackage this and send to me.
This way all created vars.txt remain in place in the folders of the version that created them.
There may be errors, not all may work, ignore and carry on as outlined…212104496994806

H2OUVE.exe -gv vars.txt

I try dumping the BIOS using FPT (12). The bios dump is successful but seem flashing it back faces error of Protected Range Registers.
Here’s the attachment of BIOS dumped and the error logs. Please have a look or suggest me further steps I could bypass it. Thank in advance.

FPT flashback error.png

FPT bios.rar (3.82 MB)

@ndthtnt - Yes, this is expected, please be sure you do everything exactly as mentioned in the spoiler
Then do both spoilers and upload ALL the files for me as requested, in a single archive, thanks
Bypassing error at FPT step #2 will come later, need to do all this stuff as I outlined first

You have to slow down, none of this stuff is important for anything, so no need to be in a hurry about anything here

I’m really sorry for missing your comments (around 10 latest comments, dont know why the thread did not show them when I F5) therefore I was a little out at my last comment.

Please find my Vars in the attachment. Hopefully I made it correctly.

Thank you in advance.

H20UVE.rar (64 KB)

@ndthtnt - It’s OK My main concern was that you did everything mentioned in the FPT spoiler FIRST!!! >> Disable Secure boot, TPM, remove any BIOS password, then proceed with FPT step #1-2, and then vars dump.
Did you do all that before you made the files attached at #22 + #24?

@Lost_N_BIOS Thanks for your super fast reply.

I did check Secure Boot, BIOS password and being pretty sure that they’re disabled. For TPM, could you have a look on my photo (cmd tpm.msc). I though it mean not activated but after you reminding the TPM I was a little unsure. It’s much different from what I could find on Google where images there showed the correct state of On or Off.


@ndthtnt - You’re welcome! Pretty sure does not work here
You need to be 100% sure, otherwise we’re wasting time, because you’ll need to redump ALL that after changing those settings, if you did not do it first.
I mean, you have to do the following, BEFORE you dump vars or do FPT stuff
1. Disable secure boot.
2. Disable Encryption or TPM if enabled in BIOS (only care about this in BIOS, if you don’t see a setting for it, then ignore this step)
3. Remove any BIOS password

Then dump vars, and do FPT stuff. So, all this done BEFORE you did 22+24 above, or not?
Still, also waiting to know what BIOS version you are using and for you to link me to the BIOS download page


Thank you for your instruction.

There I’ll process and check them in the bios screen after work. As I’m at work now therefore I searched that way of checking TPM via Chrome remote (as I could not access the device).

It was a bad decision not to bring the machine along with me when I went to work :frowning:

Ohh OK. Yes, best to check all this when you are at the system, then redo vars/FPT stuff if you have to make any changes in BIOS.
Please see my edit at #27 (about BIOS version/download page)


Sorry I missed that in your above comments.

My BIOS version is BVCN12WW.
The BIOS page from Lenovo just listed the latest version (BVCN14WW):…egion-y740-irhg
However, we can proceed the download of BVCN12WW by changing the 14 to 12:

Thank you

Hi @Lost_N_BIOS

I had checked the Secure boot, TPM (on my BIOS it shows TPP), no encryption and BIOS password before proceeding the extraction. Please find my BIOS dump and vars file in the attachment.

Thank you. (4.06 MB)

oh my bad, sometimes i get ahead of myself, i read the part about needing a dump and totally missed the part about needing the bios info screenshot. i sent that user your talking about here when i couldnt figure it out myself but i ended up figuring it out later.

@ndthtnt - Thanks for new files and confirmation -…804062200616626
Now, take this modified vars and drop in the H2OUVE_100.0.9.2 folder, then run this command >> H2OUVE.exe -sv varsM.txt
There will be long list of success/failure, reboot once it’s done, and then in windows redo FPT spoiler step #1-2 again using new file name (such as biosregnew.bin)
Do you still get error at #2 now? * Edit >> You shouldn’t, since dglt already confirmed vars mod unlocks mod BIOS flashing
So, then upload the new file from #1 for me

If you do still get error, this is last thing you can safely try, before having to get a flash programmer (CH341A + SOIC8 / SOP8 test clip w/ cable)
Put system to sleep (S3), not hibernate or suspend, then wait 2 full minutes, wake it up and try FPT #1-2 again using new name (such as biosregsleep.bin) and see if you can pass #2 without error stopping you or not.

If we can flash mod BIOS now,
do you want info fixed + unlocked BIOS menu, or just info fixed?

** Did you add/insert this value? >> 5421435100032

@dglt - Yeah, he said you got it sorted after a few more edits, right before I replied to help him
Did he have unlocked menu already? If not, how, and what did he disable that caused that?

@Lost_N_BIOS Thanks for your help even in new year day,

After run the CMD with the VarsM.txt, I then could run step 2 in FPT without error.
Please find the new BIOSregnew.bin in the attachment.

For the value of 5421435100032, it’s strange to me therefore apparently not my input. => EDit: This is the value on my sticky stamp at the bottom. But just the value alone. I don’t have the idea what it is.

For the unlocked BIOS, I had a weird question (that I could not find the answer on G): could I return to another version of BIOS after unlocked it? I mean the BCVN08 => BCVN09 (1.05) as it allows me to use the shortcut of FN+Q to control the performance profile.

Thanks again for your help. Wish you the happy new year. (3.98 MB)

advanced bios on that model can be accessed with a key combo, his problem was that he could use his keyboard in windows but not in bios, and i went through every setting that might be related to the keyboard in the advanced menu but flipping them with vars didnt fix it, i tried triggering a bios reset to defaults with vars but that didnt work either. i ended up disabling FPRR and bios/cfg lock with vars, put as much as i could find back to defaults and had him flash it back >> reboot without going into bios >> install the earliest bios version i could find from lenovo hoping it would install and work afterwards and it did. i wont claim to know exactly what change did it though, im still a blind squirrel searching for a nut when it comes to bios stuff.

Hi @Lost_N_BIOS , I wonder if I missed any file in providing you and is there anything I could proceed now?
Thank you.

@ndthtnt - Happy New Year to you as well!! Sorry for the delay, always busy and buried here, thanks for bumping the thread!
This 5421435100032 must be your serial then (not Lenovo serial) As for unlocked BIOS vs stock BIOS and going backwards in BIOS versions, I don’t know anything about that, sorry.
I can only assume if stock BIOS wont let you, then unlocked BIOS wont either, unless there is a BIOS Downgrade setting, and then you could change it to allow (if there is this, we can do anytime via single edit to BIOS, or we can change via vars edit too)

I checked, and there IS a setting >> BIOS Backflash (disabled by default) in the “Configuration” menu. Can you already see this menu? I think you can see it, based on other user image of “Information” page
If yes, and that is all you’re concerned about (ie don’t need Advanced menu in full, w/ overclocking section for everything), then I can just make this setting visible to you, so you can use it when needed to downgrade BIOS version.
So, for now, I will leave menu alone but make this setting visible to you If you want unlocked Advanced menu, let me know later/next

Great to see you can now pass FPT step #2 First, lets get some of your info back in there and see if the rest auto-populates or not (ie windows key stuff)
Ohh wait! Sorry, I thought I already had from you… I need images of ALL stickers on the bottom of case, inside bottom case, any stickers you can see on board too (need to try and find your MTM # if possible)

@dglt - Ahh, thanks for the info! I was confused how he got into that situation, and then it was fixed so he never gave more details or answers to my questions etc
Yes, must have been some USB/EHCI/'XHCI setting was changed, causing the KB to fail in BIOS. Nice job getting it all sorted out for him though

@Lost_N_BIOS thanks for your reply. Appreciate your hard work :smiley:

For the backflash, I meant: if you help me unlock the BCVN12, will the unlocked BIOS menu persist when I try backflash it to another version. I updated to BCVN12 as I saw the provided working BIOS being at BCVN12 therefore I did to avoid the risk of mismatching version, however IMO the BCVN08 => edit>> BCVN09 is better.

Let me tear the device down for the stamps and make the quick reply now.

@ndthtnt - You’re welcome! No, if you backflash, then we’d have to dump that BIOS again and then unlock it.
If you want to be on some other BIOS, go ahead and flash to that and make new dump and send to me, then I’ll fix info in that BIOS instead (and unlock, if you want)
OK, I’ll wait on the images, sorry you have to tear it down again I was hoping you already had them taken and just hadn’t mentioned

We also wont be able to get Windows key to work, I assume (it’s blank now anyway). It may auto-populate once other details are properly filled in, but I’m not sure.


Sorry for not having prepared the info before, as I’m really noob at hardward technique.

I’ve captured all the stamps I can find on the bottom, inside the bottom and on the board. However, I could not proceed more to lift the motherboard due to the mismatched screwdriver and the inside screws, until I get home. I hope the MTM was included in the images or even better if it could be autofilled.

It’s strange that there’s a phrase of “FLPR5010002” inside beside the serial. And even I could not find the “MP1NN7V1” in any stamp inside. The outside stamp is in handwriting, which is popular/normal in my country for a pre-owned machine sold by shop. However I could not find the print numbers from manufacturer. And neither windows key found there. I suspected there’s something wrong with my machine parts.

I attached the 1.05 bios dump, and the images. Hopefully you can have a look and tell me if s.t is missing/required so I could bring the Vantage and g-sync to work.

Wish you a good day.

Edit: I’m uploading the image zip as it’s larger than 6MB. Please find the new link:…iew?usp=sharing (3.97 MB)