Can EFI module version affect GPU performance in Windows?

First of all - hello to everyone. This forum has been a great source of information for me - but now I got a problem I cannot solve with the information I found on the wb - hence this topic.

I have recently switch my GPU from MSI R9 290 to Evga GTX980 SC and I am seeing lower pefromance - which is not what I expected, based on the reviews I found on the web. I am seeing 100% utilization of the GPU while gaming, but the pefromance is not there. I believe I have tried everything I could regaring the OS and drivers (see below). Now my attention focued on the motherboard (Lenovo Mahobay - which uses AMI bios) - the main question is (as per the topic) - Can the EFI module affect GPU performance in Windows, or is it only a driver that is being used on startup?

My machine is based on Lenovo Thinkstation E31 I got cheap.
CPU: Xeon e3-1280v2 (on paper better than i7-3770)
Motherboard: Lenovo Mahobay (H61 C216 based) – with latest bios 9SKT9CA (from december 2018)
16gb of 1600MHz DDR3 – two 8gb Kingston sticks in dual channel
PSU: XFX PRO 550W 80+ Bronze

My 3D mark results:
1) With R9 290: Firestrike equal to 12581 and TimeSpy equal to 3554
2) With GTX980: Firestrike equal to 8823 and TimeSpy equal to 2771

Now, what I checked:
1) The motherboard is running in UEFI
2) I changed to High Performance mode in Windows and made sure PCI Express link state power management is OFF
3) In Nvidia panel changed Power Management mode to Prefer maxiumum performance
4) Turned off V-sync
5) Turned off PhysX (or actually changed it to CPU)
6) Updated GPU bios to newest I could find on Techpowerup (, also applied DisplayPort fix for those cards that can be found on NVIDIA webpage
7) Tried a fresh Windows install – and then all of the above
8) Checked with GPU-z that the bus is running at PCI x 16 3.0 under load
9) Monitored GPU load (100% duing benchmarks, games), frequencies (at boost level at all time under load), bus load, and power draw – all seem normal and looks like the card is working at 100%.

After checking all that – I am puzzled. GTX980 should be getting higher values in 3D mark – almost twice as hight as I am seeing. I also see drop in FPS in games.

Is there any chance that the OEM bios is somehow affecting the performance of the card?

EDIT by Fernando: Thread title shortened (not all information are there required)

E31 Workstation (ThinkStation) support
latest bios version is 9SKT9CA (24 Dec 2018)

Disable windows game mode
Tap on the Windows-key,select settings,click on Gaming,turn off gaming mode,game bar,background recording


GTX 980 latest driver version is 461.72 (2021.2.25)
AMD and Nvidia GOP update upload your original vbios and share in there,also you may find a better one (latest may not be the fastest nor best)

Intel’s RST/RST(e) AHCI/RAID Drivers
Updating management engine firmware also recommended,
Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

updated bios for Thinkstation E31
modules were really old,there was no e3-1280v3 microcode (306C3).I have updated them,might give you some edge.but just in case keep your old bios copy around

As rule of thumb,keep your OS,apps,bios and drivers updated

before bios update & after bios update CPU and GPU benchmark please @purejoy88

Thanks for the quick response and the bios file.

1) Disabled game mode, game bar, background recoring
2) Changed Physx back to GPU
3) I do have Intel Management Engine drivers installed – 2040.100.0.1029 from Feb 2021 (actually are availabe even on the Lenovo support page you linked)
4) I am using the new 461.72 nvidia drivers

No difference – still Time Spy score at 2758 (should be close to 4k)


5) Intel’s RST/RST(e) AHCI/RAID Drivers – still need to look into this (maybe over the weekend when I’ll have more time - lots of work lately). But can it really affect the performance of the GPU? - I will update on this later.

6) Bios
Thanks a lot for preparing the updated bios. I did make a typo in my first post – sorry my bad – the processor I am using is e3-1280v2 not v3. I realized that when you wrote that the microcode is missing.

Looking at the file you prepared I concluded you changed those modules:
- IntelIvbGopDriv
- IntelSnbGopDriv
- SataDriver
- IntelGigabitLan
Just to learn something I have extracted those modules (with MMTool_500) and replaced them in:
- the base BIOS from Lenovo site (like your file just without the change of microcode) – lets call this IMAGE9S_2.cap
- my own back-up bios I dumped with AFUWIN – lets call this Base_mod.rom

Now regarding the flashing – I am having some issues:
a) Lenovo flash package (which I see is using AFUDOS)
- using your file I get a message (for like 1 second befor going to DOS command line) „The version of the ROM file does not match the current BIOS”
- Using my file (IMAGE9S_2.cap – I removed „_2” before the flash) – I get „ROM file size does not mach existing BIOS size”

b) AFUWINGUI under win10
- using your file: „Secure Flash function not supported on this file”
- my file: „ROM file size does not mach existing BIOS size”

c) FPT (fptw64 under w10)
It found two flash devices – interesting. Using my Base_mod.rom I get Error 280: Failed to disable write protection for the BIOS space!


I am new to BIOS modding – if I am making some stupid mistake then sorry for that :). Can you please guide me and tell me what am I doing wrong here?

I have uploaded my oryginal bios backed-up with AFUWIN - but I cannot post it direct link as I am a new user (need to get over 3 posts) - just need to copy this:

I do have ch341a programmer – so if you think it’s some sort of software block by Lenovo – I can try just forcing it directly to the chip.

  1. may improve system performance as a whole,faster disk wirte/read speeds translates into faster processing
    b) How to flash a modded AMI UEFI BIOS
    c) management engine local update is disabled by manufacturer, there may be a relevant setting in bios, use amibcp to change it if there is

    make sure you are suing the right microcode
    change the settings in modded bios as you see fit
    flash it
    reset cmos

    good luck :slight_smile:

Ok, I have managed to get the BIOS updated. In relation to ma last post – I planned to work around the write protection error by hardware flashing it with ch341a, but upon inspecting the board I found out that it has 2 bios chips (EN25QH16 and EN25QH64) and the bios is split between the two (that is why I saw those two chips via FPT).

Thankfully I came accross this thead:
Lenovo M92p Q77 Tower BIOS Bricked - Recovery with CH341A Programmer SUCCESS - unfortunately I cannot post links yet
Where @Spam00r explained to disable ME first by shorting two pins on the motherboard – then I was able to backup the bios with FTP (as a single 10mb file), but could not flash the new one. Luckily he also mentioned the trick – to put the PC to sleep (S3) for a minute and then wake it up and flash it. That worked just fine for me. So thanks to @Spam00r and everyone involved in his thead for writing all this.

In the end I managed to update:
EFI GOP Driver IvyBridge from 3.0.1013 to 3.0.1030
EFI GOP Driver IvyBridge from 2.0.1016 to 2.0.1024
EFI Intel PRO1000 UNDI from 5.0.12 to 6.6.04
OROM Intel Boot Agent GE from 1.5.55 to 1.5.62

Also, seprartely I’ve updated the ME firmware from to

All of the above did not yield any noticable difference in the GPU peroformance. I guess now I will look into the GPU bios itself and see what can be done there. Thanks @onuracengiz for your involvement.

happy to help
have you tried using Windows BIOS Setting Tool in support?
dont forget to take a look at here; AMD and Nvidia GOP update (No requests, DIY)

Thinkstation E31 updated
GOP 3.0.1030
EFI Intel GE 0.1.00 / EFI Intel PRO1000 6.6.04
Orom Intel Boot 0.1.16 / 1.5.62
microcodes updated

What Windows BIOS Setting Tool are you talking about?

I’ve done the GPU bios GOP update with GOPupd to the latest version for Maxwell (0x20011) - will post base & modified bioses there. This also didn’t change anything :frowning:

Where did you get the EFI/Orom RST from?
Is it safe to change EFI Intel PRO1000 UNDI to EFI Inlet Gagabit UNDI? UBU does reccomends this change but the difference in the name makes me wonder.

E31 Workstation (ThinkStation) support
I have not put it in the first updated version,cause i am not so sure if it will work.back up your bios and test it,should work
Open up the support website for your device,click on bios,you will find a tool in there along with the original bios files (add screenshots here,something like AMIBCP maybe?)


Intel EFI “RaidDriver” BIOS Modules
EFI LAN BIOS + Intel GopDriver modules
[Updated] Latest ROM Modules (Not AHCI/RAID related)

Regarding LAN - you are correct - I should use EFI Intel GE 0.1.00 - as it supports my card (Intel 82579LM).

I did some more digging regarding RST - and found out I was mistaken. My Chipset is not H61 but C216 - which is Intels 7-series.
From what I understand I should be looking at RST EFI/OROM 13.1.0.* - right?

I downloaded:
>Intel RST(e) RAID ROM v13.1.0.2126
>Intel RST(e) EFI “RaidDriver” v13.1.0.2126 (without the guid)

Changed the file names and tried updating it with UBU. The EFI driver is discovered and I can change it but the OROM is not. The concerning thing is that in AHCI & RAID ROM Modules it is stated that the ROM is for DEV_2822/282a wherease according to my device manager I am running DEV_1E02.

Controller in AHCI mode gets another device ID, see for example 7-series-chipset-pch-spec-update. So it’s cosmetic to exchange RST modules (OROM/EFI driver), they’re not used anyway.