Can\'t get R9 290 GPU to work with my motherboard - could it be a BIOS problem?

I have an Intel DH61WW motherboard updated to BIOS 116. But when I plug an R9 290 graphics card it won’t output signal - the fan of the R9 290 spins at high RPM but nothing happens. The card works on another PC, and other cards work with this motherboard. Could it be that from some reason the BIOS would not support this GPU?

*The power supply is working well and is not the problem, I’ve tested it on another PC with the R9 290 and it works without any problems


@Frandesktop - The only thing you can try is dump vBIOS from the card on another system using GPU-z, update it’s GOP module, flash it back using ATIFlash / amdvbflashWin and then try again on issue board.
If that does not help, then this card can’t be used on this board, board is too old / not compatible

* Edit - OR!! Maybe this board can’t boot with GOP module in vBIOS, so it would need to be removed instead of updated. Does this model have UEFI booting mode? If not, this may be the issue, some systems can only boot with legacy vBIOS in cards vBIOS
Dump your vBIOS with GPU-z, and send to me, I will make you vBIOS to flash back for testing with 1 - updated GOP + 1 GOP removed (so legacy vBIOS only)

Wow thank you! I don’t know what is GOP module by the way

I actually have 2 boards that don’t work with the R9 290: Intel DH61WW that seem to have UEFI mode (In BIOS I can disable “Legacy mode boot”) and another board that is Legacy only (I think) - Gigabyte GA-H61M-D2-B3

by GPU-z, you mean the software GPU-Z from TechPowerUp?

*I heard this R9 290 can really only boot with UEFI as you said, but the Intel board is also UEFI

Does it work if you enable legacy mode? The 290 has a switch to toggle between two bioses. This is often used for normal/factoryoverclocked, or normal/quietfan, but it’s worth a shot seeing if the other bios works. Otherwise, modding the GOP or flashing a different vbios (see repo ) can help. UEFI (in)compatibility was a common complaint with the 290.

@Frandesktop - You’re welcome. GOP is like vBIOS, but used when booting in UEFI mode.
Yes, GPU-z from TPU, while using the card on another system, open GPU-z and on the right side under the AMD Logo there is a box with arrow inside it, right next to “UEFI” Box (image below)


Click that to extract the vBIOS and send to me. I will make you vBIOS to flash in with updated GOP, sometimes this helps.
And I will make you one with GOP removed so there is only legacy vBIOS, some older systems will only boot with vBIOS this way.
Then I will show you how to flash it back.

R9 290 can only boot with UEFI is false, all cards have legacy vBIOS and or both vBIOS + GOP for UEFI Booting.

@ziddey - Thanks… Do you mean this model has a legacy only vBIOS to switch to, or is it just the usual dual BIOS switch (OC / Quiet or Compute) and you thought maybe other BIOS would possibly boot?
Good to know this is a common issue with this model, probably for a lot of systems it just needs updated GOP, but in this case since the boards are so old it’s more likely to work without GOP in there at all.

It’s been a long time, but I definitely remember some brand 290s having the dual bioses as uefi/legacy.

Thanks, I’ll do it when I’m near the pc, I’m not there right now. My card has switch but I think it’s got quiet/power mode dual bios.i tried both positions none work.

I have a few questions:

1) someone told me that I can simply try to flash a newer vBIOS from TechPowerUp and it may work, or, even flash a R9 290X vBIOS - but who makes these bioses on TechPowerUp? They’re not official because I can’t seem to find it in official sites - so is it safe?

2) how do you edit vBIOS files? You reverse engineer it by changing the HEX code, or you can actually somehow open the rom file to view the code? If so - how?

3) can you link me to a vBIOS flashing tool? Never flashed GPU bios before. And if flashing doesn’t work - does it brick the card or it has protection to go back to previous state?


Thank you. I tried with both switches but nothing seem to happen. It still won’t work. Here’s a screenshot of my GPU-Z:

How come it does not have “V” ticked in the “UEFI” box?? I thought this is UEFI only card? I’m confused now

@Frandesktop - It does not have UEFI checked because this vBIOS does not have UEFI (usually that is what that means). So this probably means your card right now is LEGACY ONLY.
So you may need UEFI/GOP added, to boot on the one system that can boot UEFI mode. Anyway, send me vBIOS dump and I will make you a few BIOS to play with
Dump vBIOS how I showed above and send me the file. I will check and let you know for sure if there is GOP in there or not. If you want, you can do this with both BIOS, shut down before you switch the switch to dump the second one.

* Edit @Frandesktop - Sorry, I didn’t see your post above the one with image until I already replied
Here’s my reply to your questions >>
1. Maybe, but I would not do unless you are 100% sure whatever BIOS you plan to use works on your exact model.
The BIOS on TPU are user dumped from cards, and some are user dumped and modified - usually for this it would be marked as “unverified” and or there would be notes/comments about the changes
Some may also be uploaded by users or TPU, from manufacturer direct sources

2. All depends on what you are wanting to do. For update or add GOP/EFI there is a tool here in the forum. To remove GOP/EFI it’s done by hex manually. For other stuff, such as changing settings, there is tools.

3. Yes, here is tool to flash vBIOS -
If vBIOS fails, card is bricked, and you have to boot with this card in secondary slot, while you have working other graphics card in some other slot (can be PCI card, or other PCIE card, or onboard graphics)
Then you flash back into the bricked card, your known working vBIOS dump

But if it does not have UEFI, why won’t it work with the old motherboards then? I’m so confused.
Also, how do you mod a vBIOS file? How do you see the contents in order to add GOP modules? I would like to just look at the contents out of curiousity
And, how do I flash a vBIOS after you mod it? Any guide and link to the software?

@Frandesktop - Please refresh page and see my edit above
It may not be working because the boards are simply not compatible, or you do not have some setting correct, or it needs GOP if the boards are in UEFI mode
Or you may need to update this cards vBIOS, to an exact match for this model but newer version, if you can find one

All answers to you questions above now, sorry I missed your post previously and was editing in reply when you were posting your new reply
* Edited #8 once more (at end)

So even though the R9 290 is not “UEFI” only it still won’t support certain boards? But how

Also, I found a modded ROM on TechPowerUp:

This mod has “UEFI” checked, so maybe they added GOP… maybe it’s actually your mod? :smiley:
By the way can I flash a R9 290x to the R9 290 and it might solve the problem as well? Or flash a difference R9 290 version (For example Tri-X) or that’s not compatible?

thanks again. Soon I will go to dump my vBIOS and send u (Still not at the place with the PC with the R9 290 so can’t do it yet)

Because not all things are always compatible, sometimes things need updated (BIOS, or vBIOS), and sometimes things are just 100% not compatible for whatever reason.
Sorry, I can’t really comment on any roms until I have a dump from your card and can look at the vBIOS info. The file you linked, if correct for your card, could be a mod BIOS, or could be a stock manufacturer updated BIOS.
Sorry, about 290 >> 290X I don’t know, you will have to google about that. I would first try to solve the issue with your exact vBIOS in the card now, or a matching updated version of that exact vBIOS from manufacturer

Guides on how to use DOS version of ATIFlash…atiflash.57750/…-cards.1353325/

Alright, this is the link to the current vBIOS:

How do you edit these files or view them? All I see is Gibberish when I open them with text editors

@ Frandesktop - That vBIOS is compatible with Hawaii vBIOS editor, if you wanted to change settings such as core speed, memory speed etc
Other tools may work with it too, but I did not check anything else due to I already know Hawaii works on that since it’s named Hawaii

GOPUpdater works on it as well, here is the thread for that - AMD and Nvidia GOP update (No requests, DIY) (79)

Some tweaking threads for your perusal later…0-390x.1561372/…eamlined_as_it/

I checked, and the rom you linked above at post #11 is not compatible, incorrect subsystemID (so not same model)
Please link me to your exact cards product page, and I will try to find you updated stock vBIOS if there is one.

In the meantime, here is your vBIOS with GOP added, you can flash via DOS with ATIFlash or via windows with amdvbflashWin.exe
This will only help in systems where you are booting UEFI mode -

Here is your exact vBIOS at TPU -…290-4096-131121 (Looks like this may be a “Debug BIOS” based on the comment on memory at bottom)

This should be what is shipped with your card below, I mean, what they eventually shipped with this model, since it’s UEFI/EFI compatible
Here is one with EFI GOP already there too (stock) -…290-4096-131112

Flash this ^^ and test, if it’s still failing I will update the GOP on that for you, and or take that vBIOS and remove the GOP so it’s legacy only

But the bios you provided is older than mine? I have 042 and you linked 041? So are you sure that’s going to help? By the way the old motherboards are probably legacy only not uefi

First, what BIOS are you referring to?? Older does not matter. If you mean the last one I linked, build date does not matter
As I mentioned, I think the BIOS on you’re card now (2nd to last link above also) is a debug BIOS, sent to someone a few weeks later, or flashed into some cards at factory a few weeks later etc
Age/date does not matter to your issue, if there was a vBIOS I thought may work that was 2 years older I’d link you to that one too

I do agree, that’s why I mentioned I’d remove GOP for you, but it’s already missing Having both does not matter, except in rare cases where board will fail if GOP present.
I thought maybe that last one would work, since it’s UEFI by stock, so more properly built for the time + does not have “debug” in the memory note.
And that’s why I mentioned to test this, and if it fails, I will remove GOP and then you can test again.

If you want, I can try to find you a newer dated one, but may not have any luck.
I see this one, user modified, same as I mentioned I would do for you for the above BIOS -
Also maybe this one from 2014 (has UEFI and also debug memory note)
If either of the two vBIOS here above fail, let me know and I can remove GOP for you on these and you can test to see if that is the cause of the issue with newer BIOS still.

Also, you do not have “42” you have “41” see your image above - I linked your exact vBIOS above -…290-4096-131121

update: I flashed my Intel DH61WW to its latest BIOS (version 120), disabled Legacy boot in the BIOS, then flashed the 041 vBIOS of the R9 290, but still I get No Graphics beep code from the motherboard… and no output

That’s curious. GOP incompatibility was why there were legacy bioses without them. Those should work fine as long as you have legacy boot/csm enabled. If you don’t have legacy boot enabled and are using a non-UEFI bios, that’ll obviously cause problems.

The good news is that if you flash a bad bios, you can just flip the bios switch to boot with the other bios. Then, flip it back while booted and flash again.

Most of the bioses in the tpu db were submitted via gpuz.

Also, if I remember right, many/most manufacturers didn’t fully support uefi boot with the intel 6-series (could boot gpt/uefi but bios was still legacy (not fully abstracted to csm yet?) – no fast boot). Intel is an exception.

Are you saying that the 290 (vbios without uefi/gop) does not work in the intel board when legacy mode is enabled? That would be strange indeed.

In any event, I’d still keep looking at trying various bioses from the tpu db (uefi support vs not). The 290 only used either hynix afr or elpida bbbg I believe, and most/all bioses should support both. As well, I believe there was only the reference design board for the 290, so there shouldn’t be any incompatibilities cross vendor.

Back in the day, this was very popular:…6-2016.1564219/ but it’s performance-related rather than addressing compatibility.

I was hoping you had a UEFI enabled vbios that’s somehow incompatible with your board, and using a non-UEFI + setting legacy mode enabled in your bios would solve this (before finding a compatible uefi-enabled vbios).

It is so weird.
I also just flashed another UEFI BIOS, and it still didn’t work on the Intel board, which I also updated to latest 120 BIOS.
Also, tried with both with Legacy mode disabled and legacy mode enabled

You’re saying that the Intel board may have “Legacy mode disabled” but is actually not UEFI and it something that’s general for all Intel boards so they didn’t remove this option so there’s not really UEFI?

No, Intel brand 6-series boards fully supported UEFI. I know my asus z68 didn’t though.