cant run TXEInfo and FWUpdate on ubuntu

hi ive an acer es1-512 and would like to update txe fw

i used 7zip to extract acer exe bios update to get .fd file
dragging the file to me analyzer showed it contained an old txe fw

im booting xubuntu daily from a pendrive, I downloaded system tools v1 and txe fw

I installed txe deb package but when I try to run TXEInfo from the terminal I get

h@h:~/ TXEInfo
bash: /usr/bin/TXEInfo: No such file or directory

i checked /usr/bin and TXEInfo is there

if I try to run it manually i get

h@h:~/ sh TXEInfo
TXEInfo: 1: Syntax error: word unexpected (expecting ")")

I was also wondering how to check if me drivers are installed in xubuntu

I couldnt run txeinfo on xubuntu so I booted win 10, installed latest v1 drivers, ran TXEManuf (passed), then ran TXEInfo

TXEInfo otput showed Local FW update disabled and BIOS Config lock enabled

I made a google search and found
Intel Trusted Execution Engine: Drivers, Firmware & System Tools (9)

I tried running
fptw -d spi.bin
but got error
I then tried to follow E6 step of
[Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing

in bios disable D2D recovery (acer disc to discc recovery) and disable secure boot (must set supervisor password first)

I downloaded bios zip from acer website and used 7zip to extract the files twice to get .fd file

this tool extracts .bin from .fd…leases/tag/v0.2

opening fd file with hxd spi bin starts at 00000CC0 and its lengh 800000 so ends at 00800CB0

I got a txt file from IFR extract with 4 languages from the body of SetupBrowser2 so not useful

I extracted PE32 image of DriverSampleDxe (which is right under SetupBrowser2 in UEFITool), then used IFR extract to generate a txt file

At offset 0x20C13 of txt file I found Bios Lock, variable 0x20B set to 0x1 by default

At offset 0x20D60 of txt file I found TXE HMRFPO, variable 0x170 set to 0x0 by default

At offset 0x20D81 of txt file I found TXE Firmware Update, variable 0x171 set to 0x0 by default

At offset 0x1E641 of txt file I found Hidden page, variable 0x258 set to 0x0 by default

I booted a pendrive with EFI shell, then i ran

setup_var 0x20B 0x0
setup_var 0x258 0x1

system rebooted

upon reboot i ran txeinfo and Bios config unlock was disabled so now its possible to edit local fw update var and HMRFPO var by going into bios setup > advanced (hidden page now enabled) > security

by enabling HMRFPO it’s possible to dump spi image
fptw64 -d spi.bin

i followed D3 of
[Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization
to replace txe 1.1.x to txe 1.2.x
I was getting
Warning: File size exceeds firmware, data in padding!
in Me analyzer so i replaced txe fw with hxd
start at 00001000, 153000 lenght
figured lenght with me analyzer, offset with fitc

I followed donovan 6000 thread to update cpu microcode…microcodes.html
at offset 00570D20 (fd) or 00570060 (bin) theres 30673 cpu microcode, CC00 lenght
at offset 0057d920 (fd) or 0057cc60 (bin) there’s 30678 cpu microcode, CC00 lengh
total lenght 19800
figured offset by searching cpu id in hxd with little endian order so 730603, lenght with mc extractor

its possible to flash spi bin with
fptw64 -bios -f spi.bin
then reset with either
fptw64 -greset
or unplug both ac and battery for 1 min