Comet Lake - Windows 7 - Z490 - Intel Driver

Hello.

After searching for Days, i think it would be the bes Forum to ask about Drivers for the 10th Generation CPUs.

Installing Windows 7 on a Z490 Gigabyte worked and also the USB Drivers are fine.
What could not be installed are all the Chipset Driver (8086).

Comet Lake PCH Thermal Controller > DEV_06F9
Comet Lake PCH SMBus Controller > DEV_06A3
Comet Lake PCH SPI Controller > DEV_06A4
Comet Lake HECI Controller > DEV_06E0

Is there any possibility to get some Drivers Modded for it?


One more missed Driver is from the Network, but this wont be a matter.
Intel(R) Ethernet Controller I225-V >DEV_15F3


At least, all the Intel UHD 630 Drivers won’t work anymore, it tells you always that the Drivers are nor for this Windows (tried all which i could find).




One interesting question would be, does it affect anything if we would use Windwos 7 without the Chipset Drivers?
I mean, they usually won’t be Updated for Years (also before Win 10) and the “newest” ones are dated since years from 1968.

I need the same drivers for my Gigabyte Aorus Master motherboard. I have 10900KF CPU so I don’t need the Intel UHD 630 drivers, but the others I do. I would liketo have the I225-V ethernet driver, but I can use a USB WiFi dongle if I have to (what I am doing now).

Would also be nice to have the Intel(R) 400 Series Chipset Family SATA AHCI Controller working for Windows 7 rather than the old Microsoft AHCI driver, but not 100% required.

@Vaniii - what Intel ME driver are you using?

@Vaniii :
Welcome to the Win-RAID Forum!
Due to the fact, that Win7 is not supported anymore by Microsoft and the chipset manufacturers, I have moved this thread into the "OS related topics" section of the Forum.

The currently latest "chipset drivers" (= INF files) for your Comet Lake PCH-H system are attached. They will work with Win7 as well.

No, as you can read within the start post of >this< thread.
Good luck!
Dieter (alias Fernando)

CometLakePCH-H.rar (10.9 KB)

@Fernando
Really really Thank you, also for all your Help and offers in this Forum and somewhere.
I can imagine how much time and more you will spend for it, because i do something similar in another Forum.


Now, with the Driver from @Fernando , there will be just one missed Chipset Driver left.
Comet Lake HECI Controller > DEV_06E0


Actually, Intel® UHD-Grafik 630 will just work in 1080p with the OEM VGA Driver, don’t think it will be fine to watch Movies or so.
Intel® UHD-Grafik 630 > DEV_9BC5 (No PCI Vendor List available)


Where are still no Drivers for is the 2.5GB LAN
Intel(R) Ethernet Controller I225-V >DEV_15F3
------------------------------------------------------
But everyone should be aware of this Adapterin combination with some Switches fitted with >=2.5GB Ports like Netgear, there is a Hardware Issue in Revision 1 and 2, production of R3 started in June 2020.
B1-Stepping > Dropped Packages / Lost LAN after Reboot
B2-Stepping > March 2020 / Maybe are the dropped Packages fixed but still lost LAN after Reboot, especially on ASUS Mainboards.
B3-Stepping > June 2020 / Will need some time to find in new MB

Intel Foxville I225-V 2.5GbE Networking Issues
It’s difficult to find more accurate Informations because it can be assumed, that they wanna avoid a warranty wave if there are really fixed Mainboards available.

If you use Win10, they patched the 2.5GB LAN Speed down to 1GB over a Windwos Update to avoid this issue… unbelievable !!! and one reason more not to use Win10
------------------------------------------------------



@Mr_Fox … I have to check it later, now i should sleep, spendt the whole night again with this Topic and to check all important Gigabyte Utillities.
Downloads over your Z490 Mainboard will be fine, everything should be Windows 7 compatible even they just say Windows 10.
Don’t mess up with old Z390 Software.

If your Win7 will hang around after a reboot (circle on LAN Symbol), you have to change the affected Service to a delayed start.
But i think it’s well known, also the same crap with the ASUS Mainboards even the old ones which where Windows 7 ready.

RGB Fusion / System Information Viewer / Easy Tune / @BIOS
All were fine also FAN Settings worked well.
Didn’t tried to Overclock, first i wanna do a stable bench with OEM Settings.
I had to install the shoddy “APP Center” to get Easy Tune and SIV working, but after they do, you can remove this Win10 crap.
Not even the Translation is correct, but when you remove it, choose that you just wanna remove this shoddy App and preserve the other Software.
Didn’t tried all Software but also others from Z390 which isn’t listened at the Z490 and it worked well.

Hello.

@Mr_FoxDoes your CPU perform into the TURBO BOOST?
I do have the same CPU with UHD Graphic Adapter and until now i was not able to get over the base 3700 MHz.
Found no way to fix it in Windows 7.
No Issues in Windows 10, it worked without any trouble.
Be aware of the Gigabyte Software as soon as you install APP Center, messed up with some Bluescreens, i am not sure which are the best Versions, try it before install something else.
But google says that they have the same Issues in Win10, so it’s not a Win7 issue.
Also i am not sure if Easy Tune will work fine but SIV and RGB Fusion did it always.


1. Ethernet-Controller // Intel(R) Ethernet Controller I225-V >DEV_15F3
2. PCI-Datensammlungs- und Signalverarbeitungscontroller => Intel(R) Thermal Subsystem - 06F9 // Chipset Driver
3. PCI-Gerät => Intel(R) SPI (flash) Controller - 06A4 // Chipset Driver
4. PCI-Kommunikationscontroller (einfach) // Comet Lake HECI Controller > DEV_06E0 (HECI bus allows the host operating system (OS) to communicate directly with the Management Engine (ME))
5. SM-Bus-Controller => Intel(R) SMBus - 06A3 // Chipset Driver
6. Unbekanntes Gerät (ACPI\INT3450) => Intel(R) Serial IO GPIO Host Controller - 3450 // Intel Serial-IO-Driver\Intel(R) Serial IO GPIO Host Controller
7. Unbekanntes Gerät (ACPI\ACPI000E) => ACPI Wake Alarm // Intel Serial-IO-Driver\ACPI TIME


HECI Controller would be assigned if you manually force it to an Management Engine Driver, but i don’t have any idea if this would be a good solution?
A Management Engine entry is nowhere else to find.

Hi bro. You can fix it with Gigabyte EasyTune, XTU or ThrottleStop. Simply change a multiplier in Windows and apply and it will instantly begin working. Otherwise, I have the same issue as what you are experiencing.

I hate Windows 10 so much. It is a pile of garbage and impairs performance on everything related to CPU and memory. Linux Mint is working great with Z490 and 10th Gen CPUs. There is no excuse for Intel and Micro$oft to not be providing Windows 7 support other than their greed and lack of regard for the wishes of end-users. Their behavior is abominable.

This may also work. (I expect it will, but I am about to test it.) https://coderbag.com/product/quickcpu?fw=upd

I would advise against using Intel XTU. The Intel Integrated Clock Controller is a piece of garbage and it is best to avoid having it installed.

@Vaniii - indeed, it does…

Capture.JPG


wPrime.png


CPU-Z.png



EDIT by Fernando: Inserted pictures cropped without showing the whole desktop and re-attached (to save space)

Really Thank you for sharing this Information.

Wanna giv it a try, prefered way would be the EasyTune but it doesn’t seems to be working.

Does Gigabyte EasyTune work for you?
No matter what i tried, always got a Blue Screen (gdrv2.sys) when i changed something, even with or without App Center.
It’s a well known one also with Win10.

You can avoid the App Center when you install both additional Files from its Package (UpdPack.exe) and (UpdPack_Gservice.exe).

You got Crazy Temeratures.
In Benchmarks like AIDA64 the CPU stays always around 90 Degrees, even with a Watercooled Enermax AQUAFUSION 240 which will perform really well in comparative tests.
Win10 with OEM Settings, 10x 4900MHz.

Do NOT use ThrottleStop!
It shows you just 8/16 Cores and since i tried it, CPU-Z just shows a Multipler by 51, even after a new Windows install.
Don’t know if its a CPU-Z issue, tried in Win7 and Win10 also after Bios reset, but before it showed me 53 for sure.

Quick CPU seems to be working until 5100 MHz under standard Settings, never saw some Cores higher like in Win10 could happen trough the Turbo Boost feature.

5500MHz and Windows 7 ? Wow, awesome, i guess it is very quick… i hope with new Vermeer i will be also able to reach 5GHz, but on max with 6 Cores.

@Vaniii :
You got Crazy Temperatures.” Thank you. I am running bare die, Optimus Signature water block and a MO-RA 360 (360mm x 360mm) radiator with 18 fans in push-pull, three pumps, and two 270mm reservoirs. For the times I am really pushing it trying to gain rank on HWBOT, I fire up my aquarium chiller to get the temps down near zero C. Same setup I used for my 7980XE thumping 5.3GHz, so it handles the 10900KF like a rag doll.

Does Gigabyte EasyTune work for you?” No… totally rubbish. I restored a Macrium image of my OS to get rid of that digital cancer. It’s like XTU… once you have installed it, you can kiss a system that used to overclock well goodbye. It will be unstable and limited after having the trash that makes it work installed. I did use @BIOS to change my boot logo, but I got rid of the rest of the junk. I am not throwing stones at Gigabyte. I am used to Windows software for motherboard features being junk. The same was always true for me with ASUS software. Best to avoid using Windows software and stick with BIOS tuning if overclocking and system stability are things you care about.

QuickCPU is more limited that ThrottleStop, but both will serve the same purpose. Use the BIOS to set the values you want. Use either program to force Windows 7 into turbo working. I think it has something to do with c-states registers or the Windows 7 power profile. Do not try to use them for overclocking. HOWEVER, ThrottleStop does work as long as you are going down in values. You only see 51x because it cannot take the core ratio or voltage higher than what is set in the BIOS. It can control them up to whatever the maximum is in the BIOS.

We should have 10 core access with it soon. @unclewebb will be providing a release candidate pretty soon. The ThrottleStop Guide | Page 1217

@Atom_Ant :

Yes, indeed. As usual, Windows 7 is always measurably faster and better with CPU and memory management compared to Windows 8.x and Windows 10.

Well @Vaniii - guess what. The problem with Windows 7 Turbo Boost not working is the Gigabyte BIOS is a mess. I RMA’d the Aorus Master and replaced it with an ASUS Maximus XII Apex and guess what? No need for any third-party software. Windows 7 works exactly as expected. See screenshot.
Link to Screenshot

@Vaniii
Do you already have a driver for Intel i225-V on Windows 7?

If not:
You can download the complete driver pack version 25.2: https://downloadcenter.intel.com/downloa…ck?product=2469
Extract and go to folder PRO2500\Winx64\NDIS68
Edit file e2f68.inf
Delete the first two occurrences of string “.10.0.1…17763” (without double quotes). This tells windows the driver is compatible (for more information see https://docs.microsoft.com/en-us/windows…acturer-section)
Now you can install that driver.

@Volatile11 :
Hi. I’m try to edit that file, but can’t get good result( I’m delete the “.10.0.1…17763” at first - no way, I’m try to delete whole strings contains “.10.0.1…17763” - bad idea. Can you help me?

@Mr_Fox
Hi. I see in your screenshots that you’ve managed to install Bluetooth support on Win7. Is it coming from external addon hardware or is the Z490 device? If the latter, which driver did you use?
Also, which driver is working for the Z490 xHCI (USB 3.x) controller (06ED) on Win7?

Thanks in advance.

I used a Windows 7 installation from my X299 Dark motherboard and it had most of the drivers already present, including the USB 3.X. I only had to install ME. I was not successful in my efforts to clean install Windows 7 from scratch. I purchased a USB 2.0 PCI-e card that I will try to use for that purpose.

The BlueTooth drivers are the latest package that I found from Intel for Windows 7. The only things I have not been able to source are the i225-V and AX201 drivers for Windows 7. Hopefully, someone will come up with a mod for those.

@Mr_Fox
Thank you. I own a Z390-based system, with BT device id 8087 0AAA. It’s not supported by latest Intel BT driver package for Win7 (21.40.5). Could you please confirm device id and installed driver version in your current Z490 system?

Also please confirm device id (8086 06ED?) of your current Intel xHCI controller and driver version installed, if any.

I cannot test it because I lack the hardware but this thread Installing i225-v ethernet drivers (W10 drivers) on windows 7? offers a simple modding method.

I was having issues with the Bluetooth and now have a Generic Bluetooth driver installed and the device disabled in the BIOS, along with the WiFi. The Bluetooth hardware ID is USB\VID_8087&PID_0026.

I will check the link on the i225-v that you provided. Thank you. I tried my own INF mod and got it to install, but the i-225-v had a problem code and was disabled by Windows. Maybe I can fix it. I am not sure if there is a solution for the AX201. I don’t use WiFi on my desktop so it is not a big deal, but I do not like having things in Device Manager that are no configured correctly if I can avoid it.


That worked. Thank you.

@Mr_Fox
Thanks, and what about the Intel xHCI device id and driver version? Is it maybe the native Win8 generic xHCI driver that was unlocked for Win7?

And, are you using specific drivers for the Asmedia and Nvidia xHCI devices in your system? (which ones?)


As I mentioned, the Intel BT drivers were buggy so I switched to the generic M$ BT driver. That worked OK, but I have since disabled the WiFi/BT module in my BIOS. The Intel BT drivers were installed on a Windows 7 image that was fully installed on my X299 Dark mobo, so I am unable to tell you what driver version. I was not able to reinstall it.

Here are the driver packs that I used:

Windows 7 Driver Bundle

NVIDIA RTX GPU USB Type-C Mod for W7
(This was based on guidance provided by @canonkong.)

I also found a special Windows 7 ISO that allowed me to do a clean install with none of the hassles I was encountering with Z490. At the first reboot during Windows 7 Setup, press F8 and disable Driver Signature Enforcement to avoid any issues with the modded drivers.