CPU Microcode BIOS modding questions/problems

The CPU Microcode is layed down within the BIOS and has nothing to do with the in-use Operating Systems.

@ Fernando
There must be something wrong with my system because in the BIOS it states I have microcode 19 but HWiNFO64 is reporting 1B and AIDA64 is reporting 1Bh.

@ General_Probe:

Done!

Only one of them can be right. I think it is the BIOS.

I have never flashed bios with 1B microcode, always 19 or older, but HWinfo shows 1B. Asus maximus v gene & 3570k.

A tool like HWinfo can only show, what it is coded to look for, no matter if it is correct.
Example: The Device Manager shows the driver date of all on-board Controllers, but it doesn’t even check the driver itself. It just reads the associated .INF (=text) file. So if you change the driver date entry by editing the INF file yourself, the Device Manage will show that date and not the correct driver date, which only can be verified by right clicking onto the driver itself (= .SYS file) and choosing “Properties” > “Details”.



Usually modern OS have a microcode update mechanism included. Linux has this and Windows also. So if you use an actual OS the latest microcodes are included and applied automatically.

CPU Microcode CPU ID:040671, Platform:22, Broadwell - v10

BDW_CPU_MC_v10.rar (11.2 KB)

@mictlan
I don’t know how it is handled in Linux, but Windows needs a Windows Update that delivers microcode Updates - and those are really rare.
The latest Windows Updates for Intel microcodes I am aware of are:

1
2
3
 
Windows 7 / Server 2008 R2          February 2011      Xeon (Penry, Merom)
Windows 8.1 / Server 2012 R2 July 2014 Xeon (Ivy Bridge, Ivy Town, Haswell)
Windows XP / Vista / Server 2003 April 2007 Core 2 Duo Mobile, Core 2 Duo Desktop, Core 2 Quad Desktop, Xeon 3000/3200/5100/5300
 


Is it possible, that a microcode update improves overclockability?
Seeing better results here after updating the BIOS of my ASRock X79 Extreme4 (4930K)...
Before it was not possible to OC via BCLK, because with increased BCLK the system refused to POST. I had to increase the multiplier (46x100).
Now I can set 37x125 and not a single crash happened.

Linux is offering better support at this, as you can see here. So it is possible to load the latest microcode without updating the board’s firmware. But for Windows, the microcodes are stored in mcupdate_AuthenticAMD.dll and mcupdate_GenuineIntel.dll, which are updated only when it is really needed.

Before I update my CPU MicroCode for Intel IvyBridge-E only, MMTOOL indicates that BOOT is
set to YES for all VOLs.

After I update, all VOL boots are set to NO

I am using an Asus Rampage VI Extreme Black ED. Motherboard (Intel 4960X ivy-bridge CPU) &
untouched clean bios ver 0701 from asus for modding

Is this a bug ? What does this flag do anyway ?

Can you make me a scripted LGA2011ibe_BOOT_YES.ffs with instructions ?

Thanks,

Biozzz

RAMPAGE-IV-BLACK-EDITION-ASUS-0701.zip (4.79 MB)


This flag is not critical for the X79 platforms.

Edit:
But if for you it is so important that I will make in the next version UBU v1.24.

Intel 4960X ivy-bridge S2011 CPU X79

Is MC patch v428 (306e4) the latest you have ?

Do you have a latest special Overclock MC patch for Intel 4960X ivy-bridge as well ?


OK, would you do it for me in the next version.


Excellent tool, look forward to more updates !

Thanks,

Biozzz

Hi Everyone,
I hope I am posting this in the correct thread. I have an HP 8200 Elite that I would like to do some overclocking on. As all of us know, the BIOS from HP is locked down to not allow this. What I wanted to find out from others who have worked with locked down versions of BIOS from these tier 1 vendors is if they have had any success in adding options into the BIOS to control the multiplier, FSB, voltage etc. I have tried looking up the MB model to find an OEM model that is similar and use that BIOS instead. I have not been able to find one yet, but will keep searching.
I have attached the BIOS that I am currently working with on the off chance that someone knows exactly what I need to do. It is an AMI BIOS for your reference.
If there is other info that you need to answer my question or to help me down the right path, I am more than happy to provide what I can.

Thanks in advance for any help!

Firstsage

P.S. Looks like the file upload doesn’t like the .BIN. Here is a link to my google drive. Please let me know if you have any issues using this.

CPU Microcode CPU ID:0306F2, Platform:6F, Haswell-E (LGA2011v3 - v2E
CPU Microcode CPU ID:0306F2, Platform:6F, Haswell-E (LGA2011v3 - v31

CPU_MC_Hasweel-E.rar (59.2 KB)

^If only there was a way to implement it with MMTool5.

EDIT: And get it to work with my ASRock X99 OC Formula.


Date MC 04-16-2015
2 FFS files with MPDT BOOT YES and MPDT BOOT NO.
Which MPDT look in MMTool5.
For replace use UEFI Tool "Replace as is…" , GUID 17088572-377F-44EF-8F4E-B09FFF46A070.

CPU_MC_31_Hasweel-E_FFS.rar (31.4 KB)

CPU Microcode CPU ID:0506E3, Platform:36, Skylake-S (LGA1151) - 1C

Capture.PNG

cpu000506E3_plat36_ver0000001C_date#02-06-2015.rar (84.3 KB)

@SoniX

CPU Microcode CPU ID:0506E3, Platform:36, Date: 18-06-2015, Skylake-S (LGA1151) - 20

cpu000506E3_plat36_ver00000020_date#18-06-2015.rar (85.3 KB)

@SoniX

CPU Microcode CPU ID:040671, Platform:22, Date: 27-05-2015, Broadwell - v11

cpu00040671_plat22_ver00000011_date#27-05-2015.rar (10.1 KB)