Dell G7 7588 Bios Unlock

So i’ve modded my laptop, desoldered the bios and added a socket. I’ve dumped the bios and I can see there is a whole plethora of options which are hidden in the current bios, I had a go at unlocking them but that didn’t work at all, was hoping someone could help me out.



@coldwove - Please package for me stock BIOS exe from Dell (or link it) and a dump of your BIOS right after you flash it using the Dell stock flashing method.
This way I have a stock copy from Dell, and an untouched dump from your system (ie one you have not tried to edit)

@Lost_N_BIOS made a drive folder with everything:…v5H_Mw15MmDWEoX Went ahead and upgraded to the lastest bios since i couldn’t find the exe for the old one.

IS boot guard active on this system? Please check to confirm, use ME System Tools V12 package from here
Intel Management Engine: Drivers, Firmware & System Tools

Inside you will find MEInfo folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell). Then run the following command >> MEInfoWin.exe -verbose
Check the end of the report, at bottom look at “Measured & Verified Boot” do they have a yes/enabled on the Left/FPF side? If yes, you cannot flash in mod BIOS, if not, then no problems here

Please show me some image of your BIOS, if it looks like old standard blue/gray AMI BIOS show me Main, Advanced, Boot, Save and Exit (Put images in zip archive or 7zip, thanks)

Unsuprizingly, it’s enabled for everything. Is there anything that can be done softwarewise or hardwarewise to overturn this?

Bios looks like this:


So at end of MEInfo -verbose report you see Measured and Verified Boot both enabled on the Left/FPF side? If yes, nothing can be done as far as BIOS modifications.
Since you have flash programmer you can dump, mod, reprogram and test to confirm to yourself this is true, but I already know it is. If you want me to send you a test edit so you can see let me know, I will update a microcode or change a single setting.
Some areas can possibly be edited, but not the ones anyone ever edits for a BIOS mod or BIOS mod to update things.
It does look like microcodes can be edited possibly (only in yellow region for bootguard coverage), but definitely not anything in the main BIOS volume where you’d edit to make BIOS setting unlock type changes (Cyan - no editing at all)

The only real way around that is to replace the PCH with a clean one without a hash burned into the FPF fuses

So, I can send you two test BIOS if you want, one with microcode update so you can confirm that’s OK, and then second with a single setting changes from default enabled to disabled or something like that, in the area we’d normally edit to unlock the BIOS.
If you want those to play with let me know.

And thanks for the image, that is rubbish Dell GUI, not so easy to unlock/add normal AMI menu entries back into anyway, so even without bootguard enabled we may not have had much luck.
I’ve worked on that a few times, but don’t remember how far along we got, I know I was able to make the hidden advance show in there for a user, but none of the submenus inside it would show up and I think we still need to continue working past that right now.

yeah, once i saw the stuff reported back by MEInfo, i had a bad feeling about this. Guess ill swap the PCH out once i don’t need the laptop anymore, I still intend to put the CPU on LN2.

out of curiosity, how is the bios able to upgade to a newer version?


The BIOS has the correct encrypted hash in it from Dell, if we had this private key would could mod then resign, but no key = no way this is possible.