Dell Optiplex 7040 - Comprehensive guide to enable ME?

I have a Optiplex 7040 with factory disabled ME. I’m a total noob and this is completely new to me.
I tried following a guide in a imgur link( i cant post links i have a new account) but I got the same error as here: (win raid)/t4727f39-Stuck-Trying-to-Activate-AMT-on-Dell-Opti-factory-disabled.html
That was without the CRC errors, I found some other win raid post that said to update the bios and that would fix it, once I did those crc errors started appearing.
I saw that the OP of that post was able to get it working with a 5040 firmware, can someone help me do that or give me a more comprehensive guide? Can I just do the cleanup and flash the 5040 firmware or did the OP do some sort of other modification, that’s unclear to me in that post.

What Chipset and CPU does your 7040 have?

It has a Q170 chipset and a i5-6500T CPU

Set the SERVICE jumper on the motherboard (consult the manual), download Intel Management Engine: Drivers, Firmware & System Tools > Intel ME System Tools v11, run Flash Programming Tool with command “fptw64 -d spi.bin”, compress and attach/link to the generated spi.bin file.

1 Like

Ok, I attached it:

The CSME firmware File System is corrupted so, as before, I had to use one from the identical 5040 model. Make sure the jumper is set, download the fixed SPI/BIOS image from this temporary link and run Flash Programming Tool with parameter “fptw64 -f spi_fix.bin”. After the re-flash, shut down the system and make sure the jumper is set to its default position. Then remove all power (AC + any battery backup) for 1 minute and press the power button a few times in between. Then reconnect all power and boot the system. AMT should be operational.

It worked! Thanks for your help!!!