Dell Optiplex 990: Enabling Full AMT

Hey, I’m trying to enable full AMT functionality on a Dell OptiPlex 990 (Q67 Express chipset) that was ordered without. So far I’ve gotten the ME region dumped, but after modifying it with Flash Image Tool it ends up far too large. I’ve attached my unmodified ME region, taken from BIOS version A20.

C:\Users\User\Desktop\Windows64>fptw64.exe -d O990.bin -me
Intel (R) Flash Programming Tool. Version:
Copyright (c) 2007-2011, Intel Corporation. All rights reserved.
Platform: Intel(R) Q67 Express Chipset Revision: B2
Reading HSFSTS register... Flash Descriptor: Valid
--- Flash Devices Found ---
W25Q64BV ID:0xEF4017 Size: 8192KB (65536Kb)

- Reading Flash [0x600000] 6124KB of 6124KB - 100% complete.
Writing flash contents to file "O990.bin"...
Memory Dump Complete
FPT Operation Passed (3.25 MB)

Run Flash Programming Tool with the command “fptw64 -me -f O990_fix.bin” followed by “fptw -greset”. After the reboot, you should have AMT enabled.

O990_fix.rar (2.97 MB)

Thanks so much! It worked perfectly. What did you do that made the image the proper size?

If you’re talking about the ME region output from FITC, just add enough padding (0xFF) to end up with the same size as the dumped ME region.

hi Plutomaniac,
I have an Optiplex 990 system with the cut-down “Intel® Standard Manageability” rather than the “Intel® Active Management Technology” that I require, and would like to convert to the full version if possible

I have tried using the O990_fix file that you attached in this forum thread. However I get the error "Error 25: The host CPU does not have write access to the target flash area. To enable write access for this operation you must modify the descriptor settings to give host access to this region."

Here’s the full output in this image:


Any assistance much appreciated. Cheers!

I assume there is a motherboard jumper which enables read/write access for servicing purposes. You need to set it, reflash the firmware and then restore it. Read the manual to find it.

hi Plutomaniac, thanks for your response!
Just a question, when you say "… then restore it … ", are you talking about removing the service jumper, or something else ?

Restore the jumper to its default position, as explained at the manual.

Plutomaniac, I’d like to give you a big, big thanks for your help!
Would also like to thank Kasm279 for creating this thread and reporting results.

In case it helps anyone else, I’d like to document the steps here, when wanting to perform the task whilst running outside of Windows:
1. Download Plutomaniac’s O990_fix.rar found in this thread.
2. Download the “Intel ME System Tools” file that corresponds to your ME version, from here: Intel Management Engine: Drivers, Firmware & System Tools
3. Create a FreeDOS bootable USB stick using Rufus (
4. Extract O990_fix.rar to the USB stick
5. Extract the contents of the \Flash Programming Tool\DOS\ folder from the Intel ME System Tools file to the USB stick (including the fparts.txt file too).

On the Optiplex 990 PC to be modded:
1. Upgrade BIOS to A20 if not already (not sure if this is required)
2. Shut it down and enable the “Service Mode” Jumper (you will need to remove the DVD writer & hard disk caddy to access this jumper)
3. Boot the PC with the USB stick that was created earlier
4. Run these commands at the FreeDOS prompt:

  fpt -me -f O990_fix.bin
fpt –greset

5. Shutdown the PC, and remove the Service Mode Jumper.

You should now have Full AMT!

HI, I have an Optiplex 990 system with BIOS version A24. I’m trying to enable full AMT functionality on it. Can I just flash back O990_fix.bin coming from A20?

Any assistance much appreciated!

which files did you use,the issue i’m getting is that i’m not seeing the version so i don’t know which files to download.