DELL T5600 - BIOS A15 & A17


I need help by activation of a factory disabled AMT.
I’m trying either on Firmware A15 or A17 with same result.
If I try to dump ME with “fptw64 -d me.bin -me” in win10 x64 but I get "Error 367: [FPTw64.exe] cannot be run on the current platform. Please contact your vendor"
If I try from DOS with “fpt.exe -d me.bin -me”, I get "[FPT.exe] cannot be run on the current platform. Please contact your vendor"
Jumper is set in "Service Mode"

Any idea? Thanks

Error 367: [FPTw64.exe] cannot be run on the current platform - This means you are using the wrong version of FPT/ME tools. Download the correct version per your current ME firmware. Can you see ME version in BIOS?
If not, you may need to download each version of tools until you find one you think it may be, or wait until someone can tell you what version it is in your currently flashed BIOS.

Wait, some boards, when jumper is set ME is disabled so you wont be able to access it only overwrite with new, see section E2 - [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing

Do you need edited BIOS w/ AMT disabled, or are you trying to update ME? If you need AMT disable, I will check what I can do, but may not be able to change that.

Here is the current ME version, included in A17 BIOS


If you already have this BIOS flashed then you should use FPT from this package (•Intel ME System Tools v7 r2 - (2017-11-19)) -!KFkQkLIS!hgkURBZpfNQYj…gbq9_MG0x_0mXwQ

For anyone else looking to help, the BIOS can be extracted via this method - BIOS Modding: Introduction and Preparations (2)

Thanks for reply.
I’m trying to fix problems of wake from sleep.
I purchased PC with bios A12 (used pc) and no problem at that time. 100% wakes. Never checked if booting with CTRL+P was giving me AMT menu.
After I updated to A15 problem has started (sometime wake worked, sometime not) - zombie PC.
After I updated to A17 wake doesn’t work at all. 100% zombie pc at wake.

I tried to install back either A12 and A15. Didn’t fix.
Tried with Win10 64. Uefi install. Several fresh install.
Same problem if using OSX.

My hope is that enabling AMT will fix. What do you think?

I read that problem in OSX may be due to MSR 0xE2 lock. Any way to unlock it?

Any suggestion is appreciated.

Thanks for the info. I don’t use sleep, so can’t help you diagnose issues with it, but I do know what you mention is common problems that can be caused by many things from BIOS to system/chipset drivers, SATA drivers, graphics drivers, windows updates, and many other random windows issues etc.

When you flashed back to the A12, did you clear CMOS after flash? Then after that, load optimal or optimized defaults in the BIOS. That should be default sequence when updating BIOS, to ensure none of the old code remains when at all possible.
Sometimes there is old stuff you can’t remove, especially if flashing backwards. Big one there is Intel ME, it often can’t be flashed backwards, only if ME is unlocked to flash to and you use Intel FPT program to specifically flash the ME region, or use flash programmer.

ME Info tools linked above V7 r2 should work for you, with jumper not set to disable. Try both ways, for dump not service mode, for flashing it would need to be set service mode.
For entire BIOS SPI dump, set service mode, that way ME is included in the dump. Try DOS or Win version (not winx64 one, try it last if others fail). If you get error tell us here what the error is.

I checked BIOS A12 and A15, both are ME version so above system tools package should work for all BIOS/ME versions
A15 and A17 has exact same ME version, so version not really an issue to look at here, other than system tools and FPT use.


I also do not use AMT so am not sure if that would help or have anything to do with the sleep issues. I checked in BIOS settings to change for you, and do not see AMT specifically.
Do you see it in BIOS, if yes what section, and is it labeled under different terminology in this Dell BIOS? I see TPM and TCM security, computrace but no AMT stuff.
It may fix, if it was disabled before but it’s not now.

A lot of the time you can only unlock MSR 0xE2 with flash programmer, it would have probably been locked before you even purchased the system, so not likely to be the cause of any issue since you didn’t have it initially.
The guys on MAC and OSX forums can advise you better on that for OSX if you need. If you know this can be reflashed and isn’t locked on your system I can probably edit BIOS for that for you but again it’s probably always been locked so not source of sleep issues.

Do you have CH341A or other flash programmer?

I think I solved the sleep problem.
Thanks to Lost_N_BIOS and plutomaniac

Using Intel ME System Tools v8 (v7 was giving error) I’ve been able to dump me and spi (just in case)
Than I used me_fix from this post 2 in this thread Dell Precision T3600 Bios A14
I just followed plutomaniac instruction: "Flash attached ME region with command “fptw -f me_fix.bin -me”, set the jumper to default/locked position and do a ME/platform reset via “fptw -greset” command"

It worked. Sleep and wake from sleep now works.
Only issue that if I wake usingmouse, than mouse will be disconnected (i have to unplug it to make it work again)

The fix is done for dell t3600 (single cpu) which is very similar to dell t5600 (dual cpu).
Can someone try to fix my ME? If I try I can’t upload files bigger than 2Mb.
Thanks in advance

Put in winzip file, winzip is free download.

Or, upload to a file host and post link, here’s one I use often

Sorry I didn’t look into ME settings before, I assumed you meant some AMT related BIOS setting! If I would have known it was more about ME related or ME/AMT issues I would have addressed them with you sooner [grim]
I can do that same ME fix for you on BIOS ME. And I don’t need the ME dump, but it would be better to use that so if you can upload it would be best, so I will wait for your upload and then do fix tonight when I get back.
Please wait for fix, do not use the T3600 stuff on this board

Here my ME (original dump form A15).
I already fixed my board using the one for T3600 :frowning:
Anyhow it works :slight_smile:

As soon as I’ll receive your fix, I’ll flash it. Than I’ll let you know.

Thanks! Lucky the T3600 file worked for you, yes it would be best to reflash. Do you want me to put ME changes into A15 or A17 BIOS

It may not be good, since you already flashed T3600 ME into your board, which includes it’s specific ME settings. It would be best if you reflash ME from A15 or A17 BIOS, then send me new ME dump after gpreset.
That way any specific ME settings from your board vs the 3600 would be included, which may not be the cause with current file above since you flashed in initialized ME from 3600 system

The one I uploaded in post 7 is original dump from a15 from T5600, before applying fix from t3600. I dumped it as safety, before doing anything. I think you could patch it. I read that any upgrade (a17) will keep all patches. Am I right?

Thanks, I will use dump from A15 above then to transfer ME settings over and then enable the AMT stuff. I am unsure if any update will keep AMT ME patches, if ME does not get updated then yes, if it does I am not sure, possibly.
For now, I’ll apply this on A15 and A17, then if you need for older BIOS later I can do again if you need. I’ll send both, modified ME by itself, and modified BIOS files in full for you to have later if needed.
It’s different older ME so if you’re going all the way back to A12 later on sometime, don’t use this newer ME from A15/A17 and put into A12, in case it is source of some issues.

Flash with programmer if you have, and if you do that be sure to drain all power for 1+ minutes (unplug PSU, remove CMOS battery, press and hold power on button for few seconds).
If you do not use flash programmer, then use FPT as you did above but be sure you do the -greset command at end.

* Pre-post edit * the above dump is ME only. I need complete BIOS dump, before any fixes from T3600 is applied, to do this “properly”. Do you have a complete backup instead of ME only? if yes, please upload, thanks!

@vdv - Is this Series 6 chipset, or C600 chipset? And what is actual chipset? When I open your ME dump in FIT tools it defaults to QM67 mobile, so does the T3600 fix_Me file from the other thread, and that doesn’t sound right to me.
So that is why I asked for entire BIOS dump, plus it is better to correct/redo ME with entire dump rather than edit the ME only. I can edit the ME only if you don’t want to send entire dump, it’s OK, but better to do with entire SPI Dump.

Let me know about chipset stuff, thanks! See, here is what I mean, selected defaults in blue, need to verify if that is correct before continue, or if not which is correct for both dropout menus?


If all that is correct, here is modified ME from your A15 ME dump w/ AMT Enabled


Thanks for reply.
It is C600.
I have the SPI dump but not with me now.
I’ll send it as asap.


OK, I can redo! I wonder why both (T3600 fix_Me too) automatically come up in FIT as 6 series chipset instead of C600.
What is the other chipset you’d choose from these now with C600 selected? If you are unsure I can figure it out (Original ME dump says CPT/PBG, I’ll look that up if you aren’t sure)

here my SPI dump.
I can’t find what Patsburgh type. I don’t know where I can find this info.
My mobo model is:
0GN6JF - A01
Chipset Sandy Bridge - E Rev 0.7
Southbridge C602 Rev 0,5


Thanks for the dump, and the info, I should be able find correct setting to choose from all that board/chipset info.
I’ll get new BIOS w/ ME and ME separately for you posted tonight

So, it’s not all that easy without the board in hand, you’ll have to help still. Can you tell me which Patsburg it is based on this

The A SKU is the most basic model which sports support for an additional four SATA 6Gbps ports via what’s referred to as an expander.
The B SKU swaps the SATA 6Gbps ports for SAS 6Gbps ports, but the count remains at four.
Moving up to the D SKU things change a bit as the D and T SKUs connect via an additional four PCI Express 3.0 lanes to the CPU(s) as both support up to eight SATA 6Gbps or SAS 6Gbps ports.
The T SKU finally adds support for RAID 5 on the SAS ports and it has built in non-volatile SRAM, presumable to be used as a data cache for the RAID in case of a power failure.
The other SKUs have to make do with RAID 0/1/10 support, but it’s worth noting that the SATA 3Gbps and the first two SATA 6Gbps ports all support RAID 0/1/10/5, it’s just the additional ports that have a different feature set when it comes to RAID

Patsburg-A only featuring four additional SATA 6Gbps ports via the SCU
Patsburg-B gains SAS 6Gbps support.
However, where things get interesting is Patsburg-D, the performance option, as this gains not only an additional four SATA/SAS 6Gbps via the SCU, but also a PCI Express 3.0 uplink to the CPU.
Patsburg-T just gains an extra RAID level, but is otherwise identical to Patsburg-D.

I guess maybe it doesn’t matter, since you already used the T3600 Fix_ME one and it wasn’t even set to C600 and it was OK
I assume it’s A, B or D based on seeing these rom packages contained in your A17 BIOS


I tested creating A B and T, and each place I see in ME image that shows CPT says CPT A0 anyway, same as your original BIOS and dumped ME too.
So I think the ME I posted before is fine to use above, that’s probably why theT3600 fix was OK for you too

Thanks, it works.
Only remaining problem in Windows 10 is that at waking from sleep I have to unplug mouse to make it work.
Bluetooth usb key need 1 minute to be detected (not necessary to unplug).
Seems not all usb ports waking at same time.

I’ll test more.
In osx all seems working fine

Have you tried messing with USB Settings in BIOS, legacy USB, wake from sleep USB etc? Bluetooth USB Probably not ideal for that, so unplugging probably normal.
Wake from USB is normally straight USB mouse only, sometimes certain USB mice don’t work as well as others too.

At least sleep issue is solved for now, rest maybe nothing you can do on this BIOS. Did you try older BIOS to see if USB still a problem, maybe BIOS version issue for the USB issue.

If I wake with mouse, I have to unplug.
If I wake with Keyboard, mouse ok, Bluetooth disconnect. Bluetoot reconnect autometically in 2-3 minutes.
I upgraded to A17 but problem remain. I’ll test more but I’m really happy. Wake works.

Other Ideas I would have are:
1) remove MSR 0XE2 lock
2) allow boot with M.2 SSD (I think some istruction have to be injected).

Do you think are they possible?

You’re welcome!

So that was BIOS A15 initially with wake USB issue, then A17 same correct? Same with A12 too? I don’t think I made an A12 BIOS for you, so maybe can’t test that one yet, I’ll make later for your testing.

MSR 0xE2 lock I can do, give me some time to read about it again
M.2 SSD, not sure, I’ll have to look into how that is usually implemented and see if it breaks anything when I try.
I will get on these for you this weekend though, as soon as I have a chance!

@vdv - here is MSR 0x02 patched A17 BIOS patched, this does not include a modified ME region, so you may need to reflash the ME region by itself again after updating to this


What is the right command for flashing?
I was thinking at "fptw -f T5600A17MSR.bin"