[Dell Venue 10] How to unlock Boot tab?

I dumped a .rom of my bios and have been trying to get the boot tab to show up as seen in AMIBCP.

I’ve extracted the IFR of the Setup Module from UEFITool, but I only seem to have one form set, “Setup”.
I’ve tried changing the options to USER within AMIBCP, and while that revealed some settings, it only revealed settings on pages I could already see, it didn’t unlock any additional tabs.
I’ve also tried changing the Suppress If: True to False within the setup module, but that didn’t reveal the tabs either.

Attached is the unmodified setup IFR.

Any help on getting this resolved is appreciated.

setup_whole IFR.txt (41 KB)

@icecube45 - Please link dumped BIOS and I will edit to unlock for you, please also include an image of the stock “Boot” page you normally see, so I can tell which is which while I edit.
While we’re there, is that the only tab you need unlocked? There is no “suppress if” constraining the boot menu, only some settings within the menu itself
Since I’ve not looked at the BIOS yet, do you need both “Boot” sections, or do you only want the one you currently don’t have?
I’ll download the stock BIOS shortly and check it out while I wait, if I can find it (if there’s not 10 variants of the model you mentioned) *Edit - never mind, yes there is 3+ variants so can’t look until you link.

I appreciate you looking in to this
Attached is the stock bios I dumped.

If you’re able to unlock everything, that would be amazing, but my main goal is getting any boot tab to show up. The model I have is a 5050 - which runs android. However all my research shows its the same hardware as the windows versions, just with a locked down bios.

edit: forgot an image, this is what is seen on stock (sorry for blurry image)

5050.zip (3.12 MB)


You’re welcome, and no problem to help! What is this exact model, so I can put your dump into a properly labeled folder for my reference later

Yes, that’s a blurry image Can you please attach it with the forum software instead of the large image, thanks - actually, please take an image of each main BIOS section you can see (Main, ADV, Security, Exit) and zip that and attach for me, so I can tell which you have already (I can unlock full BIOS for you)

So you don’t have any boot tab… Since they both have different options, which do you want, top one or bottom one or both if possible (Maybe not room to add both, I’ll let you know)?

Top one would be preferred, both would be optimal.

This is a Dell Venue 10 5050.

Getting a photo of each bios section will take a little bit as I need to flash the stock rom back to my device. I’ll post a new reply once I’ve got those images.

Thanks for model info. No rush on the images, I can’t work on this long tonight anyway. This is a tricky BIOS, and I like a challenge In the normal area that controls menu tabs being displayed it all looks to be visible, hopefully I can figure it out.

Do you have a flash programmer like CH341A + SOIC8 test clip cable, or no? So what is the other version that runs windows instead? Are you wanting to run that BIOS/Windows, or just need stuff unlocked on this BIOS for Android?

@Lost_N_BIOS Attached are the images of the stock bios

The windows version is the Dell Venue 10 5055 (and I think they released a 5056 as a successor?)

I uh… don’t have a flash programmer and test clip cable but I have a bunch of soldered on wires and an arduino that’s been working over serial with the flashrom commandline utility.

My end goal here is just to have a way to boot from USB so that I can install linux/windows/whatever - a member a few years back received a tablet in “manufacturing mode” and was able to do so, confirming this hardware can do it.

BiosPhotos.zip (467 KB)

Soldered setup is just as good as programmer if you already have it working, reasons I asked is for recover in case needed of course, but also since you mentioned the other system. You could program that BIOS on there, if we could find a good dumped BIOS, if that was really your end goal, windows and that BIOS.
I may also be able to better/easier unlock that other BIOS, if that would be something you’d want to test too? I’ll have to look at it’s BIOS though and see if it’s more normal compared to this ones BIOS.
*Edit - I checked, and in regards to what I was looking at for unlocking etc, it’s the same layout/style so still just as tricky to figure out.

Thanks for images, I’ll check it all out and get back to you tomorrow night probably.

Just to clarify - I only have the one device, the 5050.

But if we find a rom dump of the 5055, I can flash it, no harm.

Once again, appreciate it, I’ll check in tomorrow.

Yes, I knew you only have the one 5050 device. And yes, that was my thinking, but the BIOS looks about the same, slight difference in internal coding, but nearly same creation methods, I did not check actual BIOS settings vs yours.
But yes, that is something you can easily do since you have programmer setup and you think the hardware is all same except for BIOS setup for windows instead.

So far, I’ve not found the secret to unlock this, sorry, in all my methods I can find in this BIOS it appears to show all menus, so they’ve hidden the tab controls good
However, I think with some BIOS mods we can still reach your goals. Any setting you see in the IFR, we can change it’s default value or adjust to whatever setting you want to use, this would be just the same as if you could see the option in BIOS and adjust it manually.

I see this, and your mention of manufacturing mode made me wonder if this bootloader maybe had anything to do with that, currently it’s skipping bootloader and going to whatever redirection after post means.

Redirection After BIOS POST, VarStoreInfo (VarOffset/VarName): 0x41, VarStore: 0x1, QuestionId: 0x17A, Size: 1, Min: 0x0, Max 0x1, Step: 0x0 {05 91 52 06 53 06 7A 01 01 00 41 00 10 10 00 01 00}
0x128FE One Of Option: Always Enable, Value (8 bit): 0x0 (default) {09 07 54 06 10 00 00}
0x12905 One Of Option: BootLoader, Value (8 bit): 0x1 {09 07 55 06 00 00 01}

As for USB, there is lots of settings and adjustment for those, EHCI, XHCI, and all the usual other USB control settings. We can adjust all this.
Secure boot can be enabled/disable too. And any setting you see on either boot menu pages.

If you want to scroll through the IFR and make a txt file of all settings you want changed, and what you want them changed to, then I can mod BIOS for you like that.
Or, you can change in AMIBCP too, same way you’ve been trying, only instead of trying to make them visible, change their actual failsafe and default values to whatever you want the applied setting to be.

Do you think there would be a way to add a menu option to get to the boot tab? I think I read something about someone changing a menu item to open another submenu at point - maybe we could replace an option with a way to get to the boot tab?

The “setting” that I think I need to change is tough as I’m pretty sure I need to click the “add filesystem boot option” button to point to a usb - is there a way to mess with the boot order or to by default look for a usb to boot from?

But browsing through AMIBCP made me look at the “OS/BOM” configuration - there are many options here for switches between “development mode” and “android” and “windows 8.x” - looks like another thing that might help me boot?
(There’s also a “config mode” switch here, maybe that’s toggling the tabs?)

No, I said I can’t find it yet in this BIOS. Normally there is a few ways to do this, outside of AMIBCP and often those need done first then AMIBCP can control it.
This BIOS, AMIBCP does not have “Root Entries” for either MAIN “Setup” or the internal “Setup”, so no acess level for menu tabs can be set at all in AMIBCP, and the usual methods outside of AMIBCP in Setup module and AMITSE module all look like all sections are already visible.
So, until I can find it, the only thing you can do is what I suggested, change the actual settings either via setup module /IFR edit via hex, or by using AMIBCP to edit the applied settings in AMITSE/SetupData / NVRAM.

What you mention about switching setting for an entire submenu is very involved, but can be done, more easily on newer BIOS than this, but it is possible (very involved and risky, you should not attempt with programmer in hand)

I do not see “add filesystem boot option” - please check again and be exact in the actual settings name.

ON the Config mode, yes, I see this now in AMIBCP too, as well as setup. You are correct, there is where you can set “Development Mode” I bet that is what that guy had that mentioned manufacturing mode. Set it and test,
Same for the one under that, there you can change to windows mode if you want. Never mind, I compared the windows 5055 and your 5050 BIOS, this setting is same in each, only that “BOM Seletion Switch” is different (Force Android for yours, Force Windows for the other one)
Then further down >> OS/BOM Selection << Android for yours, windows for the other. Compare them side by side in AMIBCP and you’ll see all the differences. Set yours to match the other, then try your Windows/Linux installs (Should be same for those, I never have issue with Linux on regular desktop boards)
I assume Development mode may/probably works on all Android and Windows, but you’d have to play around and test that. These have nothing to do with the tabs being visible, well maybe Development mode could, you’ll have to try it and see!

Well luckily I have a programmer I suppose.

I had the order wrong, sorry - “File Browser Add Boot Option” - which would pop open a menu like the attached image.

Were you able to get your hands on a 5055 rom? Could I take a look if so? I may try to just flash the whole thing, but at the very least I’d like to compare it to my current.


Yes, you can test anything since you have programmer.
Since you have programmer, if you program in BIOS with unlocked FD, then you wont need to use programmer setup anymore, as long as you always make that edit to any/all BIOS you flash in after that, it will remain unlocked and you can then just FPT Flash in BIOS/BIOS region etc.
Here’s how to unlock, see spoiler #2 image #1 in section “B” - [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing

No, sorry, I hadn’t looked for 5055 dump yet, was going to wait and see what kind of progress we can make first.
As you mentioned they are likely same, only minor changes (Probably mainly the settings we discussed above and a few others).
Dump in this regard, would be much the same as the stock BIOS which you can download, only it would not have user specific details that a dump would (Like Serial, UUID< MAC ID etc) and minus a NVRAM volume usually
I do have the EC and stock BIOS region I cut out of the stock 5055 exe, do you want those? You’d need to replace into a full BIOS file with UEFITool (BIOS region, below FD and ME), or I could do for you. Or I could try to find a dump, maybe that would be best anyway

For that File Browser Add Boot Option, since no boot tab we can’t make it visible, but if you do get boot tab I development mode and it’s still hidden or gray, you can fix a few ways

First try only - Access Level User in AMIBCP
Then if no luck, make these changes via hex to the setup module (And then test again with and without access level set to user in AMIBCP, may ne needed, or may need to be set back to default)

Suppress If {0A 82}
QuestionId: 0x296 equals value 0x27A6 {12 06 96 02 A6 27} << Change that A6 27 to FF FF
Gray Out If {19 82}
QuestionId: 0x274F equals value 0x1 {12 06 4F 27 01 00} << Change that 01 to FF
Ref: File Browser Add Boot Option, VarStoreInfo (VarOffset/VarName): 0xFFFF, VarStore: 0x0, QuestionId: 0x27A6, FormId: 0x2713 {0F 0F E6 05 E7 05 A6 27 00 00 FF FF 04 13 27}

If you don’t mind splicing a rom together, that would be great - I’m going to change the options we talked about (Development mode, BOM select) and see if that does anything fun. Will report back

Messing with those options seems to have given me nothing but a Recovery tab with "ROM Image update denied. EFI_NOT_FOUND! ROM Image is not loaded"

Did I do something wrong in my flash? Or are these settings just not the ones im looking for.

@Lost_N_BIOS Think I got my hands on a 5055 rom - attached it to post. Do you think it might help figure out how the tabs are hidden? (as on the 5055 model they are visible)

5055.zip (3.04 MB)

Sounds like you did not do the mod right for your message #16, upload that file/files for me and I will check it. Also, specify exactly what you changed and how, since I gave several suggestions and method to modify things, I am not sure what exactly you edited, so unsure what the expected outcome should have been.
I will find your edits, but I need you to explain you intended edit to me (Such as I hex edited this setting, etc), so I can check to see if it was done correctly on whatever setting. Also, show me an image of what you’re seeing in BIOS
If you changed the Windows from Android settings we were discussing, I doubt you’d see any changes in BIOS, just now go and try to install windows.

On the 5055 rom, a dump from this system wont help figure out the tabs, I only mentioned this when thinking about cross-programming in this BIOS to your board
But, since we found same stuff in your BIOS no need for that anyway since we can adjust it all on your BIOS and don’t have to crossflash.

Unfortunately I don’t have access to the system until mid next week to take a photo as requested - but I can provide the file and the edits performed.
I just used AMIBCP to edit the values of the optimized defaults for Main->Setup->Advanced->OS/Bom Configuration:
I set the following:
OS/BOM Selection: Windows 8.X/BOM3.0
BOM Selection Switch: Development Mode
Pre-OS/BOM Selection: windows 8.X/BOM3.0

Attached is the file that I flashed.

5050-mod.zip (3.12 MB)

No need for images for now then, and thanks for explaining the changes you made.
Without seeing images, and knowing what and how you edited, what you mentioned sounded like maybe bas hex edit and some BIOS failure or something, but now that you explain I get it and don’t think that at all.

I would like to see this recovery tab when you have a chance to take some images though, it doesn’t sound like what we can see in AMIBCP recovery tab.
And I wonder why that shows up anyway, you didn’t set “Development mode” did you? I wouldn’t think the OS Changes you made would invoke recovery tab options?

I’d go ahead and try to install windows now and see if you notice anything different. Depending on the other applied settings (even hidden ones), you may need to install from GPT to GPT partition, if Secure boot or UEFI Boot etc is enabled