Dell Wyse 5070 - 3 orange blinks - corrupt BIOS

Hi there! I’m having some problems with some Dell Wyse 5070 ThinClients. We have a lot of clients laying around which need, according to the blinks of the orange LED (3 Blink, pause, 3 Blink = BIOS Recovery image not found), a cleaned BIOS. I have dumped the BIOS from a fully working Wyse 5070 and flashed one broken Wyse 5070, but unfortunately, it didn’t really work. The LED is white which means it’s powered on, but as soon as it gives output to all USB ports, it blinks orange again. What should I do in this case?

The chip is a Winbond W25Q128FWSG, 1,8V. The service tag is: B9N45P2.

I hope that there is a way to revive these.

[Problem] Locked myself out - BIOS/UEFI Modding / BIOS Modding Requests - Win-Raid Forum (

[Problem] Experimental Dell Wyse 5070 BIOS doesnt Boot - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (

EDIT: Well you can start reading the posts linked for now… witch i doubt it you’ve done it already.

What are my options there? What could I do in this case?

Learn about the structure of TXE firmware.


  • Dump a firmware with a programmer
  • Compare static bios parts to stock bios and correct where necessary
  • Clean NVRam
  • Flash it back, see if it works



  • Dump a firmware with a programmer
  • Extract the Flash Descriptor from original firmware
  • Extract the DVAR region from original firmware
  • Extract the DevExp1 region from original firmware
  • Put the Flash descriptor in front of a stock bios
  • Put the DecExp1 region at the end of a stock bios
  • Insert the DVAR region at the correct place replacing into the stock bios
  • Clean ME according to [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization
  • Flash it back, see if it works

Not all of your machines may have a firmware error, not all may have the same error. Might be corrupted static bios parts, corrupt ME/TXE, might be corrupted NVRAM, might be defective hardware or a combination of all.

Since there’s not much feedback on earlier threads no general recommendation. Easiest way would theoretically be to dump one machine, create a ‘universal’ stock firmware image with clean ME/TXE and then transfer the machine specific DVAR region for each machine.
Missing here unfortunately the proof of concept.

1 Like

Hi, there. I have the exact issue as you met. I have tried many different combinations but didn’t seem to work.

Any updates on this issue. I’m also looking for a working bios.

Thanks inadvance!