DELL XPS 13 motherboard has locked password. How to unlock?


Saw on ebay someone selling a Dell motherboard for an XPS 13 for a fair price but only one problem. They say theres a password locking you out.

So was wondering if this can be fixed if I buy it by just flashing the rom clean with a new image using a programmer via usb?


Often yes, that will fix it, but you need a dump from non-password system. Dump the BIOS first so you can get board details later, then reprogram with programmer using your detail corrected dump

So not just the bios from the manufacturer website… Finding someone else to do that be hard part . Thanks.

Usually no, you can’t write just the BIOS from Dell, and specifically no in this case, even after you extract the HDR on only contains partial contents and non-programmed ME Region etc.
However, if you dump your BIOS on the board, I may be able to create you a good file to program in, check to be sure there is not two BIOS chips if there is dump both and send.

Finding someone else to do what will be hard part? You have a programmer right?

You mean when I get the board dump the bios using my programmer? Because theres another guy on this site that has that board: Seeking Knowledge (Dell/NVMe)

Anyhow I have studied photos from ifixit and know exactly where the bios chip is located. There is only one I bleieve and with a working test clip should not be a problem to dump its contents.

Yes, dump the BIOS from the board when you get it, so you or I can pull out the serial, asset tag, LAN ID etc, and put into a stock BIOS to program back in.
Once it arrives, make sure there’s not two BIOS chips, you’ll be able to tell in person but probably same as in images too so you may be correct.

I have a couple ideas on how to unlock that password however you might have a better idea. Mine is to dump the rom with and without a password and compare the images looking for the differences. From there one should be able to blank it out maybe idk.

The other idea is and I am not even sure if this is possible but reset the cmos. Not even sure if its possible. I mean if it could have been done the seller would have done it. So only option is to transfer the serial uuid mac numbers onto a new copy and just flash it over.

I should have the motherboard by tuesday and will post the file hopefully by tuesday night.

Here is layout photo I got from IFixit describing where the flash chip is located:


Yes, it’s possible to do the way you mentioned, but finding the correct location blindly will be nearly impossible via compare in this situation. BIOS-mods guys probably know the location and could remove for you, if someone would reply kindly and do it for you.
If you have two of these, then you could find it easily! On the system without a password, dump the BIOS, then set same type of password and dump again, there you have a much easier comparison with minimal differences between those two dumps which would make finding it a breeze.

Clear CMOS wont help, it would be nice if it was that easy

Well who do you recommend has the skills to unlock the password? Bios-mod guys? Anyone in particular? Perhaps I could get a dump from a fellow Win-raid member who might own a 9350 dell system?

Anyhow I should have it delivered by end of today and will try to use my CH341A to dump the bios.


I’m not a BIOS-mod guy, just a electronics repair technician, but in some AMI BIOS i was able to locate and remove the password. Upload your dump and we’ll see what we can do.

Will have to be a few days more at least I’m afraid. Seller took a week to wrap it up and take it to post office for shipping.

Was really looking forward to this… Darn…

I do have the original bios executable from Dell I suppose I could post just to see what kind of bios it is and the structure.



Finally received the motherboard. It took me about 50 tries to get a good read on the bios chip but in the end was able to pull the bios off of the chip. My soic-8 test clip must really be bad. I ordered a couple more just to be safe.

Actually dumped the bios twice to verify accuracy.

If anyone is familiar with unlocking dell bios passwords and bios files here it is.


Well this problem has been solved and it didn’t take a bios mod to do so. Turns out theres a site called that has a password hacking algorithm that allowed me to hack its password and now its working!

Thank you.

@davidm71 - I think DeathBringer can do it, but make a thread I’m not sure if he’d happily help in a PM or not.
Yes, if you could find a member here with same system that would provide two dumps for you then we could easily locate the password. You’d want them to send one dump without password set, and then have them set a “Same Type” password and dump again then send you both dumps

Probably loose connection issues when you were having BIOS dump hassles, you can try tiny rubber bands on the tip, but be careful not to put too much pressure on the BIOS legs they can bend or break loose from solder so you can’t squeeze super tight.

So, you got it via master password? If yes, what was the master password you used, what code did you feed to that site? Trying to see if that info will help me find the pass location in your dump
Send new dump now, so I can compare with one above! Then maybe we’ll locate it!

Thanks @Fabio - I could remove too if I knew the location , but I don’t know how to recognize it, are they often/always in a similar module, if yes, which?

@Lost_N_BIOS , in some cases here is where the password is stored.

With password.


Without password.

no password.jpg

I’m not a BIOS mod expert and i’m learning tons of new things with your help. Thank you!

Thank you @Fabio - I am not expert either, only learn as I go and as I help. Password I never deal with, so never tried to find. Do you know if it’s always same thing in NVRAM for AMI BIOS?
So you 00 that, and then password is gone? * Edit, see below, check file above post #12, I found x5 instances of the AMITSESetup NVRAM type entries (one invalid NVRAM entry), all already 00’d out.
So must not apply to all BIOS types, or there is something else you missed when you compared possibly, and that is the area needed on this system?

If yes, @davidm71 - would you kindly confirm I removed password from your initial BIOS dump by flashing this back in, you can do FPT BIOS region only flash if you want since it’s contained in the BIOS region
Never mind davidm71, I checked all instances of what Fabio showed above (x5) and all appear to be 00’d already, like his image for “without pass”

Well fortunately I did not need to resort to bios modifications to unlock this Dell motherboard. The first step was to obviously install the motherboard in my Dell Notebook and remove the old one. Was a time consuming procedure being that every cable is paper thin and very delicate work. At first the machine did not want to go on but after a couple tries Success! It worked though only to be greeted by the bios password screen that the Ebay seller had told me was wrong with the board. Time to get hacking!

The trick to unlocking the password is to make a note of the system serial number that is displayed on screen when the password request comes up. From there you enter that code into ‘’ and press enter. From there the site gives you a half dozen codes to try. The correct on was the one labeled ‘serial code’ and it was a long alphanumeric code that you have to type back into your notebook and then press ‘CTRL’-‘ENTER’.

That did the trick.

Now if only I could get an Nvme drive working…


@Lost_N_BIOS - Never did a full research on all BIOS files i have here but i can see now this not apply to all BIOS.
I don’t have the knowledge to do a full research on this theme, and to be honest, it’s much more easy put the serial, MAC, UUID, MSDM key, etc on a BIOS dump without password.

@davidm71 - Glad you got it sorted out easily! Do you need NVME mod, or you know how to do that don’t you?

@Fabio - what BIOS did you find this on anyway, maybe it’s only certain AMI series? Anyway, I still appreciate the tip, I don’t get asked often to deal with this, but at least now I know one thing to check each time just in case

@Lost_N_BIOS , check the link below. This one i removed the password with success.
[AMI]bios password reset for unbranded tablet