Detecting Array...... upon Boot Win 10

Previously Win 10 was running okay for many months. (BIOS was already updated to the latest then).Windows10 32 bit was re-installed to 21H2 (November2021) as August 2022 Update was not getting properly installed.
Now repeated BSOD code- Driver IRQL not less or equal - ncis.sys - ndis.sys - crashed. BSOD Code D1 (97c425f8, 00000002,00000000,825b8f98)
So Network driver updated.
Then also updated manually Storage Driver (SMB) to v 15.57 and installed Silverlight also. (This perhaps was a mis-adventure).
This led to a BSOD with error – System Thread Exception Not Handled- nvlddmkm.sys crashed.
Restart was taking time to collect dump file or BSOD screen got stuck so manually restarted PC.
PC opened with Detecting Array …
No RAID Disks detected.
Bios was reset to default - time and other settings were reset.All RAID settings were set to Disabled. PC Rebooted but cannot go to the login Windows and also no USB detected - SSD and DVD ROM detected in BIOS but cannot re-install Win 10. The screen goes only up to Detecting Array… No RAID Disks detected.
How to re-install Win 10 or go to log-in?
Please guide.

Welcome to the Win-RAID Forum!
Although you forgot to post details about your system (chipset, mainboard, sort of disk drives), I will try to help you.
To be able to to use any former member of an Intel RAID Array for a non-RAID system, you have to do the following:

  1. Enter the BIOS, make sure, that the SATA mode is set to “RAID” and store the BIOS setting.
  2. Reboot, re-enter the BIOS > “Rapid Storage Technology”, delete the RAID Array and store it.
  3. Reboot, re-enter the BIOS, set the SATA mode to “AHCI” and store it.
  4. After having done that, you should be able to get any modern Windows OS installed.

If the former RAID array members should not be shown by the Intel RST RAID Utility, you may have to “secure erase” all data of the former Raid Array members. This is the only option to get the “raw” disk drives back.
Dieter (alias Fernando)

P.S.: Why did you create a RAID array at all and why did you install a 32bit OS?

Before the above steps are tried out, the answer to your question and missing details –
The MoBo is BIOSTAR MCP6PB M2+ model N61PC-M2S chipset MCP61. It is not Intel but AMD Athlon64 Dual Core processor (may be of 2006 make). BIOS was flashed to latest and changed HDD to SSD sometime back. It is an old low end PC.

RAID Array got created as a result of 2 BSODs – second one being the worst-
as mentioned above-- due to BIOS slipping to default settings with wrong drivers.

After trying out the above, or if got stuck, the results will be posted.
No data on SSD worth saving.
Thanks for responding so promptly.


This means, that your mainboard’s chipset and the RAID array is from NVIDIA. So I have wasted my time trying to help you without the required information, which should have been given by you within the start post.

Deeply regret your efforts and time spent in vain. And I assume that the probable solution is much simpler than what it appeared to be.

Now, please would you be kind enough to help me out. As mentioned earlier neither USB nor SSD or DVD ROM is accessible. SSD and DVD ROM gets detected on BIOS settings but not the USB. Best I can reach is the BIOS settings. Then tried many permutations and combinations of settings but USB or DVD ROM or SSD is not reachable for OS re-install or open. Please guide.

Since NVIDIA stopped the storage driver support for their chipsets already in 2010 and modern Microsoft Operating Systems don’t care about old nForce RAID systems, I recommend either to replace your system by a newer one or to break the RAID array and to install Win10 or Win11 in IDE mode.

Thanks for getting back so soon.
…or break the RAID array and to install Win 10 … in IDE mode.
Now this is worth attempting. Please tell me how to do it.
I am unable to access SSD / DVD ROM/ USB port. In such a scenario, how to install Win 10?

If you are not able to break the NVIDIA nForce RAID array by using the related nForce RAID Utility, you should do a “Secure erase” of the former RAID Array members. Important is, that the RAID data on the track0 will be erased.
Before you start the procedure, you should enter the BIOS and set the on-board NVIDIA nForce SATA Controller to “IDE”.

Done as instructed to set the BIOS and up on pressing F10 on reboot, reached the Media Shield Utility (May 22, 2006) -
— Define a New Array ----
There are 2 columns –
(Left column) -
RAID Mode : Options are – Mirroring /Striping/Stripe Mirroring / Spinning / RAID 5
And in Free Disk is mentioned the SSD(240GB) with capacity 223.57GB as Port 1
(Right Column) –
Striping Block : Options are – Optimal/128K/64K/32K/16K/8K/4K
And Array Disk is mentioned with Add button - (By clicking Add Button the disk details as mentioned in the left column gets shifted to right column).

Now for “Secure Erase” - What proper settings are to be made in left / right column? Please guide.

If you want to “secure erase” an SSD or GDD, you have to use a specific tool (e.g. “PartedMagic”). You cannot do a secure erasure of the data from within the BIOS.
You should not create a new RAID Array, but break the already existing RAID Array (if such Array already has been created by you or the former user).
If the NVIDIA MediaShield Utility doesn’t show any already existing RAID Array, although both former used SSDs/HDDs are connected to the mainboard, there is no need for a secure erasure of their data. Just set the NVIDIA SATA Controller to “IDE” and store this changed setting.
After the reboot you should be able to get Win10/11 installed. When you come to the point, where you are asked for the target disk drive, don’t forget to let the OS Setup delete all existing partitions of the target disk drive and to create a new partition for the OS installation. Don’t forget to backup your important data before.

NVIDIA MediaShield Utility does not show any already existing RAID Array when former SSD/HDD is connected to Mainboard. So no need to secure erase.
But then after all the settings done, and reboot - not going beyond BIOSTAR screen – Only Green light LED flickers on CPU unit… no red light flickers. SSD not in power?!! USB ports and DVD ROM – not in power?!! Or should I buy a new SSD and try?

You know better than me, whether the disk drives of your system were members of a RAID array or not.
If you are unsure, I recommend to secure erase the data by booting off an appropriate tool like PartedMagic.

The details about PC are as follows –

Home Desktop PC with BIOSTAR MoBo MBP6PB M2+ ver 6.0 Model - N61PC-M2S Chipset NF-MCP61
with 1 Hard disk = SSD 240 GB
Win 10 Home 32 Bit
BIOS was flashed (previously 2 -3 years ago to upgrade / update 2010) . Do I have to re-flash BIOS?
Athlon 64x2 Dual Core Processor.
Runs on Win 10 2GBx2 Slots = 4GB. (Only 2 slots with max 2GB each available).

Technician at repair shop succeeded (don’t know how) in re-installing from USB Win 10 Home 32 Bit OS after removing RAM from one slot. But I am not convinced that it is a hardware issue. Something is blocking the second RAM slot.

PC runs okay on Win 10 with one slot of 2GB RAM but ends up with the same issue of Detecting Array when both RAM slots are fitted with 2GB RAM each. Earlier (before the issue, Win 10 was running on same PC with 2x2GB RAM properly). How to fix this RAM + Detecting Array issue? I need full 4GB RAM for better performance.

Your report, that only 1 SSD is connected to the mainboard, verfies, that no RAID array has been created and a switch to the IDE mode should be possible, but may require a fresh OS installation (why don’t you use Win10 x64?).
To be able to find out the reason why you cannot use both attached 2 GB RAM modules, I recommend to run a hardware diagnostic tool like HWINFO and/or to swap the connection of the RAM modules.

A fresh / clean Win 10 Home 32 Bit was re-installed successfully with 1x2GB RAM.
(Many programs don’t run on 64 bit and 64 bit is quite confusing as I am used to 32 bit). Re-flashed the BIOS Upgrade again on windows successfully.

If both RAM slots are loaded then PC stops at Detecting Array…
If 1 slot is loaded it runs all okay.
Swapping RAM in slots shows RAM is okay but 1 slot has been identified as the one creating the error Detecting Array. I still doubt it is not hardware issue but perhaps a driver issue.

While making a clean re-install of Win 10, I could not do as instructed – This needs storage drivers to be pre-installed-- as I do not know which storage driver is being asked for. Besides, Win 10 picks its own appropriate driver. Secondly, the Graphic Driver (NVIDIA) do carry 2 extra drivers - 1 of them is SMB Storage driver and other is perhaps Network Driver if installed manually. I have not done a manual re-install of graphic driver.

DUMO freeware shows –
Driver Update

Or is there an error in settings for AHPI, ACPI , AHCI or somethings like that or is it an error / virus in MBR or bcdedit, etc. BIOS settings seem to be okay.
HWiNFO was run without loading the problematic RAM slot. The summary report is as attached –
HWInfo (14.2 KB)

How to fix it?

Edit by Fernando: To save space I have deleted the voluminous HWInfo results and attached them as *.zip archive.

Here is my comment:

  1. If you want to check a maybe faulty device, you should not remove it before running a tool like HWInfo.
  2. NVIDIA MC61 chipsets don’t support the AHCI data transfer protocol. Your on-board NVIDIA nForce SATA Controller can only be run in IDE or RAID mode.
  3. Trying to get rid of the “RAID Array” , you should enter the BIOS and set the NVIDIA SATA Controller to “IDE”. After having done that, I recommend to re-insert both RAM modules and to do a fresh install of Win10 in IDE mode. The best NVIDIA nForce SATA Controller driver for this configuration is the Win10 in-box Microsoft driver named pciide.sys. It will be installed automaticly during the OS Setup. Don’t ty to change the driver.
  4. If your issue should persist, it is the proof, that your currently in-use mainboard has a severe hardware (RAM management) issue. In this case the complete mainboard should be replaced by a not faulty one.

Point 1 - If I add RAM in both slots, then PC won’t Start but give Detecting Array error. So started PC with 2GB RAM in 1 slot and then added 1 GB RAM in second slot in running PC. And then run HWiNFO and these are the results attached.

Point 2- AHCI settings are done after OS install for Vista and 7 by going into Regedit and also for Win 10 on my PC by restarting in Safe Mode. My PC runs with SSD.

PS/2 keyboard is default in BIOS. By connecting a PS/2 keyboard, BIOS is accessible and then setting USB support as Enabled in BIOS, all USB run okay. And Win 10 OS can be installed from USB.

Point 3 – In BIOS RAID is Disabled by Default.
The Drivers were changed using 3rd party updaters to see if it makes some changes to this old PC. Can be rolled back anytime. But it was worth noting that NVIDIA nForce Serial ATA Controller shifted its position from Storage Controllers to IDE ATA/ATAPI Controllers and yes, it is not the latest version. Latest version comes with Win10 OS setup.

Point 4 - I am hopeful. I know the answer lies somewhere in your commented points 2 and 3. I shall keep trying.


You cannot choose or change any AHCI settings, because your mainboard doesn’t support AHCI.

The installation of any nForce SATA (RAID?) driver was a mistake. Only the Win10 in-box MS SATA driver named PCIIDE.SYS supports your on-board nForce SATA Controller while running in IDE mode. Furthermore this MS driver is the only possibitlity for you to get the SSD perfectly cleaned by using the TRIM command.

1- Something had helped my PC when it was switched from HDD to SSD and when on Vista / Win7 -
and may be on Win 10 –
2- But to pre-install pciide.sys while making a clean re-install of Win 10 OS, upon Load Driver - it searches for .inf file and not .sys file. So I could not pre-install this driver before Win 10 OS install.
3-Moreover, TRIM is enabled. Whether it worked or not ???

… Just trying to re-create events/mistakes to find out what really went wrong and how to fix it.
And why I went to manually update drivers with 3rd party updater on Win 10 was because PC got repeated BSOD at long intervals due to ndis.sys (not ncis.sys-- as mentioned in first post - And that was with all drivers as comes up with Win 10 setup / install (no 3rd party)) and then another BSOD - nvlddmkm.sys. (that was with wrong drivers as selected by me on random). Now with 3rd party drivers (perhaps due to my correct selection), I did not get any BSODs. Something is left out half-baked in my PC. Trying to sort it out before going in to hardware (RAM slots)…Text

After having read all your posts it seems to me, that you may only have updated the OS, but never done a clean OS installation since Vista times. If my impression should be real, it would have been a very big mistake and may explain all your troubles.
Here is my statement to your last post:

  1. Your used “Switch from IDE to AHCI” and “RAID to AHCI” tools cannot have the desired effect for your system, because your mainboard’s NVIDIA nForce chipset doesn’t support the AHCI protocol at all (as already written above).
  2. All Microsoft Operating Systems from Windows XP have the generic SATA IDE driver named PCIIEDE.SYS in-the-box (but with different versions and properties). Provided, that the system drive (SSD or HDD) is connected to a NVIDIA nForce SATA port running in IDE mode, there is nothing to load at the beginning of the OS installation - the OS own IDE driver will be automaticly installed and the related IDE Controller will be listed within the “IDE ATA/ATAPI Controllers” section of the Device Manager as “Standard Serial ATA Controller”.
  3. Regarding the TRIM support it is not enough to check, whether the TRIM command has been sent. Much more important is the question, whether TRIM has been arrived within the SSD cells. Neither NVIDIA’s SATA AHCI Controller (of newer nForce chipsets) nor NVIDIA’s SATA RAID Controllers let the TRIM command pass through. If you want to know whether your SSD is continuously TRIMed, I recommend to run the “TrimCheck Tool”. You can find the related download link and the guide within the start post of >this< thread.