DFI LanParty BI P43-T34 AHCI problem

Hi, is there any possibility that I can install ahci on that board?
(ICH10 on bios only Legacy mode enabled/disabled option) AS SSD software tells PCIIDE - bad.
Tried to install Fernando mod drivers for ICH10 but it tells that I have valid drivers installed and I cannot force to install other (I’m not sure I do it well).
On installation of Fernando modded Intel RST drivers v11.2.0.1006 It’s says that Your system doesn’t have requirements (or something I don’t have English version).
I make a little research and:
CBROM.EXE B345D527.BIN /D my bios returns:
No. Item-Name Original-Size Compressed-Size Original-File-Name
========================================================================
0. System BIOS 20000h(128.00K) 1576Bh(85.85K) B345D527.BIN
1. XGROUP CODE 0CCF0h(51.23K) 08EF1h(35.74K) awardext.rom
2. ACPI table 04E21h(19.53K) 02030h(8.05K) ACPITBL.BIN
3. YGROUP ROM 0D3A0h(52.91K) 06F19h(27.77K) awardeyt.rom
4. GROUP ROM[ 0] 07F50h(31.83K) 035ADh(13.42K) _EN_CODE.BIN
5. SETUP0 027D0h(9.95K) 00EB3h(3.67K) _ITEM.BIN
6. BIOSF0 018E0h(6.22K) 0114Fh(4.33K) _DMI.BIN
7. FLSH CODE 02530h(9.30K) 00E07h(3.51K) SPIFLASH.BIN
8. SMI32 00010h(0.02K) 00038h(0.05K) SMI32COD.BIN
9. SMIAP 003F0h(0.98K) 002FAh(0.74K) SMIAPCOD.BIN
10. 1 PE32 in MB 11241h(68.56K) 112B5h(68.68K) MEMINIT.BIN
11. GV3 0296Dh(10.36K) 00E61h(3.59K) PPMINIT.ROM
12. ISA ROM[1] 04000h(16.00K) 0294Ah(10.32K) AHCI_ROM.BIN
13. LOGO BitMap 4B30Ch(300.76K) 1A2A9h(104.67K) BI_P43-T34.bmp
14. EPA LOGO 00DD0h(3.45K) 006AEh(1.67K) ABS2-B11.bmp
15. PCI ROM[A] 0D800h(54.00K) 05DC0h(23.44K) PXE_250.lom
SP) NCPUCODE 20000h(128.00K) 20000h(128.00K) NCPUCODE.BIN


Best regards!

@ adlerfromsc:
Welcome at Win-RAID Forum!

Yes, if you can enable AHCI within the BIOS.
The presence of an Intel AHCI ROM within your mainboard BIOS indicates, that it may work.

That means, that your system is currently running in IDE mode and that your partition system has not a correct alignment.

Which OS are you running? How did you try the installation?
If you have the BIOS option to set the Intel SATA Controller to "AHCI" mode, you should be able to get the "Universally modified" Intel RST driver v11.2.0.1006 installed.

Regards
Dieter (alias Fernando)

Thanks for reply.

I don’t have AHCI option in my bios.
I have Win 7 and I tried with “Universally modified” Intel RST driver v11.2.0.1006.
On setup.exe I’m getting error message “The platform is not supported” (In other language so I’m not sure is well translated).

Then you will not be able to run the SATA ports of your mainboard in AHCI mode.
The installation of an AHCI driver doesn’t help, because the on-board Intel SATA Controller is always running in IDE mode.

… and probably there is no option to modify BIOS or something …

In Bios in "On chip configuration IDE" I have only option Legacy disabled/enabled mode.



I cannot even force to install AHCI drivers.

Anyway thanks again, so I must change mobo to oldest P5Q Pro:/ or buy a new one:/


http://en.wikipedia.org/wiki/List_of_Int…tium_4_chipsets

This board is P43 mine is P45 I have ICH10R (raid possible), P43 has ICH10 (no raid). In the OP it is stated the bios has an option for the ICH10: enable legacy mode/ disable legacy mode. Clearly ACHI is with the option set to disabled.

Before you change the bios setting, install this: MicrosoftFixit50470 It enables the microsoft standard drivers for ACHI mode which were not loaded when you installed the OS in legacy IDE mode.

I don’t know if your bios needs modding to use the RST driver, mine did. The info you provided about your bios may indicate either way to someone with knowledge of bios rom slips.

You can load Intel matrix storage manger drivers if your bios is pre mod.

You would have to modify the code of some system BIOS modules and this action may brick your mainboard.

If you would have succeeded, you wouldn’t be able to boot into the OS.

This would only make sense after having enabled the AHCI mode within the BIOS.

ICH10 (Consumer) does not support RST AHCI. But, there is hardware support for AHCI as long as it’s implemented properly at the BIOS settings and an AHCI driver is loaded afterwards.

1.PNG

2.PNG



And there is my problem. When I disable Legacy mode (so as a bios say I’m in native mode [“ahci”?]), set my ssd to sata port 0 windows 7 restarts (I suppose on loading or installing new drivers) and windows 8 says drive is locked. Installed Microsoft Fixit50470 but also not resolve my problems.

On P5Q Pro I don’t have any problems with ahci:/

As long as it is not possible to enable "AHCI" within the BIOS, it will not work.
The search for a suitable AHCI driver is no problem.


Obviously, but it may not be called “AHCI”. Depending on OEM, there could be an option Legacy Enable/Disable. Enable means PATA and Disabled means AHCI. That’s general, I don’t know how this OEM did things.

When the enabled "LEGACY" setting means P-ATA, then the disabled option means "S-ATA" and not AHCI.


I’m aware of that, I meant to write IDE. Either way, PATA=IDE & AHCI requires SATA so “technically” it was not wrong. Maybe after disabling Legacy (PATA), another menu will appear.

@ adlerfromsc: Can you show a picture of the BIOS settings regarding storage controller?

Sorry the microsoft fixit did not work for you. I googled “does ich10 do ahci” and found another way to enable it: http://forums.hexus.net/motherboards/112…tml#post1763795

Note that the post talks about ich9/ich9r, so that is another hint that ich10 has the capability to perform in AHCI mode.
http://ark.intel.com/products/34392/Inte…B-IO-Controller = ICH10
http://en.wikipedia.org/wiki/I/O_Controller_Hub

Here you go:

20150205_230705.jpeg


20150205_230725.jpeg


20150205_230747.jpeg

Judging just by the menu name (OnChip IDE Device) this BIOS does not support AHCI. The platform does (with no RST) but if the OEM has not implemented it properly then you can’t do anything.

Regarding the Legacy option, it has to do with Compatible vs Native IDE mode. Not with AHCI.

The JMicron controller is also PATA so there’s nothing else to try.

Thanks for all, so the last hope is gone:)
I switch to P5Q Pro…

82801IB (ICH9) Base officially neither AHCI or RAID support, but a simple driver INF edit shows it supports AHCI without problems
http://en.wikipedia.org/wiki/I/O_Controller_Hub#ICH9

I would say its a bit early to give up on this, if you have the desire to look into it yourself. I’m sure u could get help here if u wanted to mod the driver (see above).

Where is the driver I shall mod? I don’t see any.
By the way: All my modded Intel RST drivers do support the DeviceID of your on-board Intel ICH10 SATA Controller, if it would run in AHCI mode.
Furthermore the installation of any AHCI driver will fail as long as the on-board SATA Controller hasn’t been set to “AHCI”.

Where is the driver I shall mod? I don’t see any.
By the way: All my modded Intel RST drivers do support the DeviceID of your on-board Intel ICH10 SATA Controller, if it would run in AHCI mode.
Furthermore the installation of any AHCI driver will fail as long as the on-board SATA Controller hasn’t been set to “AHCI”.




I tried install modded Intel RST With legacy option enabled/disabled and I can’t install it. EOT.
I must buy new mobo or go back to P5Q Pro:/