[Discussion] UBU Tool related Questions, Reports and Suggestions

Respected Experts i am very new to this forum & dont know anything about Bios Modding.
i hope experts must help me getting the latest updated roms for the Bios i am looking :

Specs via the Great UBU tool by Sir Sonix as follows

Scanning BIOS file TZ370PG.CAP.
Please wait…
Manufacturer - ASUSTeK COMPUTER INC.
Model - TUF Z370-PLUS GAMING Rev X.0x
BIOS release - 2801 01/13/2021
BIOS platform - AMI Aptio 5

[EFI Drivers - Find and Extract]
Intel RST GUID 91B4D9C1-141C-4824-8D02-3C298E36EB3F
Intel GOP SubGUID 380B6B4F-1454-41F2-A6D3-61D1333E8CB4
AMI NVMe GUID 634E8DB5-C432-43BE-A653-9CA2922CC458
Intel Undi GUID B1DA0ADF-4F77-4070-A88E-BFFE1C60529A
Intel Undi GUID 4953F720-006D-41F5-990D-0AC7742ABB60
Intel GOP VBT GUID 878AC2CC-5343-46F2-B563-51F89DAF56BA

[OROM - Find and Extract]
VBIOS in Padding
VBIOS in GUID A0327FE0-1FDA-4E5B-905D-B510C45A61D0
OROM in GUID A0327FE0-1FDA-4E5B-905D-B510C45A61D0
OROM in GUID A0327FE0-1FDA-4E5B-905D-B510C45A61D0
Press any key to continue . . .

after pressing enter

Main Menu
[Current version in BIOS file]
1 - Disk Controller
EFI Intel RST for SATA -
OROM Intel RST for SATA -
EFI NVMe Driver present
2 - Video OnBoard
EFI GOP Driver SKL-AML - 9.0.1080
3 - Network
EFI Intel Gigabit UNDI - 0.0.13
OROM Intel Boot Agent CL - 0.1.10
4 - Other SATA Controller
5 - CPU MicroCode
S - AMI Setup IFR Extractor
0 - Exit
RS - Re-Scanning
A - About

Thanks a lot in advance :slight_smile:

Welcome to the Win-RAID Forum!
Your post has been moved by me into this better matching thread.

As first step you should read the UBU Guide, which is within the start post of >this< thread.
After having done that, you can post here the questions, which are not answered within the Guide. Don’t forget to give us the following information:

  1. Which BIOS modules do you want to get updated?
  2. Is the on-board SATA Controller running in AHCI or RAID mode?
  3. Do you use the Wake-on-LAN option?

Enjoy the Forum!
Dieter (alias Fernando)

1 Like
  1. Sir i want to Update all BIOS modules which are found old via UFU tool as per latest updated repos by there devs.
  2. on board sata controller is in AHCI mode with rst enabled ( ( i will take a snapshot of it & will post here)) : 1st M2 slot direct under cpu : wd 250gb 3d nand blue m2 sata ssd +Second M2 Slot : intel optane 32 gb . i also have samsung 980 pro 1 tb PCIE m2 2280 so that i will swap it with wd ssd when i need.
  3. no sir never used wake on lan.

Edit | Images of sata controller : 1 - Album on Imgur

Since you neither use the Intel RAID nor the Wake-on-LAN option, an update of the Intel RAID and Network BIOS modules will have no effect on your current system (no benefit at all).

1 Like

ok sir i will go only with latest Disk Controller ROM .
Pl let me know which rom will best suit this hardware as i think is old :slight_smile:

As I already have written, your system will not use any Intel RAID BIOS module, because the SATA Controller is running in AHCI mode. If you want to update the Intel EFI RAID module nevertheless, you can find the latest/best ones within the start post of >this< thread.

1 Like

HI all,
I Just got from ASRock tech support a new version of bios, with new microcodes, but it doesnt resolves the problem with CSME detection tool, it is still “This system is vulnerable” situation.
Anyway, i opened it with the UBU tool and it shows that the microcodes are not in the database. Provided MEGA link in the tool itself, doesnt work. So how do i send the microcodes to be uploaded in the database?
And my MB is ASRock Z370 Pro4.


Can you share the BIOS file?

Z370P4_4.zip (8.9 MB)
There you go!

Did you implemented the update for the ME CSME 11.8 CON H DA v11.8.93.4323
The CSM tool will inquiry the board ME fw revision.

All tools and MEGA links for the Intel Management 2-15 thread are working correctly.

EDIT: This has nothing to do with UBU, the guide is here: Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15)

1 Like

I dont know how to do that. There is a problem with UBUTool and ASRock boards with newer APTIO V BIOSes. I allways get the “parseFile: non-empty pad-file contents will be destroyed after volume modifications” , and I don’t know what that means and how to overcome it. Also, when I try to update BIOS with that modified BIOS file I get some error. So i asked the ASRock tech support and supprise, they replied with the updated microcode in BIOS but without updated CSME. So that’s it…

It worked flawlessly!

1 Like

UEFI BIOS Updater v1.79.17 did not updated till 3-Jul-2021.

Did the project ended?

This is a user tool project, the user has not provided any further updates since then.

The tool itself doesn’t need an update. UBU users, who want to get the latest available modules inserted, can put them into the related sub-folders of the “Files” directory.

did i insert the wrong file?
my device is Asus X455LD notebook with haswell cpu

You obviously did not follow the advices of the _Readme.txt file, which is within the Files\intel\RST subfolder of the UBU tool:
You have to make sure, that within the related RST subfolder the desired (latest) Intel RST Option ROM RAID module has been named “RaidOrom.bin” and the desired (latest) Intel RST EFI RAID module has been named “RaidDriver.efi” before starting the UBU.bat command file.
Only in this case the UBU tool will find the matching updated Intel RAID module.

my bad, i downloaded the file from this topic AHCI & RAID ROM Modules and it has .bin extension

Can anyone help? Why is Ubu not replacing the microcode for my AMD laptop bios?
[REQUEST] Vivobook Pro 14 (M3401, AMD Ryzen 5000 Serie) - Bios SMU/Microcode upgrade - BIOS/UEFI Modding / BIOS Modding Requests - Win-Raid Forum (level1techs.com)

My attempt:

  • Get the MMTools and rename as described
  • Updated MCU to latest version
  • Get MCU microcode repositry and paste all AMD microcode into Ubu/Files/AMD/mCode/AM4
  • Run Ubu and try to update microcode but failed…

Hello I updated my Z97 Marks S with a modified bios file from UBU.
I did this already around 3 - 5 times in the past successfully.

Unfortunately I’m having currently this issue:

  • XMP / Ram Settings aren’t changeable.
  • Normally my RAM is capable of 1600 MHz through it’s XMP profile and normally I’m using the RAM with a frequency with 2200 MHz.
  • Now matter what I’m changing Frequency or Timings, the settings won’t change and the RAM uses it’s stock settings (1333 MHZ).
  • I’ve already tried to rollback to stock BIOS, removed CMOS battery, using only one RAM module instead of 4, etc… without any success… RAM settings still locked smh.

Has here maybe someone a clue how I can fix the issue?