[Discussion] UBU Tool related Questions, Reports and Suggestions

@westlake :
Can you provide a modified ubu tool?

Edit by Fernando: Unneeded fully quoted post replaced by directly addressing (to save space)

I don’t think SoniX would be happy about that.

My motherboard is asus ProArt X570-CREATOR WIFI
I have tried to replace the orom in ubu or use mmtool to update the orom in the bios file
But cannot start (black screen)
plz help&thx

my bios file : https://www.sendspace.com/file/6rz0k6


Which OROM? The 0540 version is new (2021/12/15), almost everything is the latest.

EFI AMD RAIDXpert2-Fxx - 9.3.0-00221 -> 9.3.1-00029
00800F12│08001250│2019-04-16 -> 00800F12│0800126C│2020-06-19
00810F11│08101102│2018-11-06 -> 00810F11│08101103│2019-04-17

Modded BIOS file.

UEFI BIOS Updater v1.79.17

Have Problem with Checksum that do not acepted the bios and showing MicroCodes. So I can not update.

Gigabyte B560 AORUS PRO AX (rev. 1.0) - Firmware vF8 Uploaded.
There are the disc controller very old (v18) too.

mb_bios_b560-aorus-pro-ax_f8_n.zip (11 MB)


Is Gigabyte Q-Flash supposed to work with UBU-modded BIOS files? Gigabyte B560 DS3H motherboard here and Q-Flash detects UBU-modded BIOS as corrupt if I try to flash from within BIOS. Should I use the Q-Flash button instead?

UBU is lacking a little support for recent chipsets and hasn’t been update for a while… i would be careful, but if the board has Bios Flash Back we may assume that we can recover.
Older boards could be updated (mod) from bios Q-Flash… dont know how the Q-Flash Plus button function will react, if detects any corruption also or other security prevents or in worst case it will flashes the mod till the end and
the board will boot or not, your choice here.
Or wait for some one with similar chipset generation/Gigabyte motherboard, that already tried mods on it.

A final note: New bios files from Gigabyte are presented now with a “new” CAPSULE method… this can be an issue.

"Introduce capsule BIOS support starting this version.
Customers will NOT be able to reverse to previous BIOS version due to major vulnerabilities concerns."

A previous method also used before in several bios, was the extraction of the bios region from the capsule, mod and then replace back in capsule bios, done with UEFI tool or HeX.
Another method used before… by the Intel FPT tool (From the correct Intel ME FW tools package), as long as bios regions are accessible.

Modded BIOS file.

"There are the disc controller very old (v18) too."
Absolutely not old. The V19 belongs to the 600 series.

EFI Intel RST RAID Driver - ->
OROM Intel RST for SATA - ->

EFI GOP Driver SKL-CML - 9.0.1111 -> 9.0.1112

EFI Intel Gigabit UNDI - 0.0.29 -> 0.1.02
OROM Intel Boot Agent CL - 0.1.15 -> 0.1.16

And I manually replaced the old microcodes:

A0653, EA, 2021-03-08 -> EC, 2021-04-28
A0655, EC, 2021-03-08 -> EE, 2021-04-28
A0670, 2A, 2020-09-23 -> 2C, 2020-11-24
A0671, 40, 2021-04-11 -> 50, 2021-08-29

@MonarchX , @Waly
And yes, use the Q-Flash Plus Button.

But everyone does this at their own risk!





How to update intel csme the way other bios image components are updated?


That doesn’t work. The BIOS Region and the Intel ME Region are completely different parts of the mainboard’s BIOS chip.

Thanks for quick response.

Thats weird because i was able to flash both bios and intel me from single bios.bin file using my MSI mobo.

I erased my chip completly and reprogrammed it using ch341a and it updated my bios as well as me region also i had the same output using m-flash and fpt.exe -f bios.bin

What am i missing here because im pretty sure both me region and bios are part of msi image that is 8.192 in size. Maybe those images that Intel provides are not compatibile with the version of me region that is inside those official msi bioses? I find no other explanation

@podkaracz Use the guide for cleaning ME, but insted of using same version use latest version.
This may have some caveats, f.ex. ME 9.0 bios not prepared for ME 9.1, ME 14.0 missing some sub- volume that might be required for 14.1 (may be present as dummy)

Normally way via fwupdlcl is shorter…

I know that this program can add and update bioses for x79 and x99 Chinese boards.
But is it possible to add 5600g or 5600x microcodes to x370 board ?

Hi there. sometime in the future, it is conceivable that it will support the 12th generation intel platform?

I found a bug in the latest version of UBU while updating BIOS version 4101 for the ASUS X99 Deluxe (Version I). After updating both Intel LAN EFIs to the latest versions (0.1.02 for I-218V and 9.7.06 for I211), I did a rescan. The second Intel LAN EFI was no longer detected. I investigated a little. If I replaced \Files\Workfiles_List_Extro.txt with the version from UBU, then UBU was able to find the missing EFI during a scan.

I won’t actually be testing out this updated BIOS to see if it works. I was only experimenting with the UBU tool. I hope this bug report helps.

The modified BIOS is attached.

X99D.zip (8.1 MB)

hey folks,

I’ve used UBU in the past to update CPU microcode and lan adapters. However, when I attempt to update lan and cpu microcode in my Asus Z490-E (in preparation for my 10900-KF), lan adapter doesn’t update, and cpu microcode don’t all say yes after updating. i have the latest mceextrator and the proper mmtools, what am i doing wrong?

attached is the picture with some things in the last column showing “no”, despite running the replacement. any advice? i’m new so i can’t post the link to the original bios, but just google Asus Z490-E and it will be the first google result, then check under support. Thanks.

bios updater issue.png


I modded for you. EFI Intel PRO2500 UNDI, and OROM Intel Boot Agent GE is the latest. OROM Intel Boot Agent GE 1.5.89 belongs to another branch.



i´ve read that the UBU Tool cannot update an Award BIOS.
I want to update my Gigabyte GA-990FXA-UD5 to a newer AHCI, sadly…Award BIOS :frowning:
Is there a way to do it "easily" ? Thx

UBU only works with the Rev 3.1 of the motherboard/bios.
For Award here: [Guide] Award/Phoenix BIOS Modding
But not easy as UBU of course.

Thx, i will have a look :slight_smile: