Eluktronics Mech-15 G2-Rx Disabled CSME

@plutomaniac Many thanks for all the information ! My laptop Eluktronics Mech-15 G2-Rx (ME version is was soft-bricked after a failed undervolt attemp via the BIOS. Eluktronics said I have to replace the mainboard but it was almost impossible for me to send it to the US, then I had a computer service here in VN revived it but with a different Bios of Mechrevo X9Ti, but the ME FW version doesn’t show in BIOS, MEInfo result is “ME is disable”. I could not install ME software ,too. After reflashed the BIOS with a stock ROM and EC file provided by Eluktronics in Bios just the boot image, ROM version+Manufacturer is changed back to Eluktronics, my Machine ID and UUID, Serialnumber is still of Mechrevo, and the ME status is still the same.
Strange is with MEIAnalyzer the SPI dump show the full info of both CSE ME and PMC, ME dump is OK, too. Should I flash the newest matching CSME+ PMC from your post, get ME to work and then try reflash BIOS ROM to get back the original info or should I clear the ME region first, and how can I do that ? Your help is highly appreciated !


If you don’t have a backup of the original SPI/BIOS image then you’ve lost the serial numbers and other similar stuff stored in the BIOS region. For the CSME firmware, if the currently flashed SPI image is proper (the one the OEM gave you) then you can clean it via [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization. What SPI/BIOS image did they give you and how did you flash it? Maybe you re-flashed the BIOS region only and not the full SPI chip (FD + CSME + BIOS) so the system is still running that CSME firmware from the other system (Mechrevo X9Ti). Could be that the repair shop used some dumped image from the web (initialized, needs cleaning) but if the model was also different then the CSME settings might be wrong too.

@plutomaniac I attached 2 files they gave me, pictures I took of the BIOS 1st page before, with the wrong BIOS and at the momment and my current spi dump too, I don’t have the original Bios spi dump. I followed their guide first flash ROM, then update EC with the second file( boot uefi, run F.nsh, reboot…) without success so I open the .nsh they gave me the command was “AfuEfix64.efi GK5CP0ZN152.ROM /p /b /n /r /x /l /reboot” and “IFUX64.efi GKxCPQ20.409 0 1” for the EC file. Later I notice the EC file they gave me have the name GKxCPQ20.409, the same with the current Machine ID I wanted to overwrite (which is Mechrevo X9TI R series GK7CPQ) and not GK5CP0Z of my original BIOS and I mailed asking them but they said those are the only two files they use in production provided by Tongfang. The original EC version is the same 4.09 so I think it might be true and Eluktronics people they could not help any further due to the limited assets/knowledge or their lack of will in doing so, I don’t know. Luckily I joined the forum in Feb intended to unlock my BIOS, so I came here read your post about ME and it’s like a saving boat for me :slight_smile:

bin.zip (4.21 MB)

spidump.zip (5.76 MB)

Yes, they gave you the BIOS region only, not the full SPI image. Well, to fix the CSME firmware, follow [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization on your 16MB SPI image dump. To flash it back, do you have a hardware programmer? If not, you need to check if you have an unlocked Flash Descriptor (read/write access to CSME firmware region) via [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing. Once the FD is unlocked, you need to use Flash Programming Tool via “fptw -f outimage.bin” followed by “fptw -greset” and after the forced reboot, the CSME should be operational.

I don’t have a hardware programmer but I think the Flash Descriptor of mine is unlocked. I just learnt to dump the spi image just from that post, and I can dump the desc.bin too so it must be opened. Let me follow your guide and try. Again thanks a lot !

Well dumping/reading may be allowed but it could be that flashing/writing is disabled. The instructions at that thread should be updated. Anyway, run Flash Programming Tool with "fptw -dumplock" and show me the result.

fptw.exe -dumplock result is invalid command. Here is info with -i and -spibar if it could be of any help, also the desc.bin I dumped. Would you kindly have a look at the ME drivers packet Eluktronics provided for my model on the website, here’s the link: (together with other drivers 2GB)
Or here only the ME file 130MB from my Onedrive : https://1drv.ms/u/s!As1Cv9tRxdLJjcIXJw9fRZFhF9QnTg?e=Pi8MYM
Should I use the CNPH_B_PMC_300.2.11.1019_prod.bin combine with CSME_FW_Consumer_CNP-H_PCH_Production.bin to create a SPI.BIN from folders CNP-H\PMC(or CSME)\Production or I should use the ones from Pre-production folders? I reckon this packet is from Eluktronics for my model it should fit perfectly for my system with all the functions included( provided can be flashed successfully). And what with “CNP_H_B_Cons_FWU_Base_Production.bin” from the CNP-H\FWUpdate_bin\Production\ , is that the unnecessary FWU base image you mention in your post or it’s a ready-made one fom Eluktronics for clients to directly flash and update ??


desc.zip (466 Bytes)

As suspected, you have Read but not Write access to the CSME firmware region of the SPI/BIOS chip. So you need to get Write access as well first by trying the steps at [Guide] Unlock Intel Flash Descriptor Read/Write Access Permissions for SPI Servicing. Once that’s done, you’ll need to repair the CSME firmware, as explained above. The archive provided by the OEM is a full CSME kit (firmware, tools, docs) provided by Intel to OEMs and in no way tied to a specific model or yours.

Thanks, guess there’s no easy road for me then ! The FD post is a completely new jungle for me as I have no engineering/programming experiences. Btw, will it cause any damage if I try to flash again the ROM file OEM gave me with fpt. I’ve just read on some other posts Lost N bios said not to use the AFU, and I just flashed it with AFU only followed the guide from Eluktronics, and my UUID as well as Machine ID has not changed back, hence ME not matched, too ?

The BIOS info (UUID etc) will never change back by themselves. These were lost in the original BIOS which was not saved. Since you have a picture before all these were lost, maybe Lost_N_BIOS can help to bring them back. But honestly, that’s not really important until the CSME issue has been solved. As for flashing, if you want to re-flash the stock BIOS region (not full SPI) they gave you, you can use the provided instructions via AFU or by using Flash Programming Tool (fptw -bios -f GK5CP0ZN152.ROM) followed by “fptw -greset”. After the forced reboot, check if the CSME problem persists. If it does, it means that the CSME firmware needs cleaning. Maybe you can bring the laptop back to that local service shop of yours, which I assume uses a programmer to dump and re-flash the SPI chip. In that case, we can provide them with what to flash and they simply flash it.

Yes, I can help you put back your UUID, Serial, but MAC ID is either stored in chip or in GbE region and I don’t have full dump of GbE region on this system so you’ll have to provide that and then I can edit for you to flash it back (if this region exists)
Please do as noted below in spoiler and send me both files

If you do not have Intel ME drivers installed, install them now from your system driver download page, then start over here after reboot.
Check your BIOS’ main page and see if ME FW version is shown. If not then > DOWNLOAD HWINFO64 HERE <

Once HWINFO is open, look at the large window on the left side, expand motherboard, and find the ME area.
Inside that section is the ME Firmware version. Take note of the version. (ie. write it down or get a screenshot)

Once you have that, go to the thread linked below, and in the section “C.2” find and download the matching ME System Tools Package for your system.
(ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
> DOWNLOAD " ME System Tools " packages HERE <

Once downloaded, inside you will find Flash Programming Tool folder, and then inside that a Windows or Win/Win32 folder (NOT x64).
Highlight that Win/Win32 folder, then hold shift and press right click. Choose “open command window here” (Not power shell! >> * See Registry file below *).

If you get an error, reply to this post with a screenshot of it, OR write down the EXACT command entered and the EXACT error given.

((If “open command window here” does not appear, look for the “Simple Registry Edit” below…))

Now you should be at the command prompt.
You are going to BACKUP the factory BIOS & GbE region, so type the following command:
Command: " FPTw.exe -bios -d biosreg.bin "
Command: " FPTw.exe -gbe -d gbe.bin "

>> Attach the saved "biosreg.bin & gbe.bin ", placed into a compressed ZIP/RAR file, to your next post!!! <<

Here is a SIMPLE REGISTRY EDIT that adds “Open command window here as Administrator” to the right click menu, instead of Power Shell
Double-click downloaded file to install. Reboot after install may be required

Flash programmer to fix the ME FW is cheap and fairly easy to use, you just have to wait for long delivery or pay more to get it faster, if you want linked examples to the items you’d need let me know. Or, you can do the pinmod in above guide.
Tape off all other pins, and do the FD pinmod unlock method “E.1” on the guide linked at post #8. If you do that, do not reboot once you do it, you then need to dump FD (FPTw.exe -d fd.bin) and edit it, per section “B” of that same guide, spoiler two, image 1 or 2, then flash it back (FPTw.exe -f fd.bin)
If you do this pinmod and you can’t figure out how to edit FD, don’t reboot, upload the the file and we will edit for you to unlock it. Then you can use FPT to fix ME FW.

Yeah @plutomaniac nothing changed. I’m clueless now as it seems I don’t have a gbe region, don’t have a EC region (fptw -d -ec and fptw -d -gbe both failed, command result is no such partition), my ME region is disable( but I can dump it), my FD is no-write and honestly I don’t even know where my flashchip is located, in case I want to flash it by hardware programmer. So your idea is quite good actually.

@Lost_N_BIOS thank you for involve in my own mess . I was unable to dump the gbe region, but my Lan card is present and working ok the whole time, might be slower since I lost the ME ?! . It’s Mac address also haven’t changed since original Bios until now. I’ve watched a few Youtube videos about flash programming they all required de-soldering then re-soldering the chip, right? If that’s the case then I might have to bring it to the computer shop because i have very unsteady + clumsy hands. I’m too busy these two days I did not have time to open my laptop and check my chip for details. But in my area there is one seller
is it one ok? and what other accessories I should buy to connect .
Link to my Biosreg, spi dump, original UUID as well as other things are here https://1drv.ms/u/s!AhOZeebMGMoNmAnaDYatFyey3ds0?e=EFmhS5
My plan is try to fix my stuff first and then join your thread “OverPowered TONGFANG CyberPower Machrevo” to unlock my Bios, when you help me put back the UUID do you think you could make it unlocked , too? :slight_smile:

@ynhutranh - Sorry, I missed your reply until now! No, you don’t have to desolder chip, you would use a clip with cable to attach to the BIOS, it’s easy and people with no experience do it all the time, so don’t let it scare you
Yes, that programmer you linked is what you need, but you also need one of these - https://www.ebay.com/itm/183425731977
Sometimes those are bundled with programmer too, so you may be able to find bundle kit.

So, you need serial/UUID fixed and this BIOS (BIOSreg) unlocked, correct?
Does ME FW need fixed too, or did you already sort that out? << that would require programmer to put back in, unless you did pinmod and unlock the FD

@Lost_N_BIOS To answer your question is YES and YES.
And my ME FW problem is still not fixed.
I almost gave up after my attempt to pin-mod but when did opened my laptop I realized everything is sooo much smaller than what I was imagined and could not figured out where the sound chip nor the BIOS chip is. My flash programmer order will arrive in a few days. Pls have a look at the photos I took of the mainboard and point me out where the BIOS chip is if you could.

Bios Area IMG_20200704_105225656.jpg

Mainboard IMG_20200704_105149073.jpg