Enabling Secure Erase in Z170 OC Formula

I have a BIOS from Asrock which has Secure Erase enabled (Z17OCF7.40B) which is different from the non Secure Erase one (Z17OCF7.40). I also have a modded BIOS that enables Coffee Lake-R CPUs to work (Z17OCF7.51A). I have tried to enable it using AMIBCP with no success. I am trying to enable Secure Erase in the Coffee Lake-R Bios. Is there a way to copy the feature from one BIOS to another?

@MrJack - Upload Z17OCF7.51A I will check it for you, also include Z17OCF7.40B in case there is a module that needs copied over.

Here you go.

Z17OCF7.40B.part1.rar (5.9 MB)

Z17OCF7.40B.part2.rar (2.01 MB)

Z17OCF7.51A.part1.rar (5.9 MB)

Z17OCF7.51A.part2.rar (2.26 MB)




It’s not there in AMIBCP in BIOS Z17OCF7.51A, so how could you have tried to enable it? Ohh, I see it now, I wasn’t expecting it to be there (it’s not where it should be based on your other BIOS images for the board it is working in)

*Edit - @MjJack - First, try this AMIBCP edit only from my end, so we can be sure AMIBCP can enable or not (It’s in advanced page on this BIOS, not in “Tool” page). Or, this method may add it’s own top menu tab/section after “Tool” tab, I am not sure, it’s an odd layout in there

If that does not work, I will make try another method.

I was referring to 7.40 which has Secure Erase Disabled. I tried to enable it to see if I could somehow copy it over to 7.51A. The Asrock implementation is not the default one that is dormant in AMIBCP Bios. They added this module. I have tried enabling it in other versions of the Bios using the "user" or "supervisor" option but it would not show, and I do not know how to copy a feature from one bios to another.


Yes, see edit above, I found it, sorry for the initial confusion

If you have flash programmer, or BIOS switch between BIOS 1/2 on this board, you could try a straight up “Setup” module swap (Or PE32 from within setup) from one to the other.
Try my edit above, if that does not work we can try other methods. It may be what you tried already, but maybe you forgot to enable at the root level too?

*Edit - I see now, in 40B, it’s ASR Secure Erase Tool, totally different thing than the “Secure Erase” we see in all these BIOS in AMIBCP.
This will probably at minimum require a setup module swap from 40B to 51A, possibly also AMISTE and AMITSE Setup Data
There is a secure erase module at GUID FB62F7F0-5433-11E4-B810-402CF41D8A90, and it differs by two bytes in 40B vs 51a, so I think this, Setup, and AMITSE swap all should be done (AMITSE secure erase is found in 40B, not in 51A)

Does your board have BIOS switch, or do you have flash programmer?

Here is 7.40. The Secure Erase added in 7.40B is not the one that is disabled in 7.40. It is a different module.

Z17OCF7.40.part1.rar (5.9 MB)

Z17OCF7.40.part2.rar (2.01 MB)

Compare 7.40 and 7.40B they are identical apart for Secure Erase. 7.51A is very different as it enables Coffee Lake-R in Z170. Yes my motherboard has a Bios switch.

Good your board has BIOS switch! This way, if I send you BIOS that fails, you can boot to BIOS, enter built in flash tool, then switch to the failed BIOS before pressing enter to flash the failed BIOS instead.
I noticed the secure erase are different, did you see my edits in post #6 this morning? I think I can make BIOS for you! Give me some time tonight, I will get this done for you here in a little while.

*Edit - @MrJack - did you test the BIOS I posted above? I know it’s the wrong Secure Erase, but I wondered if a Secure Erase section of any kind showed up in the BIOS?

Here is module swapped BIOS to test 51A, but I am sure this will affect some of the Coffee Lake-R features shown in BIOS settings, like core count etc (Possibly all) Please test with other CPU first.
I know this negates the reasoning behind using 51A BIOS, but it’s only way I know to move these settings between BIOS like you wanted.
This has Setup, AMITSE and “Secure Erase” modules swapped

In the end, you may have to email Asrock again and have them add this secure erase to 51A, or do without it until they add in later, or swap CPU’s when needed and flash back to 40B.
Or, use the AIO tool here on the forums to add back in Coffee Lake support (Microcodes, ME etc not changed in this BIOS) to the above BIOS
There are many ways to secure erase things without having to do within a BIOS.

I don’t have the 9900k yet. I am going to buy it soon. I wanted to test the 7.40 with Secure Erase if it was possible. What is AMITSE and how does it affect things? Having a Secure Erase tool in Bios means you don’t have to boot up Linux and makes things alot easier. Alot of motherboard manufacturers offer this except Asrock.

Linux is not needed to secure erase either, you can do from windows or DOS.

Are you saying now, I misunderstood you and you want 7.40 modified with stuff from 7.40B? If yes, why, same BIOS, just use 7.40B

AMITSE contains BIOS String and setupdata, similar to the setup module but not the same at all. Since you don’t have 9900K yet, then that’s good you wont have to swap CPU’s to test above BIOS, let me know how it goes.

I want to see if its possible to transfer secure erase from 7.40B to 7.40. If it works then most likely transferring Secure Erase from 7.40B to 7.51A will work. At least that’s what I think.

7.40 is same as 7.40B except for enabled Secure Erase correct? I assume same transfer I did from 40B to 51A would be same in 40B to 40 too, except there you wouldn’t have to worry about it messing with Coffee Lake-R changes in 51A
Give me a sec, I will do same edit to 40

*Edit @MrJack - here is 7.40 BIOS modified with 7.40B secure erase changes

It showed up in BIOS! I tested it on an SSD and it has indeed worked! All I had to do was edit the one you made with UBU as it had a secure check fail message.

Since ASR Secure Erase tool showed up in 7.40, is it possible to copy it to 7.51A without changing anything else? Or have you done that already in post #9?

Ohh, yes, sorry I forgot to remove the capsule for secure flash on mod BIOS! Glad you knew about that though,

Yes, I done that already in post #9, it should work just the same as the .40 mod, but the warnings I mention about CPU compatibility are probably true (ie some settings may not be correct/missing in the BIOS).
CPU should still function, but you may not have all the settings like 6-12 core etc to change individually, since I put in the 40B setup module

Would it be possible to individually select the ASR module and only copy that?

No, it’s not a module on it’s own (ASR=ASRock, they use this for many things within the BIOS). The “Secure Erase” module that is same in all BIOS, only differs by two bytes in the 40B vs 51A module, so it’s possible this is the ASR module, and those two bytes enable it.
But the setup and AMITSE must also be copied over even if that two byte change alone enables the module to function, because the Setup/AMITSE modules contain what you actually see and all the functionality within the BIOS, so they must be swapped as well.

Would I be still able to overclock all 8 cores 16 threads? Would things like DSDT and CPU SSDT and CPU microcode be changed?

Yes, but you wont see the individual settings options past certain number of cores in the BIOS. No, all that rest you asked about would be same still.

Are the 2, 7.51A Secure Erase BIOS (Table Edit and GUID Swap) edited for capsule for secure flash? I can’t find them on UEFITool. I’m going to try both soon.