Error Code 10

I’m using a Razer Blade Stealth 2016 which has a i7 6500U. It was recently repaired from the manufacturer and they replaced the motherboard and battery due to unable to boot properly.
Ever since I got my laptop I’ve checked most of them and the Intel Management Engine Interface states ‘STATUS_DEVICE_POWER_FAILURE’. So I tried downloading the IMEI from Razer’s Driver Support, reset to default my Bios settings and still nothing happens.


Download ME System Tools v11.0 from the ME thread, open a command prompt at Flash Programming Tool folder and run it with command “fptw -greset”. After the restart, does the problem persist? If yes, what driver do you currently have installed? Is there any option at the BIOS which is ME related? Meaning a version field, an option to “Enable ME Reflash” or similar.


It doesn’t matter. Go for x64 if you have 64-bit Windows (you almost certainly do).

I still have the same issue. This was the version currently installed from my system which is from Razer’s Drivers itself. It seems there were no options in my BIOS to reflash but I saw this ME version and its even unidentified.



Yes, ME version N/A or is what I was looking for. The ME firmware is corrupt, its settings probably are. Read Section A of the CleanUp Guide to understand why. It’s not your fault. Razer did not reflash a cleaned+configured ME region before shipping the system back to you and now it has problems. Check if they have locked read/write access to the ME region by running “fptw64 -d spi.bin” command. Does it work? Are you certain that the BIOS has no option called “ME Reflash” or similar?

Well, the dumping of the flash did work but I don’t know if it’s locked. I double checked the BIOS and no ‘ME Reflash’ to be found.

If it worked then great, we can fix the issue ourselves. Compress and attach here the dump you got.

Heres the file, sorry for late upload. My internet uplink sucks.…N0tpcGhIb0xtVFE (4.27 MB)

Here is the attached fixed ME region. This is the ME region only, not the full SPI image you dumped. Flash it with “fptw64 -rewrite -me -f me_fix.bin” and when it’s done, do a “fptw64 -greset”. The problem should be gone after the reboot.

me_fix.rar (1.36 MB)

Should I? Sorry, really not good at this.


Thank you so much! It worked! Finally! :slight_smile:
Is there anything I need to check?

Great, glad I could help. You were lucky that Razer left the Flash Descriptor unlocked which means read/write access to the ME region. You should check that your problems are gone, that the BIOS reports a proper ME version and that MEInfo and MEManuf tools complete their operations successfully.

My problems are gone but like you mentioned to check MEInfo and MEManuf tools both gave me some errors. Is this good or bad?

error 2.PNG


It looks ok, that laptop does not have an Intel Sensor Hub Controller probably. You’re good to go.

Thanks! I thought there was still missing :slight_smile: Thanks for all of your help!