EVGA Z790 Dark KP fails to boot with mCode modded BIOS

Hello guys,
after the EVGA motherboard support and coding team has apparently ditched the company, we are left with no new BIOS versions (latest version 03/23!) to properly support intel’s 14th Gen CPUs. I’ve decided to try and mod my own BIOS to import the 11D (11F) microcode for better functionality and performance on these CPUs. I followed both of the guides I found here (Lost_N_BIOS and davidm71) to HEX-edit the microcodes, import them back and correct my FIT tables. I paste-inserted the mCode over an old one, deleted the FF values in the end for it to have the same size when replacing the body back in UEFITool and made the calculations for the FIT table to show all the mCode versions. The were some difficulties in the end, because I had to add the size of the Paddings to the calculations in order for the mCodes to show in FIT and have the correct locations, but in the end it all worked. Flashing the BIOS itself was not a problem, but when the system boots it just hangs on POST Code 65 (CPU DXE Initialization) with the Caterr_LED on. The good thing is I can always recover with the regular BIOS version and the USB flashback button, also the motherboard has 3 BIOS chips, so that isn’t a problem, but can’t understand why the system won’t boot. Any help would be much appreciated. Attached both the original BIOS file and my modded one.


Edited FIT candidate, too, empty padding before ME (EC firmware?), lost several paddings in bios region…

Seems you just tried to change just the last µcode?

In this case you wouldn’t need any complicated changes to FIT since the last µcode would have an identical start address and _FIT_ only notes start address and type. There’s enough room in the next padding to keep the slightly bigger size, the padding contains just one last line.

You may try: 1E799113_mc.zip (9.2 MB)

1 Like

Thank you for the answer. I haven’t changed anything on the paddings just noticed I have to add their size in order for the mCodes to sit correctly in FIT, but it looks like I messed up the structure.

Yes, only tried to change the last mCode because the BIOS supports switching between the different versions and since I’m using a 14th gen CPU I only wanted to edit the one to be able to try it out versus the older version.

Tried your file, but getting the same error and stuck at POST Code 65.

OK, I don’t think it’s µcode related then. The error message isn’t neither since afaik µcode is loaded very eraly, then the PEI and then comes dxe drivers. I wanted just to exclude that the changes in structure caused this error.
You might try to update ME to a later version, the link for this board will work for your board, too:


Intel ME Consumer Firmware :
Firmware : [05/09/2023]
PMC Firmware : [06/09/2023]
PCHC Firmware : [06/07/2022]
PHY N Firmware : [21/06/2023]
PHY S Firmware : [30/01/2023]​

Otherwise @chinobino might have a look into the µcode thing, but I’m afraid, this is bios (-region) code related…

1 Like

Updating the firmware with the corresponding MEI drivers didn’t help either. I had 2264 previously which was up to date as well for the 14th Gen mCodes, but 2307 doesn’t solve the problem.

Just to be sure: You’re working on the correct firmware, if I remember right you have 3 firmwares to choose from?

Did you try beta bios 1.14? Seems that changes weren’t µcode only?

Just in case: 1.14 with latest B0671 microcode 1E799114_uc.zip (9.4 MB)

1 Like

What do you mean by firmwares? I have 3 BIOS chips to choose from. And depending on the BIOS and the CPU installed I have several mCodes in a BIOS menu to choose from.

I modded 1.15 at first, but had the same problem with POST code 65. Tried your modded 1.14 BIOS and it gets stuck at 65 as well, BUT it boots normally with a 12900K CPU installed. Which was not the case with the modded 1.13 version.

Thank you once again for your time!

I got used to call a complete image for a firmware since the bios region is just one part of a complete image.

Wasn’t aware of 1.15, but read a little about EVGA and the discussion about a promised but never delivered bios update.

There are some changes from 1.14 to 1.15 but I think this is too early in relation to 14th gen release in october. One might compare to other bioses with 14th gen support, check the necessary changes from last version without to first version with support, but that’d be a lot of work without any warranty of success.

1,15 with latest µcode in case it’s different to yours.

1E799115_uc.zip (9.4 MB)

1 Like

Yeah man everything’s been going downhill for EVGA. It’s a shame because that board is a great piece of hardware, but missing proper support and performance with 14th Gen. I don’t expect them to bring out another BIOS version, the motherboard team is gone for good.

Tried your 115_uc, still getting the same error, just the code is 63 this time, which stands for the same thing. I don’t really understand why it won’t boot if the only changed component is a replaced uCode…

What do you mean? Whcih version does boot unchanged with a processor and doesn’t boot with newer µcode with this processor?

None of the files so far boot with my 14900K. It’s just that I tried my 12900K as well and while it didn’t boot with some of the versions, it booted with your modded 1.14. Haven’t remounted my CPU and waterblock now to try the modded 1.15 as well, but no boot with the 14th Gen.