[Experimental] NVMe Option ROM

Thank you! That was it!

I did not understand what this „Link present“ option was supposed to do. But now I succeeded to mod my ancient Asus P7P55D motherboard to boot from a Samsung 980pro NVME.

There is only one issue: After every reboot the drive seems to be missing in bios. So therefore I have to cold boot every time I have to restart…

Link present means now it is 126F:2263 NvME SSD. After every reboot the drive seems to be missing in bios this issue I met before. I confused some time but after a while I never met again. Check the card is fastened or cleaned. Especially be alert CPU temperature

Anybody has this mod file P6X58D-E-ASUS-0803_MOD.rar? the file is no longer available.

Thanks in advance.

Are you sure you need this BIOS.
This bios was made specifically for the Crucial P5 Plus nvme M.2 venID C0A9 devID 5407. Do you have exactly the same nvme?

@Ethaniel @Dagal @crojas
Just to make it as clear as possible for the users and to avoid unneeded failures I have added just now an important hint to the start post of this thread.

Hi I new :stuck_out_tongue: I like to install win 10 on my new Samsung 970 Evo plus but my main is a little old FSC D2628-C14
Maybe you can help

I edited your post, i believe we’re talking here of a Fujitsu Celsius R570/670 motherboard with Intel 5520/ICH10 chipset.

For this kind of legacy (Not UEFI) board this is one of the options you can try at your own risk. Read the thread.

Other options without messing with bios are Clover etc…

3 days lost and only “AIO boot” boot grub but no sukces in system boot :sweat_smile:

Hi all !
I have the same problem as @hellkot - afert system is rebooted, the BIOS does not see the nvme disk until you turn off the computer. Problem only with fastboot. Cold start - good start. Has anyone solved this problem?

Hi Fernando, I wanted to ask you if this NVME ROM is good for modifying the bios of the p5q deluxe motherboard with legacy ami bios modified for xenon. Thank you

Dearest, first of all I wanted to congratulate you on this wonderful work you are doing, I am a new user who is passionate about electronics (I am also an electrical engineer), since I have two Asus P5Q Deluxe PCs, one with a normal non-UEFI bios and one with a bios. modified for xenon cpu I wanted to improve it by adding a mvne module. Now I’m wondering if anyone can enlighten me on this topic. In general I would have understood how to do it, the only thing that doesn’t work for me is knowing whether the attached mod bin nmve file is valid for all motherboards or whether it needs to be modified for this specific motherboard.
If you helped me, I wouldn’t be grateful.
sorry for the english.

If you read or understand it correctly, you’d know that it needs specific HW ID configuration by the user for desired the NVMe (CONTROLLER ID) to use and edit the OpROM before bios integration.

Really can understand how users miss this, is this to hard to notice???

Important Hint (added by Fernando):
Just to prevent a serious misunderstanding and wasted time by trying to customize the offered NvmeOpRom module with not matching HardwareIDs, I want to make clear, that the user has to customize the VendorID and the DeviceID of the NVMe Controller , which is within the SSD (and not of the SSD itself }.


Experimental Modded VMware-NVME Option ROM for AMIBIOS8 Core ( Legacy ) - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

Dear thank you for your kind reply, I would have understood the following:
I take the xenon modified bios for asus p5q deluxe,

I open the mmtool 3 program, insert the bin file above the ROM[Experimental] NVMe Option ROM indicator, insert the vid id of my nmve product (not samsung) in the appropriate boxes of the program, add an option line to bios n 20 and save the biography. Generally speaking, do I need to do a few steps first?

Hi guys, if you can help me with the P5Q deluxe non UEFI bios modification.
I did everything as per the guide by inserting the relevant PCI card IDs, I flashed the bios but still nothing appears in the boot options. Are there any other steps missing?
if you can help me. If I can I will post my work.
Thank you

Hello. Post the original BIOS and the one you made. Specify VEN_0000&DEV_0000 as indicated on the picture of your nvme disk, I will take a look.

I have a similar situation.
I modified the BIOS and flashed it using this guide Experimental Modded VMware-NVME Option ROM for AMIBIOS8 Core ( Legacy ) - #2 by eierhals.
NVMe appeared in the BIOS. But when installing Windows, the same error appears.
I checked this on several boards and with several SSDs (yes, I made BIOS modifications for each SSD before checking).
Whoever succeeded, please tell me about the details when installing Windows.

And what a mistake.

This is not a BIOS problem.
Try this if you get an error.
Fn + Shift + F10
list disk
select disk “(0, 1, 2 …)”
convert gpt

I tried GPT and MBR.
But it did not help. If the drive has a GPT, then the error is as in the previous message.