[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

Thank you for your reply.
I have read the ‘[Guide] How to flash a modded AMI UEFI BIOS

Usage of the ASUS “USB Flashback” feature

However, my question is how to prepare the moded .cap file?

I have the original A.cap file.
extract body to A.rom file
MMtool, open rom file, insert Nvme to A.rom file, save as, get the ready flast B.rom file.

What is the next step please?
How to convert B.rom back to B.cap?
Or just flash B.rom file by ASUS “USB Flashback” feature?

many thanks

No, you dont need to extract any ROM, edit/mod the .CAP directly, thats why USB BFB is the best option on flashing mods on board with this feature, there’s no concern of security issues.
Use the MMtool method for NVMe mod, put the mod file (M5A97R20.CAP) in an USB on root, thats it.

hello mr. fernando
i want mod nvme GA H61M-S1 (v2. 2) bios
please :pray:t2: help me.
I was trying to modify bios with nvme modules on uefi tool , mmtool but every time it shows some error.
please make mod nvme for my bios of mobo. GA H61M-S1 (rev 2.2)

Read STEP 2, B, expand Open guide and read notes.

thanks to all
i have successfully completed the process.
Now i can boot my pc from ssd .
thank you so much :pray:t2:
in future if anyone facing problem can contact me at [email protected]

1 Like

A post was merged into an existing topic: [Experimental] NVMe Option ROM

I modified and flashed my Asus UEFI ROM using the specific procedure described below, and all seemed to go well with an MSI NVME SSD in a PCIe adapter. But for some reason my PC kept shutting itself down, whether I was running Windows, Ubuntu, and even in the UEFI Shell. I finally flashed my original 0910 ROM back to my motherboard using BIOS Flashback, removed the NVME SSD from the PCIe slot, and reconnected the original SATA SSD instead. Now I’m waiting to see if the system will continue to shut down.

This is what I did - I opened P8Z77-V-LE-PLUS-ASUS-0910.CAP in UEFITool 0.28.0. I found the Volume containing the File with the Text description “CSMCore”. I scrolled down and highlighted the last file in that same Volume, right-clicked and then clicked “Insert After” and inserted there the file “NvmExpressDxe_5.ffs”. Then I clicked File > Save Image As, and saved it as CAP file with a different name. I flashed this modified CAP file to my Asus P8Z77-V-LE-PLUS using AI Suite II.

I installed my NVME SSD in a 4x PCIe slot. My PC booted fine. I had earlier used Clonezilla to clone my SATA SSD to the NVMe SSD, and since it booted to Windows just fine, I didn’t reinstall Windows on the NVMe SSD. I doubt that not reinstalling Windows caused the shutdowns, because the shutdowns also happened in a fresh installation of Ubuntu and also in the UEFI Shell.

I want to emphasize that these were “orderly” and not spontaneous shutdowns - both in Windows and Ubuntu, a message would pop up saying that Windows or Ubuntu was going to shut down, and then the PC did so. I thought maybe it was just hardware failure and not the BIOS, but I had another shutdown when I replaced the NVME SSD with my original SATA SSD. That’s when I decided to flash back the original unmodified BIOS.

So I’m wondering what was triggering the shutdowns. Was it something happening in the firmware? Could it be overheating or something, but if so, would it have been an “orderly” shutdown?

Also I’m wondering if it would have made any difference if I had extracted the body of the CAP file to a ROM file and worked with the ROM file instead of the CAP.

If anybody has any thoughts or suggestion on this I would be very glad to hear them! I did a search of the forum looking for any similar “orderly shutdown” problems with a modified bios, and didn’t find anything.

@jimspoon Welcome to the Win-Raid Forum!

Flashing of a modded, but still capsuled BIOS file without using the ASUS own USB Flashback feature may have been the reason for your shutdown issues.
That is why I recommend
a) to reflash the original BIOS,
b) to remove the BIOS capsule,
c) to modify the .ROM file and
d) to flash it according to >this< Guide.
If you want security, that the insertion of the Nvme module has been done correctly by the UEFITool, please attach or give us a link to your modded BIOS and the original BIOS.
Good luck!
Dieter (alias Fernando)

4 posts were merged into an existing topic: [Guide] How to flash a modded AMI UEFI BIOS

thanks for you very kind guide! i am trying to do the mod for my supermicro x10slh-f but bother methods sadly generates that extra pad file and i did not go ahead to flash as im worried for bricking my board.

wonder if you can help me to take a look or advice what can i do?


When this situation happens in certain bioses, the best chance is try using the different versions of the UEFItool 0.25/0.28 and/or MMtool 4.x/5.x, eventually a correct mod will be achived.

unfortunately, i tried all versions and variations and none seem to work! wonder if anyone have some other insights?


Please attach the original BIOS or give me the link to it. Then I will test different tools.

Sure! Latest firmware below

According to my tests it is possible to get the “small” NVMe module properly inserted into the original BIOS named x10slh1.121 without creating or removing any Pad-file by using the AMI MMTool v5.0.0.7.
Please check it and give us your feedback.

Many thanks! It works and now I have a modded bios!

For this supermicro board, can I just use the provided flash tool and flash the modded bios?

You can find the answers within the first post of >this< thread.

A post was merged into an existing topic: [REQUEST] NVMe mod for ThinkCentre M81 (7517 IS6XM mb)


Did you have any luck with that bios ? I have the same mobo and would like to try it as well. If you have any further insight it would be appreciated.