[Experimental] NVMe Option ROM

Already told you that the [Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS doesn’t work for you.
The only thing from there that you can learn is the OS installation method. period.

About this NEW NVMe mod presented here, it is the only chance that you may have to your motherboard, so just follow the post and links/pictures provided by users and get the work done.
I do not make this mod for anyone and i do not know all the steps for it, so learn and do it yourself with the feedback provided here from other users and they will help you, when they can.
Your device controller ID identified is correct for this mod, any more details wait for someone to answer with a more focused detail on your mod procedures.

If you dont know how to work with AMI bios tools, make dumps, backups…etc, then you have a higher probability of fail/breaking your motherboard.

I can confirm it works on a H8QG7 LNF4 Board with AMI Core8 and it is bootable. Insert as a new 20 Module. Thanks Ethaniel

Hello everyone, obviously my first post here, but i read a lot here and it was very helpful.
I have an Asus p6x58d-e and I try to mod the bios tu use a Nvme PCI adapter card. I followed this guide posted here :

"1) Open >this< thread.
2) Download the archive from the first post named NvmeOpRom.zip
3) We write down the VID / DID of the NVMe media that we plan to use. (Either we search in Google, or, which is more reliable, we insert it into the motherboard through the m.2 to pci-e adapter, VendorID & DeviceId in the Device Manager)
4) Using OpRomCfg.exe, enter the values ​​from clause 3 and the checksum into the firmware.
5) Using the AFUWIN64 program, we save the current bios ROM firmware, make a backup of it.
6) If you have AMI, then take MMTool 3.19 / 3.22 and add the resulting NvmeOpRom.bin via Insert, check the "Link Present" checkbox and enter our VendorID / DeviceID, click Insert, then Save Image As. If AWARD, then it is better to prepare the programmer in advance, because avard is famous for the jambs of its native utilities and often kills the firmware with them, but you can try to find a cbrom that will work with your firmware normally. If Phoenix / Insyde - then everything is really bad.
7) Flash the resulting ROM image.
8) Go to the boot device selection menu and enjoy the line like "NVME 01: 00.00.1".
9) Install Windows XP with added NVME drivers (item # 2 in Integral Edition).
10) We enjoy life without any Clover and flash drives stuck on a permanent basis."

but i have a few questions

In MMtool 3.19 after load the rom, i have to insert NvmeOpRom.bin (after using opromcfg.exe with VID/DID) and then again with link present and vendor ir and device id, insert again ? also do I have to use Compress module to insert or Insert uncompressed ? and RomRegion?. I tried different options but after doing that i dont see any new "20 / PCI Option rom / …" in MMtools with VID/DID inserted, is that right ?
Also after saving the rom, if i use AMIBCP and watch the strings in the rom i dont see any "NVMe" string, thats why i think im doing something wrong or missing some step

Any help is welcome as i dont want to brick my main pc

Greetings from down here - Uruguay

PS:sorry for my english, im still learning :slight_smile:

So I was able implement the option rom into my EVGA SR-2 bios, and my Samsung 950 pro NVME now shows up under bootable devices. However, it never actually boots to it, and when I try to install windows via a USB the installer still says it can’t install to to the drive since the BIOS doesn’t support booting from it. Anyone know what may allow me to boot from it?

Follow point#4 here: [HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

The NVMe must be cleared into GPT system file
Disconect all other system drives during setup.
The thing here… on this mod, is the ability to boot on a pré-UEFI environment OS setup…

EDIT: “Isn’t this for a UEFI bios?” This what… the link i pointed? This option rom is for pré/non-UEFI motherboard bios… that works in all motherboards models…im afraid not and others bioses like AWARS rather than AMI Core8 seems to have few/none success.
The message you had, usually on a standard system occurs when the NVMe drive has already an old system partition. The standard NVMe protocol demands GPT/NTFS, not MBR/NTFS.

Isn’t this for a UEFI bios? My EVGA SR-2 is from 2011 and doesn’t have the EFI modules, which is why I am using the option rom here to get legacy support for booting to the NVME. I’ve disconnected all the drives, and am using the standard windows 10 media creation tool for the USB boot install.

I completely cleaned the drive several times, removed all partitions. Every time I get to the point to pick the drive to install windows on I get the error that Windows can’t be installed on this disc, because the hardware may not support booting to it. Prior to modding the BIOS the NVMe did not show up in the boot order, it does now, but I still get this error.

Gonna be honest, i never lost time doing this mod in old motherboards, not a priority to me in legacy/pré-UEFi hardware.
This mod is, in my opinion is a walk in the edge of the knife, i think it has a very low margin of compatibility on old hardware against a modern storage device along with a modern OSes… we really cant ask more to the author of this mod/thread, you should wait for other users opinion, good luck.

Users of a Samsung 950 Pro SSD don’t need to modify their Legacy (non-UEFI) mainboard BIOS, because this SSD natively contains the required NVMe Option ROM. So you should be able to get Win10 installed onto the NVMe SSD.
Note: This will only work after having prepared an OS installation in LEGACY mode (using the Master Boot Record (MBR) partition scheme.

Point 4 of my Guide doesn’t work for users with a LEGACY (non-UEFI) mainboard BIOS.

1 Like

@Fernando This is what I thought which is why I bought the Samsung 950 Pro. However, nothing I could do would let the drive show up as a bootable device and everytime I tried to install Windows it would say the BIOS can’t boot from this drive with the error seen above. Reading online I found I wasn’t the only one who couldn’t get this drive to boot on a legacy system. Which is why I started looking here, and actually this BIOS mod did allow my drive to show up under bootable devices finally, but window’s still won’t install on it. I thought I have tried both legacy and UEFI installs, but maybe i’m not doing it right. I’ve tried a Windows 8 CD, the Windows 10 media creation tool, and then the Windows 10 ISO using Rufus with I believe the BIOS bootable option. Is there a better way to ensure i’m installing in Legacy?

Make sure that in the bios of this motherboard, by default, the sata connector is not raid, but ahci.

That is how it is, that is the default setting.


ATA/IDE mode - Legacy
maybe in this case - This computer's hardware may not support booting to this disk. Error Fix Guide 2022 - YouTube

This is the default Sata configuration.

Seems the bios doesn’t load the option rom on the SSD.

Are there any optoins in the bios that could block option roms on PCIe cards? Checked the manual and found only “OffBoard PCI/ISA IDE Card” and “Assign IRQ to OCI VGA” According to the name these should cover PCI slots, but as far as I can see the board doesn’t have any PCI slots, only PCIe?

Show us in bios
EDIT: Confirmed, now also note lfb6 remarks and make a tryout with all sata ports to AHCI on enchanted or compatible.

Interesting reports from users on EVGA forum:
post#6 SR-2 and NVMe drives - EVGA Forums

post#3 NVME in SR2 - EVGA Forums

The PCIe m.2 NVMe adapter is a single device or multiple or those with sata ports…

By viewing a few simple user posts seems that this board, like lbf6 said, doesn’t like to load the internal rom devices on both AHCI or NVMe ssds, not saying to gave up on it…
But just like Fernando remind me… the 950 Pro should work without nvme bios mod (Model that it has its own controller), at least in AMI IV UEFI up… did you tried before the mod to see if the NVMe would appear in OS setup destination drive?

This didn’t show up until after I did the BIOS mod.

There is an option called interrupt 19 capture, which appears to allow option ROMs to interrupt the normal boot sequence. I have this enabled, Even when disabled it doesn’t make a difference though and still shows up in the BIOS boot order.

There are no PCI slots, there are only 7 PCIe slots and I have the PCIe to NVMe adapter in the 7th slot. I’ve tried it in others but it still doesn’t allow me to install windows to it.

The only option I can see related to option roms was “Interupt 19 capture”, which allows options roms to boot up when enabled, and I have it on.

I’ve seen those posts already from the EVGA forums, it’s what led me here actually to see if I can modify the bios to make it work. I don’t want to use Duet/Clover. I believe i’ve gotten further than anyone else that I’ve seen with this board as I now hoave it showing up in the BIOS, but still windows install won’t work. If I allow it to attempt to boot to the drive I can tell it actually does because the drive lights start lighting up right after post and then when the error “reboot and select proper boot device” shows up, If I hit any keys the lights on the drive flash, as if the drive is active…but there is no installation of windows on it.

@MeatWar Yes, the drive always shows up in the windows install even before the mod but it won’t let me install windows to it as it gives the error I posted above relating to the hardware not support booting to the disk. But the drive didn’t show up in the boot menu until after I modded the BIOS.