[Experimental] NVMe Option ROM

I’m sorry, out of ideas. The option rom you inserted is experimental, the bios itself doesn’t load (certain?) PCIe option roms. Thought there might be a difference presenting the disk as ahci or ide, but if I remember right Win 7 does install on IDE, too.

Don’t know if the original samsung rom was extracted once? If so you could try to insert the original rom directly.

Im like lfb6…regarding this issue, but ill leave here the Samsung 950 Pro OpROM, shared on old forum, cant seem to find the same post again on new forum, the original sharing is from Dagal

SM950Pro.rar (9.9 KB)

1 Like

Thanks, I tried loading in this option rom into the BIOS but it doesn’t even detect the NVME with this one. The original one from this thread does detect the drive, but it just won’t allow for a windows installation. Interestingly, with the experimental NVMe option rom loaded it does appear to sort of boot to the drive, as the hard drive lights up and starts becoming active when I press any keys, but i just get the error of “reboot and select a proper boot device” and Windows refuses to install on it.

I also attempted to clone an installation from an SSD and move it to the NVMe, but it still won’t boot.

Hello. If you want, send me your bios, I’ll flash an OpROM into it to boot. I also need to know the VEN_0000&DEV_0000 of your nvme. Maybe it is the OpROM firmware in the BIOS that will solve your problem.

@Dagal Sure.

Here’s a link to the bios from the vender website:

And the vender/Device ID is 144D_A802

Hello. Here is your bios.

I checked everything. Everything looks good.
If this BIOS does not solve the problem (and I checked everything is fine in the BIOS), then it’s definitely not the OpROM, but:

  1. In the individual settings in the BIOS;
  2. Hardware incompatibility.
    I want to share about a problem that I had and I think you have the same problem.
    I have an old GIGABYTE GA-EP45-DS3P motherboard, it has 3 pci express 2.0 slots (first slot works x16, second x8, third x4). This board has ATI CrossFireX technology. When a video card is connected to the first slot and all other slots are empty, the video card works in x16 mode. When there is a video card in the first slot and you connect a second video card to the second slot, my chipset divides the pci express slot like this:
    pci express 1x8
    pci express 2 x8
    This is the problem. Nvme uses x4. When these boards were created, there were no nvme and when you connect to the second pci express nvme, the chipset “thinks” that you connected the second video card and sends 8 pci express lines. My computer refused to “see” nvme. (Although if you connect a dual nvme adapter with two disks to the second slot, the computer will see it, but only the first disk will work, since there are no settings in the BIOS for dividing x8 by x4 + x4).
    You, in the characteristics of the motherboard, also have pci express division, this may be the problem.

As always, I warn you of responsibility that I do not bear any responsibility for updating your BIOS, possible problems during operation and updating. If you are not confident in your abilities, you need to refuse to update the BIOS.


I think the problem is the work of nvme, it’s exactly in the pci express lines.
EVGA Classified SR-2 works with pci express like this: The seven PCI Express x16 slots can work in two ways: “x16+x16+x16+x16” or “x16+x8+x8+x8+x8+x8+x8”.
That’s why nvme doesn’t work.
If possible, this can be checked.
You need to put a video card in the first slot, and put such an adapter in the next x16 slot

put four NVME into it (the first is samsung 950 pro, the other three do not matter). Thus, the second slot will be x16 and the computer will see your samsung and install the system on it.
But only 1 NVME will work, because there are no settings in the BIOS for dividing x16 by x4+x4+x4+x4.
The ideal solution is a BIOS mod for dividing PCI Express lines into x4+x4+x4+x4.

1 Like

HOLY COW. It worked! Was there anything different you did to this other than just loading the same experimental OpRom at the start of this thread? That’s what I did originally and it did start showing the NVME in my bios, but it never allowed Windows to boot from it. YOURS DID! Interestingly with my modded bios it would list the drive under boot devices as “IDE:NVMe (7:0:0:1)”, but with yours it actually calls it out as a “N1-Samsung NVMe”. I wonder what the difference was? Did you use MMTool or AMIMMWIN to insert the OpRom? Yours installed Windows just fine and booted straight to Windows. THANK YOU!

Edit by Fernando: Unneeded fully quoted post removed (to save space)

… congrats then. Since this is not a mod on a personal dump file, share it, if you will, the mod here (Remarks to NVMe used): Latest BIOS/UEFI Modding/Offers: Already modded special BIOSes topics - Win-Raid Forum (level1techs.com)

And txs to Dagal for his work.

I’m glad that everything worked out for you.
I originally prepared the BIN for your nvme and pasted it into your bios using MMTOOL.
I will soon write a guide for nvme support on NO UEFI boards.
Ferdando has long proposed to prepare a guide, all hands do not reach.

1 Like

looking forward for the tutorial want to test it on x58 or older motherboards!

There is no tutorial, there is reports from users so take as it is:

no tutorial yet ,Dagal above is preparing a guide for it !!!

how did you get the nvme work via pcie in p6x58d-e? i have the same mobo and my win10 crashes at boot… could you help me?

I’m busy at work right now, I’ll post it as soon as I get free.

I need to know the VEN_0000&DEV_0000 of your nvme.

Crucial P5 Plus nvme M.2 (CT500P5PSSD8)… vendorID C0A9 DeviceID 5407

Dagal asked for the HardwareIDs of the NVMe Controller, which is within the SSD. They are unique.
So you should look for them within the “Storage Controllers” and not within the “Disk drives” section of the Device Manager.

i did it in the storage controllers, but in the wrong controller… there is 3… i checked again and found vendorID C0A9 DeviceID 5407… thanks

@ bebexule
Hello. Here is your bios p6x58d-e.

As always, I warn you of responsibility that I do not bear any responsibility for updating your BIOS, possible problems during operation and updating. If you are not confident in your abilities, you need to refuse to update the BIOS.

1 Like