[Experimental] NVMe Option ROM

@Dagal thanks for your attention and effort, but i cant flash the bios, it returns an error… “Boot block in file is not valid”… i oppened with mmtool and it have the module with my nvme info

The flash drive must be formatted in FAT32.
And rename the file to a short name.
If you are not confident in your abilities and you do not have a programmer, then I advise you to abandon the firmware.

it work with a fat32 usb drive…i triyed to flashing from bios and the file is in HDD c: drive ntfs, as i always flash my bios… didnt try yet the Nvme SSD… then i let you know… thanks

well… the nvme ssd is show at bios, but i can’t boot any of my systems WIN10 OR wIN7, both crashes at boot… try some bios config, like AHCI or IDE, disconnet usb 3.0 driver… nothing work… disconnet all my HDD’s, try to boot from Clover and run an win install usb drive via EFI, and the result is the same… MASCHINE CHECK EXCEPTION… i don’t know what can i do to make it work… maybe the Crucial drive is not compatible with the MoBo… if you know something more, please show me… anyway, thanks for help

Are you installing a new system on Nvme and it crashes on boot?

i can’t even start the instalation… it crashes at windows log (moving points circle)… the same crash if i start my system… see video bellow (you may fastforward cause it will be blackscreen for 2 minutes)

with Nvme connected - install win10 via Clover VID_20220821_201355.mp4 - Google Drive

with Nvme connected - booting my Win10 systemVID_20220821_202203.mp4 - Google Drive

without Nvme - install win10 via Clover VID_20220827_000118.mp4 - Google Drive

Sorry, but I did not see in your videos that bios recognizes the installed Nvme. Are you sure bios saw Nvme.
Why are you using Clover? With this method, the download is carried out without Clover.

i post the wrong video… see the one below
you right, it doesn’t need Clover to run, but i just tryied this cause nothing works with the Nvme connected

with Nvme connected - install win10 with usb VID_20220916_210948.mp4 - Google Drive

Lets try to unplug all other hard drives from your system, leave only the PCIe M.2 with the NVMe disk and still disable the Marvell controller.
This is need to troubleshooting the BSOD during windows setup.

the same result… see video below for bios config

with Nvme connected - install win10 with usb VID_20220917_154221.mp4 - Google Drive

Even worst motherboard models with this mod were successful… putting aside hw issue or iso corruption, there are “small” bios settings that need various tryouts, for example the bios will configure hw resources and allocation in different ways, upon selecting a PlugNplay OS as yes or no…do you have the notion that modern win OS are all PlugNplay… still much more settings to work with on that bios…keep going with your tryouts.

Your bios saw Nvme as IDE N1-CT500P5PSSD.
It should not be.
I recommend that you disable all drives, Marvell controller, extension cards (sound cards) and connect Nvme to different pci express x16 slots, including the first one, instead of the video card.
By the way, after flashing the BIOS, do you reset the CMOS?

I checked everything again, there is no error, everything should work.
On my legacy system, the BIOS sees Nvme as SCSI: N1 ADATA LEGEND 750.
Try resetting all settings to default.
If you have another Nvme, at least for a while, to check, let me know.

1 Like

Hi! Just flashed it on P6X58D premium and it works fine! Thanks for the OpRom @Ethaniel and thanks for the tutorial on moding AMIBIOS8 @Fernando.
I’ve also updated Intel raid and lan modules. Some tips on any more mods?

Welcome to the Win-RAID Forum and congratulations for having succeeded with your project - enjoy it!
Dieter (alias Fernando)

See…the user ZeGotex just reported a sucess with the same base mod… now all that remains is the PCIe M.2 adaptor and the NVME model he used/you’re using. Also that detail refereed by Dagal IDE/SCSI…

Can you please share some more specific tiny details in bios settings or screen caps, to help the above user bebexule on his P6X58D-E, thank you.

@ZeGotex could you post some references, like which “Intel raid and lan modules” drivers, your bios shows Nvme as type IDE or SCSI or else… Marvell as…?.. some configs that is necessary to make it works

Just adding the nvme module worked for me. No other mods were needed, though I have updated the Intel RST and lan modules after I did confirmed Nvme working. I used bios version 1501, the latest provided by asus. I think your problem was flashing the bios with OC settings enabled. I think I did it once in my tentatives, and it was a no no. nvme drive appears as IDE, but there’s no difference if I enable AHCI or IDE mode.

To all of you people here, is there any way of modding RAM compatibility? Like, making it use 8 GB sticks when factory maximum is 4 GB sticks. I’ve downloaded a server bios from Asus from the same chipset, but I don’t know wich are the ram modules. I’m on a X5675 and I really would like to use 8GB ram sticks and go from 4x2GB + 2x4GB mixed mess to 3x8GB same ram kit.

i tryied an Adata XPG Spectrix S40G M.2 and it works… windows 10 shows the drive and i can access it… so i presume that Crucial P5 Plus is not compatible with the P6X58E-D mobo, as the nvme can run in another system… unless there’s a magic trick for it, i will not lose more time with this… now i have another prob to run it… my 4TB HDD used as storage runs to slow on win10 and crash the system, and in other same win 10 (dual boot) runs well… thank all for the support… great forum

I can confirm that this option rom works well with my msi p45 platinum lga775 and xpg/adata ASX8200PNP 512 gb model. I can boot from it with Windows 10 mbr mode.
The motherboard supports pcie 2.0 slolts so this as good as this can be for data bandwith/transfer. Wonder if a pcie adaptor with switch from Boradcom or Asmedia would let the nvme use the full bandwith pcie 2.0 x8 lanes to the nvme (without raid0)?

1 Like

Typical no, it provides a max of 8 lanes but device itself only requests and uses 4 lanes.
Now i presume you’re talking about a multiple PCIe M.2 adapter cards witch internal bifurcation chip… the same applies, thats the same as putting it in x16 full slot, i think i already explained that to you in another thread.
Modern motherboards with slot bifurcation or Intel CPU VROC and those kind of adapters will do exactly that… settings differs across mb models and adapters…but the device (The NVMe disk) is the lane limiter.
Any user correct me if im wrong here please.