[fixed] Microcode update for fx 8350 gigabyte GA990FXA-UD3 rev 3

I have a UEFI based aptio 4 GA 990fxa ud3 rev 3 motherboard I have patched in new op roms and added in nvme support but I wish to update the microcodes.
I have not really found a tutorial but from reading on the forums I have come up with the below:

1. Use MMTool and extract the AmdProzessorInitPeim file.
2. Open the AmdProzessorInitPeim file in Hxd Editor
3. Open your old and new version of the microcodes in Hxd Editor.
4. Search for your old version of the microcode in the AmdProzessorInitPeim and replace it with the new one. Then save it.
5. Import the modified AmdProzessorInitPeim file back in to the original bios.
6. done

Does this sound correct?

I also found this:

1. Open the whole bios file with Hxd editor.
2. Open your old and new version of the microcodes in Hxd Editor too.
3. Search for your old version of the microcode in the bios and replace it with the new one. Then save it.
4. Open your new bios file with UEFITool.
5. Find the GUID of the AmdProcessorInitPeim file using MMtool.
6. Right click on the GUID and click REBUILD. Then save your new bios.
7. Done.

Both sound like valid ways but as there is not really much info I’m not 100% sure if the above is correct.

Below is the output of mc extractor which I have a funny error what does this error mean, and from what I believe 4 of the microcodes are outdated as pointed via the red NO?


Either would be OK, and rebuild suggestion with UEFITool would be suggested in both methods at the end. You could also do all extraction via UEFITool, extract GUID as-is or PE32 image (extract body) inside that GUID, then hex edit, then reinsert and rebuild then save.
Be sure, however you extract (As is, body, GUID or PE32 etc) that you insert back same way you extracted. Microcode GUID is DE3E049C-A218-4891-8658-5FC0FA84C788

Be sure when replacing old with new, there is room at the end if the new update is larger. If some update is larger and there is not extra room after the end of the old I am not sure how to deal with that, you could try insert instead of paste and it would push other stuff after end of old down, but file size would grow.
That may or may not be OK, rebuilding should correct that if it is an issue, or some error would come when rebuilding and then saving new image, I’d hope :slight_smile:

I do not get that error with same version of MC Extractor when used in windows, on BIOS version FDk. If you’re looking at same BIOS version, then it could be Linux error maybe?

I have an updated FDN bios for this board direct from gigabyte tech support I raised a bug with the use of ssd’s in ports 1,2,3,4 along side a mech hdd and they gave me this bios to resolve the issue it could be to do with a different bios version…

I’m using mc extractor from within windows 10, I was going to try the python script directly and see if it worked better it could be related to the bios version, but I might give a try with the fdk version.

EDIT: the error is related to the console not accepting UTF-8 characters I typed in chcp 65001 in the Windows console to switch your codepage before running the UBU bat file and now it extracts with no error.

Im not sure how to replace the extracted and modded file as all the options are ghosted and un selectable except extract and hex edit is this because it is a inside bios ?
problem is missing dependancys from uefi tool.

I tried with mmtool but it fails to import the module because of the ffs checksum.


Redo the mod, using only EUFITool or redo using a different version of MMTool that allows extract and insert on this BIOS at same time.
I checked, version v4.50.0.23 allows extract and replace on this particular BIOS, others may as well but that’s the only version I checked right now and it works for this BIOS version

I got it sorted the uefitool dependencies were missing to make the program operate.

Of note the new microcodes dropped my crypto hashrate with the spectre/ meltdown fixes quite a lot more than I expected.

my hash rate has dropped by a tad over 15% from the previous microcode.

So you got the microcodes all updated now? Good deal if so!

I knew Intel Spectre/Meltdown fixes hurt performance a lot on certain models, but didn’t know AMD was affected like that too.
15% is quite a drop, hopefully both Intel and AMD will get better microcodes released instead of relying on operating system side fixes.

Loosing 15% performance on Bulldozer is no laughing matter. :frowning:

Yip the bios is Successfully modded now with all the latest ORoms and the latest MicroCodes, I’m a bit disappointed in the downgrade in performance at least in a cryptoningt V7 mining test it is down 15% but other than that everything seems good.

Thanks all you have been very helpful.

Great it’s all updated for you now, except for the performance hit due to Spectre fixes. Hopefully they release better microcodes in the future!
Please share your BIOS here for anyone needing update that finds this thread in the future, if you don’t mind, thank you!

Update as attached.

Of note I opened the rev 4.1 motherboard’s bios just to have a look and the processorintprelim in in both unmodded bioses are identical and it could be patched in to that bios and possibly all the other bioses in the gigabyte ga-990fxa ud3 range.

one would just need to replace their processorintprelim with my modified one.

9FXAUD33-FDN.rar (5.64 MB)

Thanks for sharing! And good info on the other BIOS in that range too, hopefully it will help someone later.
If you can still edit post one, maybe put board model name there so it’s easier to find if someone look for updates later, thanks!

I have a GA-990FXA-UD3 Revision 1 and am trying to get support to boot from an NVMe drive in my PCIe slot. Windows 10 installer supports it and detects the drive but states that my hardware does not. I am hoping someone can help. I am not sure what hardware changed from rev 1 and so on. Thanks

Hi you can possibly add NVMe support I don’t know the specifics of your bios but here is a guide here on how to add it:
I’m not confident to be able to mod your bios as I’m new to this and don’t have an NVMe device and don’t want to render your computer non operational:

[Guide] How to get full NVMe support for all Systems with an AMI UEFI BIOS

@Makinbacon - your BIOS is old Award Non-UEFI, so options are limited. You can try one of these methods
[Guide+Video] How to install windows on NVME SSD 960 EVO without clover on a board without NVMe support. hyper-v method.
[Guide] NVMe-boot for systems with legacy BIOS and older-UEFI (DUET-REFIND)

Is that both the stock and modded bios in your link?

i have an updated info here with a new FDN bios version


Was looking for the bios without the Spectre and meltdown bugs fixed to avoid the 15% performance loss

I will look for the original untouched FDN version bios for you and get back to you as it does not have the latest microcode’s.

I think the fx series microcode is pushed by windows now so it does not matter you re basically forced to use them.

Awesome thanks. I did have it at one time but seem to have misplaced it. Might not be noticeable in games but I did notice a drop in benchmarks.