Flashing Gigabyte while avoiding "Invalid BIOS image"

@zoe934 - It’s OK, I only was saying I checked the EFIFlash version included in that package, trying to see what version EFIFlash it was so I could give you answer to your question, the BIOS version does not matter.

In F9 BIOS is included EFIFlash 0.42.
In F10b BIOS is included EFIFlash 0.43.

Thanks @ex58 - Where in file do you check to see version, or how can you tell by running app?

@zoe934 - so, you can probably us either of the above mentioned versions, modified. If they are not modified here in this thread already let me know and I can mod for you.
If you want me to mod for you, please tell me what error you see on screen that you’re needing to bypass

So,BIOS F10c…F10…F11b got issue ?

for hackintosh.
I don’t think there are issues running on windows

@zoe934 - Do EFIFlash from F7 and F10x give you same error message, if yes, what is the error message?
If you wanted, you can use @BIOS to flash back to older BIOS, otherwise you will have to tell me the error so I can modify one of these for you since I don’t see any versions this old already modified on this thread

Thanks a lot for your reply.
I am trying to flash F7.
I download the files from Gigabyte
then move them into a flash drive (Rufus dos mode)
boot the flash drive will automatically go into EFIflash.
But it failed

@zoe934 - Please see my edit above, I need to know the error you see on screen (exact words), or you can use latest (For your board) @BIOS tool w/ fingers crossed

I used F7 Efiflash from Gigiabyte and it shows

“gigabyte SPI FLash BIOS Update Utility v0.36
Flash Type : MXIC 25L series"

Nothing else…

I also tried @BIOS

"This Motherboard is protected from using this BIOS.
please download the latest BIOS from Gigabyte website to update BIOS again.”

Try this EFIFlash downgrade…unzip and replace files in F7 BIOS…(read how to use).
You can’t use EFIFlash from F7 BIOS,as is outdated.

Efiflash downgrade.zip (45.2 KB)

Rename EFIFlash (.exe) file to EFIFlash.efi
Open with Notepad or Wordpad, at the bottom you can see version.
.exe file can be open also with Hex editor.

I got

"!!! Invalid Command !!!

did I miss anything?

I rename F7bios to "bios.bin"
dragged AUTOEXEC.BAT, Efiflash.exe, bios.bin into the flash drive.
boot up from flash drive.

bios.bin must be without .F7 word on the end.

only bios.bin
no F7 on the end.

Thanks ex58!
If above fails @zoe934 , try EFIFlash in lastest F10 or F11 beta BIOS, and then show me error you get on screen.
You may not be getting error if you are not running it manually, remove autoexec.bat and run the command yourself >> Efiflash.exe biosname.extension<br />
*Edit - Obviously for the above file you need to edit the .bat to use your BIOS filename.extension, or rename your BIOS to bios.bin, either way you want to do it

As I don’t have much time now,please use different way with ftp tool…


good luck…

@zoe934 - With above FPT method, you will need to edit in your MAC ID to BIOS first before you flash, otherwise you will loose MAC ID and ethernet wont work
Please give me your MAC ID and I will edit F7 BIOS and put it in there. You only need to use this method if you don’t want or know how to edit the .bat file (open with notepad), or just rename a copy of the bios to bios.bin
Then, if that still fails for you, we can go the FPT method, but you’ll need to give me your MAC ID first (run command from CMD prompt >> IPCONFIG /ALL) Or, check sticker on board, on LAN Port or near it (look on side, top, bottom etc)

@Lost_N_BIOS - for

Which EFIflash version should I try?
Because f10beta downloaded from Gigabyte doesn’t have EFIflash in the folder.
also, F11 downloaded from tweaktown.

can I use the one above from Downgrade EFIflash?

this is my Mac ID: 94-DE-80-6F-0C-F6

@zoe934 - Extract these files to a folder on your desktop - http://s000.tinyupload.com/index.php?fil…724930636785684

If your OS is Win10, run the “Add_Shift+Open_command_window_here_as_administrator.reg” registry file and then reboot first.
This will add “Open CMD Here as Administrator” to your right click menu. Go inside the folder which directly contains the FPTw.exe and the BIOS file, then right click any blank area and choose open command window here as Administrator

If your OS is Win7, then hold down shift key, and right click this folder which contains the FPTw.exe and BIOS file file and choose "Open CMD Prompt as Admin here"

Make sure you see Administrator at the top of the CMD Window, then run the following command>> FPTw.exe -f Z87XUD4HF7.bin

Once it is done, then reboot, enter BIOS, load optimized defaults, save and reboot back to the BIOS, then make all other changes you need before booting to the OS