Flashing Gigabyte while avoiding "Invalid BIOS image"

@SeattleBob Once you have flashed a modified BIOS onto your BIOS chip (using modded EFiflash, Intel FPT or SPI programmer) you can dump it with EFIFlash (modded or original) and it will correct the checksum allowing the dumped copy of the modified BIOS to be flashed with Qflash.

@SeattleBob - Sorry to hear! Sounds odd though, how you mentioned you edited it? UEFITool is not used here, at all, only a straight hex editor. Are you dumping some module, editing it for this Qflash unlock, and inserting back in and rebuilding?
If yes, this is the issue, probably wrong UEFITool breaking the BIOS or something like that. But really you don’t do the edit that way anyway, just straight hex edit at the end of the file directly, never any issue and always works. If you still can’t get it, send me your mod BIOS

Yes, to avoid passing your mac address and NVRAM out, edit stock BIOS, then post that with the Qflash lock edit so others can flash with Qflash.
This is also how you should flash BIOS, edit stock, reflash BIOS with Qflash, your MAC and all system details will remain in place if you use Qflash.
The only time you need to dump your BIOS and edit it is if you are using FPT to reflash BIOS or GbE regoin (or BIOS as a whole)

I was using UEFItool to find the appropriate sections, exporting them, editing with HexEdit, then importing them back in. I was assuming that UEFItool would then take care of appropriate check coding. I will try it again just with the HexEdit and see how that works. I also used the same process to correct the MAC address.

Are there not checksums or some other such verification used in these BIOS files?

@SeattleBob - Yes, I thought so after reading your comment again, this is the issue, due to PEI volume of the BIOS you can’t rebase PEI modules with UEFITool easily (I never touch PEI volumes with UEFITool, sometimes it’s OK but that’s rare)
It may work with MMTool the way you are doing, but you should just straight hex edit the file, works every time

Yes, there is a 16bit sum used for Qflash in the BIOS, but that has nothing to do with any of this (ie doesn’t matter, doesn’t need changed etc)

Edit stock BIOS with your desired mods, once done do the Qflash edit to 00 on straight hex file as a whole, then you are done and can flash it with Qflash.

Lost_N_Bios, thanks for your help. It would have saved me a lot of time if I had figured it out earlier. I’m learning a lot here. It’s kind of nice to have a new challenge, and have a way more powerful PC for a bargain price too.

You’re welcome @SeattleBob - sorry I didn’t realize sooner how it was messing up for you, I almost didn’t catch your comment that made me realize it too
So, you tested it out now, and all works properly doing it that way, correct? Hope so

Thanks again, Lost_N_BIOS.

I just ran through another test. I took the Gigabyte F9d BIOS from their web page, Ran it through the CoffeeLakeModTool, entering 2 (for 8xxx cpus) for the processor selection twice during the process. It gave me a modified .bin file which I edited with HexEdit to change the single byte at 7bbbof ($BDR +60h, follows a 07) from 1 to 0, then saved the result back to my disk. With Boot Guard Technology turned off in the BIOS, it worked perfectly to run it through QFlash from the file on a USB drive and ran perfectly after reboot.

After the CPU pin mods mentioned elsewhere, that’s all you need to do to run a I7-8700k on a GA-Z270XP-SLI motherboard.
Do watch temps, including the VRM temp as you test it.

The above is for this Gigabyte board. Other brands may lock the ME area in the BIOS so the bios flash may not get the ME changed if you have the latest version installed.

I should add, that the board boots my 8700K to 4.7GHz with 1.44V. currently, I go into BIOS after flashing and set the speed multiplier to a lower value, as I don’t want to see that voltage. I have CPU Vcore LoadLine Calibration at “auto”. "Standard seems the same, and “high” pushes the voltage higher. The voltage does come down after a minute or so after windows comes up. any ideas to limit this would be appreciated. It may just be my CPU - It is used, with unknown history, and does seem to have a convex heat spreader, looking at the thin paste area along the centerline of the spreader after removing the heatsink.

You’re welcome! Good to see it’s working for you now Boot Guard shouldn’t need changed for this, unless that’s something new Gigabyte is enabling that’s causing issues with Qflash, that they didn’t used to have enabled in past models (up to Z170 I’ve tested)

You’ll have to add your BIOS mod report and or BIOS into the thread of which ever Coffee mod tool you used, I’m sure others will appreciate it!

Efiflash modified v0.80
This version bypass following checks:
!!! BIOS ID Mismatch !!!
!!! OEMID Mismatch !!!
!!! ROM BDR FFS GUID Mismatch !!!
!!! FILE BDR FFS GUID Mismatch !!!
!! Invalid BIOS image !!
The current BIOS image is outdated.
Use on your own risk.

Efiflash_0.80_mod.zip (47.5 KB)

Thanks @dsanke - what version is that? So others know

@Lost_N_BIOS I write it in title , you might ignore that , it’s 0.80.

Yes, sorry I missed that

@dsanke The modified v0.80 Efiflash seems to to be the same as the original? (same hash)

@chinobino I uploaded the wrong file. I have corrected it now.

That’s better :slight_smile:


Thank you. That helped me a lot

I experienced a very strange behaviour on a Gigabyte X470 Aorus Gaming 7 Wifi Rev. 1.1 where Q-Flash, Efiflash and @BIOS (Windows) refused to update the BIOS. The motherboard came with BIOS version F1 though it was manufactured in March 2019 I asked Gigabyte support and they told me the board should have shipped with F30. My guess is that there must be some checksum bug in version F1. Nevertheless I finally had success with this modded version and was able to flash main and backup BIOS and Q-Flash is now working.

I made a dump through Q-Flash and attached the BIOS (F1) in case someone’s interested.

X470AG7W.part1.rar (6 MB)

X470AG7W.part2.rar (1.27 MB)

Original Efiflash v0.84 attached…

Efiflash v0.84.rar (53.4 KB)

Hi, I have Z87X-UD4H.
I want to flash old BIOS
I have tried many different Efiflash version.
Can anyone advise me which version should I go for BIOS F7.

Thank you

@ex58 - do you know answer for above Q by @zoe934 ? I tried to look at version included with F10b BIOS, but I can’t find what version that is, and even when it’s ran it does not show version #

Don’t use F10 or anything above.
Plenty of issues
I am trying to flash back to F7.