Flashing Gigabyte while avoiding "Invalid BIOS image"

@Lost_N_BIOS I use that version to avoid some careless people flash wrong model , I usually provided that edition with my modified BIOS.
And here is the official 0.74.

Efiflash_0.74.exe.zip (46.4 KB)

@dsanke - So “Mod All” does not have the Invalid ID bypass then, only the Invalid ID has? Nope, I see same edit on both @EDCDh, so still confused why “Mod All” version didn’t work for invalid ID for KedarWolf.
I am really only asking so I can make a note of the changes for all, and look in assembly etc, so I can mod future versions if needed.
I know it may differ in others, but I’m sure I can make a note of the locations to bypass and do in future versions too. Or, if you want I can just tag you every time I see someone ask?

@Lost_N_BIOS The "Mod all" including "Invalid BIOS" , but not include "OEMID mismatch".
"Invalid BIOS" will show when BIOS were modified.
But sometime Gigabyte change OEMID, so "Invalid BIOS" bypass can not bypass OEMID check.

Ohh, OK, thanks @dsanke - I missed that little difference in our discussions and assumed same/same OEMID/Invalid while we talked about it. I will now check all changes, and make notes for each bypass

All this can be bypassed if user flash with Qflash anyway, if wanting to crossflash/wrong ID etc, you can mod BIOS for them if necessary But I know you know this already.
For normal situations, Qflash should be most convenient and safe for user to use, long as that byte following BDR is changed to 00 if 01 by default

The EFIFLASH 0.65 you uploaded can be flashed on the Gigabyte B450M GAMING. The Invalid BIOS image will not appear, but the 0.76 will still prompt this Invalid BIOS image.

Is the latest EFIFLASH a modified version of 0.76? EFIFLASH0.65 can be normal on the Gigabyte B450M GAMING brush BIOS

@silver258 - I only uploaded 0.76 version stock, nothing modified on that yet, but I planned to do it later (Soon). 0.74 MOD was posted few posts back, I am not sure if 0.65 will work on B450 board, probably not since 0.65 is very old version.
As for "Invalid BIOS Image" be careful if you are getting that with Qflash, this can mean broken/bad BIOS mod too, so not always a good idea to force past that error in this manner

Oh, that’s what I got wrong. Now I can use the 0.65 normal brush to brush the Gigabyte B450M GAMING motherboard, and there is no problem, just see the new version, I want to try it, I can’t use it, so I want to try it, the same Thank you very much for your reply

Ohh, OK. Well mod version 0.74 is posted on page #4 post #55 (Sorry, I thought it was posted on page 11, but he only gave info where he added)/ So you can try 0.74 mod for now, it should work if 0.65 works. Then later we’ll add 0.76

I want to ask a question, I don’t know how to modify and brush the ASUS UEFI BIOS into the motherboard. After the download and modification of the official website, the refresh prompt in ASUS EZ Flash is not EFI BIOS. Is there any other way, ASUS B450M-DRAGON

@silver258 - Asus BIOS flashing has nothing to do with Gigabyte BIOS flash tools (This page is about Gigabyte BIOS flash tool)

Asus board you mention has EZ Flash within the BIOS, download and then extract the BIOS >> B450M-DRAGON-ASUS-1804.CAP, put BIOS file on USB Stick and boot to BIOS, enter EZ Flash and flash BIOS. USB should be formatted to FAT32, and BIOS file should be on root of USB, not in a folder
Or, you may also be able to use USB Flashback, you’ll have to check your manual to see about this (I can’t find specs on Asus site, so I can’t tell if it has USB Flashback or not).
If you do that, rename file to B450MD.CAP, turn on file extensions if you don’t see .CAP on extracted file name, that way when you rename you don’t end up with B450MD.CAP.CAP
If you are not sure if you have file extensions on, make a new notepad file on your desktop, do you see newtextdocument.txt? If not, you need to go to folder options, view tab, and uncheck “Hide extensions for known file types”
Then rename file as mentioned. This only required if you are using USB Flashback, for EZ Flash from within the BIOS, you can use as named when downloaded B450M-DRAGON-ASUS-1804.CAP

If this is modified BIOS, you cannot flash it via EZ Flash, you will have to use USB Flashback or purchase a flash programmer (Like CH341A + SOIC8 test clip with cable if BIOS is soldered to board, or a U Type Flat IC extractor if BIOS in a socket)
You may also try the method mentioned at post one of this thread (Search ValkyrieStar and follow link right before that name) - [Guide] How to flash a modded AMI UEFI BIOS

@dsanke , just wanted to add that your check-free efiflash 0.65 (in post #55) worked perfectly for me on a GA-H97N (rev 1.0), thanks so much!

I bought the board used on eBay and it had some wonky Equus Nobilis custom BIOS on there and wouldn’t let me flash the stock one (OEM ID Mismatch). The check-free efiflash let me flash the stock one and everything works good as new now, thanks again!

@hnahorton - do you have a backup of the original custom BIOS? If yes, please send to me in a PM, or link here if you want. IN case someone needs this from me later, or help fixing that same custom BIOS etc.

@Lost_N_BIOS I do! I’ll PM you now.

I have a GA-B250M-D3H board that I’m trying to mod to use with an i3 9100F. The board has BIOS version F8, which means the Intel ME version was already upgraded to v11.8. I used the CoffeeTime utility from these forums to make a modified BIOS that supposedly includes ME v11.7, but it’s unclear to me how I need to proceed from here.

If I use the efiflash utility from this thread, will it also downgrade the ME version to 11.7? Or is that only possible by flashing the modified BIOS with a SPI programmer? Thanks!

@jojo_whit3 - since you have Gigabyte board, you have unlocked FD no programmer needed.
My advice to you would be dump BIOS with FPT in full (FPTw.exe -d SPI.BIN) and then redo your modifications to that, then reflash with FPT (FPTw.exe -f SPIMOD.BIN) << Follow that with this command, before you reboot >> FPTw.exe -greset

As to your original question, I am unsure if EFIFlash always flashes ME FW or not, maybe someone else knows.
I do know, if your BIOS asks you if you want full/in-tact BIOS flash while you flash with Qflash, then that means ME FW is flashed too (Full BIOS file, as-is is flashed when you choose Intact/Full, but not all BIOS/Qflash offer this option)
If you are unsure what your Qflash offers, go into BIOS now with stock BIOS on USB, and then enter Qflash via F8 and flash the BIOS, if you get asked quick/partial or intact/Full then you know you can flash your mod BIOS this way also (use Intact/Full and it will reflash ME FW too)

FWIW, I tried modifying the $BDR+63H byte from 1 to 2, which did allow it to be flashed using Qflash into the GA-Z270XP-SLI BIOA for my i78700K. The result for me, with just that change from an operational BIOS version loaded with CH341A was completely non-operational, just cycling the CPU LED.

@SeattleBob - $BDR+63H, sorry I don’t know what you mean, and some BIOS have several instances of BDR, so you may have edited something at wrong location, you’d have to show me an image in hex.
However, the proper edit is 01 to 00, so sounds like you didn’t make correct edit to begin with

I checked latest BIOS F9d for Z270XP-SLI, and here is correct edit. I think I know what you meant now, 63h after BDR? If yes, that is incorrect (and +63h is a 03 by default as it see it), correct edit byte is 60h after BDR.
I see if you include $BDR, then yes, it’s 63 bytes total to the edit byte, but still needs to be 00, not 02. Or were you just testing for science? If yes, try 03 and see what that does


1 Like

From page 1 of this thread - "- first and safest is to switch the flag for Volumes check. Based on efiflash disassembly, the check only happens when that flag is 01, or $BDR + 63h = 1. Thus it can be changed to any other value to avoid the check and error. To remain on the safe side, I suggest the use of Gigabyte values: I have seen FF or 02. The value 02 seems more appropriate"

That’s why I tried 02H. The location was as you showed above. I might play with it some more, but did get the modified EfiFlash to load it fine. Much easier than getting the CH341A clip on the chip correctly. It would be nice to get it so Qflash would load it, though.

@SeattleBob - Ohh yes, I see now on those images, but that was 2015, maybe 02 or FF worked then, or maybe he was only discussing and hadn’t tested directly in BIOS?
Now, setting it to 00 as I showed always works, you can Qflash without issue. I’ve used that on Z97 and maybe earlier too-Current models, and always works when this is found set as 01 in BIOS.
Funny, I used to think those images were about editing EfiFlash since that’s what’s attached, but then later I noticed it’s in BIOS

I did some more experimentation. I tried modifying the same byte to 0. I could again load the file with Qflash, but ended up with my previous result - it would not boot at all. I then tried loading the same file using my CH341A - same result again. The file without that 1 byte change loaded with the CH341A works fine. Changing this byte seems to change something else the bios cannot handle. I did the changes using UEFItool and Hexedit.

it’s not a big deal. I can load with the modified EfiFlash or my CH341A. It just would be nice for QFlash to work, especially if I decide to post my bios.

When posting a bios, is there a standard procedure to avoid passing my MAC address?