GA-H57-USB3 Need to mod BIOS to update Intel Rapid Storage Option ROM

Hi guys

First off, thanks for all the effort put in here. This seems to be the ONLY site of it’s kind on the internet :slight_smile:

I have a Gigabyte GA-H57-USB3 mobo, and i need to upgrade it’s RAID so it can “hopefully” detect some new 4TB drives properly (currently only being detected as 1.6TB each in the RAID setup (pre Windows boot)

My current RAID ROM version is, and i’ve seen the later modules available on this site.

So am following the guide, and appear to of fallen at the first hurdle. I run CBROM.exe againest the latest firmware for my mobo from Gigabyte, and it shows the following:

Now from your guides, i’m supposed to see various modules (inc the RAID) but here…am only seeing 2? That look right? Or am i doing something wrong?

I also tried with the CBROM_155 version of CBROM.

Many Thanks

Hello BigDook,

welcome at Win-RAID Forum!

As you have already verified, it is not possible to update any module of your Gigabyte mainboard BIOS by opening the entire BIOS file with CBROM. The reason is, that Gigabyte has blown up the size of the BIOS to 8 MB, although the BIOS modules themselves only are using 1 MB.
So if you want to modify the BIOS modules, you have to do the following:

  1. Run the Hex Editor HxD and open the entire BIOS file named h57musb3.f9.
  2. Mark the last part of the BIOS beginning at offset 700000 and ending at offset 800000 and cut it out.
  3. Hit “New” and let HxD create a new file by hitting “Insert”. Save this file and name it h57musb3_part.f9, which has a size of 1028 KB.
  4. Open this file named h57musb3_part.f9 with CBROM32_198 by using the /D command. Now you will see a picture like this:


  5. Update the Intel RAID ROM module according to my guide.
  6. Open the modded file named h57musb3_part.f9 with HxD, mark the entire file and copy it.
  7. Open the file named h57musb3.f9 (where you had cut out the previously modified part) with HxD, go to the end (now at offset 700000), insert the just copied modified part and store the just completed BIOS file.

Now you should be ready to flash this BIOS file into the BIOS cip of your mainboard.

Good luck!

:slight_smile: Thanks for the response Fernando. Gonna give it a try now. Fingers crossed :smiley:

BUY THAT MAN A BEER!!! :smiley:

Fernando…you legend, i followed your guide carefully, and lo and behold, my machine booted, the Intel Rapid Storage Option ROM is now on the latest and greatest, and finally…it see’s my 4TB drives as 4TB drives :smiley:

Thank you mate. The manufacturer of my motherboard doesn’t enable me todo this, but you and your site has.

I’ll be donating to your site straight away! Thank mate, have a great weekend

@ BigDook:

You are welcome! I am glad, that you succeeded with your modded BIOS, and it was a pleasure for me, that I could help.
Have a nice weekend and enjoy your updated system!


P.S.: Thank you very much for your donation!


I’ve just bought 3x4Tb drives and am encountering the same problem as BigDook. My H57m-USB3’s raid bios had to be updated.

Google brought me to you.

Many thanks to BigDook for asking you the question (I found you thanks to him).

Many many thanks to you, Fernando. I’m now able to use my new drives.



@ braxess:
Welcome at Win-RAID Forum and thanks for your feedback!
I am glad, that you succeeded the same way as BigDook did.

Enjoy the Forum!

Nice one braxess. Yup, Fernando’s the man :slight_smile:

I HAVE been having some random BSOD and lock ups since doing it though, but i’ve not confirmed it’s down to my RAID Controller yet. If you do experience anything as such, please let me know.

No bsod (yet?)…
Im not very pleased though. Slow write speeds (22mb/s).
Anyhow I think it’s intel raid’s speed…
Do you have something similar ?
thanks again

Please do a look into >this< thread.

Thanks again.
> 160 mbs write
> 300 mbs read
Very satisfied !


To begin, thanks to Fernando’s work.

I have a GA-H57-USB3 too and I’d like to ask 2 small questions :
- If I update only Intel raid bios, will am I able to boot on a 3 To raid1 even if my mainboard doesn’t support EFI?
- Could I install Windows 7 32 bits or should I need a 64 bits version?

Many thanks

@ lordv:
Welcome at Win-RAID Forum!

Although I do not exactly know what you mean with a "3 To raid1", my answer is: "Yes!" If your mainboard doesn’t support booting in UEFI mode, your Intel SATA RAID Controller always will use the Intel RAID ROM module of your mainboard BIOS.

You can install Win7 32bit as well.


I mean a Raid 1 with two disks of 3 Tb each.
If I have well understood, EFI is just needed when booting from SATA on a very large disk (> 2 Tb).
When I use a Intel Raid, the raid bios is enough.

In your opinion, what is the best bios module for my mainboard Intel RST RAID ROM v11.2.0.1527 or Intel RST(e) RAID ROM v13.2.0.2134?

Best regards

For your H57 chipset I do not recommend to insert any Intel RAID ROM of the v13.x.x.xxxx series, because they are designed for Intel’s 8- and 9-Series chipsets.
You will get better results with the Intel RST driver/ROM combo v11.2.0.1006/v11.2.0.1527.


This is quite an old thread but seems to be the only one that really talks about this :).

I have the same motherboard, albeit v1.0. It seems to have the issue of only detecting 1.6TB of a 4TB drive.

This is including disk management.

I gather this has something to do with the BIOS compatibility and it not being UEFI? I am in fact not trying to make it a boot drive but simply a data drive. From what I’ve read, this should work.

However, I can’t seem to get it to see all 4TB, no matter which controller I try.

This is for one of the drives. Another drive I have, which was preformatted to begin with, it “saw” 4TB, but seems to only use up 1.6 or 1.8TB before it complains that it is full. The drive shows itself as being completely full but when checking the file size of all the files together, it only reveals it to be half the amount.

I am thus thinking that this has something to do with the BIOS or controller.

I thought the instructions here would maybe enable the allowance to see the drives as they are but I think I’m a bit confused as to how to go about it.

Any clarification and reassurance will be of great help.


Hello @Braxess and @BigDook (and of course @Fernando ).

Sorry to resurrect such an old thread. I’m still using this ancient board, and hoping to bring it to life with new Option ROM RAID BIOS.

Do either of you have a copy of the modded BIOS you ended up with? Hoping you can share, to avoid reinventing the wheel.

Short of that, where to obtain the newer OROM version, so I can continue following the guide? All the download links in posts about this seem to have expired.

So far, I am past the 8MB size issue by splitting the file with HxD.

Thank you for any help you can provide!


Excellent, thanks for pointing me to that guide I had not yet seen.

I have the new OROM for v11.2.0.1527 integrated/replaced into a modded ROM with CBROM32_140. However, attempting to display the contents (/D), it seems to hang indefinitely on the Micro Code Information at the bottom. Is this a known issue, or did something go wrong?

C:\bios\f9mod>CBROM32_140.EXE h57musb3_part.f9 /D
CBROM32 V1.40 [04/30/04 release] (C)Phoenix Technologies 2001-2004
******** h57musb3_part.f9 BIOS component ********
No. Item-Name Original-Size Compressed-Size Original-File-Name
0. System BIOS 20000h(128.00K) 13984h(78.38K) test.BIN
1. XGROUP CODE 0E0D0h(56.20K) 0979Ah(37.90K) awardext.rom
2. ACPI table 057E0h(21.97K) 01C30h(7.05K) ACPITBL.BIN
3. GROUP ROM[18] 04BC0h(18.94K) 02E87h(11.63K) ggroup.bin
4. GROUP ROM[20] 04870h(18.11K) 02E8Bh(11.64K) ffgroup.bin
5. Other(40CA:0000) 00960h(2.34K) 006DFh(1.72K) y2group.bin
6. YGROUP ROM 0D7F0h(53.98K) 076F8h(29.74K) awardeyt.rom
7. GROUP ROM[22] 0F630h(61.55K) 02CE5h(11.22K) tgroup.bin
8. GROUP ROM[23] 0F630h(61.55K) 040B7h(16.18K) t1group.bin
9. GROUP ROM[24] 0F630h(61.55K) 01979h(6.37K) t2group.bin
10. GROUP ROM[ 0] 07AA0h(30.66K) 02A70h(10.61K) _EN_CODE.BIN
11. Other(4069:0000) 351C0h(212.44K) 351F5h(212.49K) csimemrc.bin
12. VGA ROM[1] 10000h(64.00K) 094B8h(37.18K) ild_1973.dat
13. PCI ROM[B] 04000h(16.00K) 02B4Ah(10.82K) pchahci.bin
14. PCI ROM[C] 0F800h(62.00K) 09328h(36.79K) rtegrom.lom
15. PCI ROM[D] 08000h(32.00K) 04628h(17.54K) jmb10706.bin
16. LOGO BitMap 4B30Ch(300.76K) 1B59Ah(109.40K) usb30.bmp
17. GV3 037C0h(13.94K) 021D9h(8.46K) PPMINIT.ROM
18. OEM0 CODE 03056h(12.08K) 022F4h(8.74K) SBF.BIN
19. LOGO1 ROM 00B64h(2.85K) 00520h(1.28K) dbios.bmp
20. PCI ROM[A] 1DC00h(119.00K) 10EDFh(67.72K) pchraidr.bin
Total compress code space = E3000h(908.00K)
Total compressed code size = B7369h(732.85K)
Remain compress code space = 2BC97h(175.15K)
** Micro Code Information **
Update ID CPUID | Update ID CPUID | Update ID CPUID | Update ID CPUID

edit: formatting

@templeofdoom - only certain cbrom versions will display this properly, depends on BIOS and sometimes no matter what fails to display ucodes after being modified making it hard to trust sometimes.
For GigabyteH57 try 115, 198, 219 or 155 (only edit with 155 or below). Did it display the microcodes properly with 140 before you edited it? If yes, I would do the edit again using another version instead.
Gigabyte H55/H57 is a pain for many mods, be prepared for recovery if you flash mod BIOS. This may apply more towards H55 than H57, since I see your BIOS is not 4MB BIOS that I’m most familiar with from H55N