GA-Z77HD3 - Corsair Force x2/ Samsung EVO SSDs

Ok my setup is with my Evo/SataII as my boot drive and the corsair’s/SataIII in raid 0 with windows storage spaces. Bios Sata settings is set to AHCI. And i am getting just awful speeds on my Raid0, so ran some benchmarks of all the drives and as a raid 0.

Top 2 are the corsairs not in raid 0, single AHCI settings, and bot left is my Evo and bot right is the corsairs in Raid0 with storage spaces. All using the iastor driver v11.2.0.1006


Now the interesting part comes in when i tried to change my settings in my bios from AHCI -> RAID, so i could try the hardware raid0 and see if it was any better. Not only did I find out you cant really do that without getting a BSOD, but it also was corrupting my Bios EVERY single time it tried to boot in RAID. After I flashed my bios back to default, i decided to try and load with default settings, and it did the same thing due to it being on IDE now. After another reflash and not allowing my boot drive to try and boot before I get to bio and change to AHCI, I am able to load back to windows without issues.

So am I really having a bios issue or a driver issue?? I feel like its causing my SSD speeds to suffer. I tried the microsoft storahci driver and the recommended driver from gigabytes download page iastora All with similiar results. The corsair force gs should be zooming by itself, here was a benchmarks from a similiar Z77 review a few years ago.


So i feel like im missing something, as a raid0 should get near 1000MB/s read speeds. So any help on what my issue might be, whether its drivers/bios/win10/hardware.

Thanks in advance!

@Acps87 :
Welcome to the Win-RAID Forum!
This is what I suggest to do:
1. Make a backup of all your important data and store it outside your current system.
2. Set the Intel SATA Controller to “RAID” mode within the BIOS.
3. Create an Intel RAID0 array consisting of your 2 Corsair Force SSDs.
4. Unplug the 2 Corsair SSDs and do a fresh install of your desired Win10 Edition onto the Samsung 850 EVO SSD.
5. Install all available MS Updates and all missing drivers.
6. Re-attach the 2 Corsair SSDs and restart the computer. The Intel RAID array should be automaticly detected by the OS.
7. Read the start post of >this< thread and follow my advices, especially point 8.
8. Re-do a benchmark test of your RAID0 array and look what happens.

Dieter (alias Fernando)