Gigabyte 880GMA-UD2H

Hi, all

First, I want to say that this is an amazing forum. I had no idea that such thing could exist. A big thank you to Fernando for all the invaluable work he’s doing and to all the contributors.

So, like all of you here, I have been wondering how the hell can I upgrade the RAID ROM of my motherboard. At the moment I am with the latest BIOS which is F5. Needless to say, it’s from 2010 and its RAID ROM is version 3.2.1540.19 (if remember correctly). Today, after I found out about this forum and reading most of the guides, I tried to update it. I took the ROM from some ASUS bios which as I understand it’s not a problem since they are all the same. I managed to integrate it to the official Gigabyte F5 bios, flashed it successfully, rebooted and everything seemed fine. I loaded the default settings, then set up the BIOS again, rebooted and just before the moment when it usually loads the RAID configuration, some screen informed me that there’s a checksum error in the main BIOS and it automatically started flashing it from the backup BIOS. Now everything is fine because I flashed it back with the original F5 bios but I want to know what went wrong.

My RAID controller’s hardware info is PCI\VEN_1002&DEV_4393&SUBSYS_B0021458&REV_40

Could someone probably help me to integrate the latest AMD RAID rom properly? It would be greatly appreciated!

This is a link to the original BIOS for my motherboard:
http://download.gigabyte.asia/FileList/BIOS/mb_bios_ga-880gma-ud2h_v.2.x_f5.exe

Cheers!

@bobypf :
Welcome at Win-RAID Forum!

Please give me the link to the BIOS, which has been modified by you. This way I can verify, what you have done.
Further questions:
1. In which mode (AHCI or RAID) are you using your AMD SATA Controller?
2. Have you updated the AMD AHCI ROM module?
3. When you have updated the AMD RAID ROM, did you update the related MISC.BIN module too?

Regards
Fernando

Hi, Fernando

Thank you for your fast reply! Here are my answers:

The file which I modified is attached.
Hmm I am not sure after I attached it where did it go so here is a link:
Bios

I am using it in RAID. I am using 1x SSD as a system drive, 2x HDD in RAID1 and 2x HDD as standalone.

No. I didn’t know it’s needed since I am using the controller exclusively in RAID mode.

No. I wasn’t sure what is this MISC.BIN for and from what I read, I was under the impression that it’s not necessary.

EDIT by Fernando: Quoted text corrected

Zitat von bobypf im Beitrag #3

No. I wasn’t sure what is this MISC.BIN for and from what I read, I was under the impression that it’s not necessary.



If you want to use an updated AMD RAID ROM, you have to update the related MISC.BIN too.
I just have done a look into the BIOS, which has been modified by you, and compared it with the original BIOS.
The MISC.BIN module is within the HOLE2 of the BIOS and should be replaced by the non-UEFI BIOS MISC.BIN file v3.3.1540.17, which you can find within the start post of >this< thread.
Furthermore I recommend to update the AMD AHCI ROM of your BIOS from v3.0.7.C to v3.1.2.0.

Alright. I added RAID850.BIN, then ahci.BIN, but when I tried to add UI850.bin in HOLE2, I received the following error:

Combine UI850.bin file to 88gmad22.f5…
UI850.bin doesn’t compress


Instead of /PCI I used /HOLE2 as an option because with /PCI it didn’t work.

What’s wrong?

@ bobypf:

What you have done was absolutely correct, but obviously it is impossible to get any v3.3 misc.bin into any hole of an Award BIOS, because they are compressed and CBROM needs them uncompressed.
You will get an explanation done by SummoneR within >this< post.
The only alternative for you may be to insert an AMD RAID ROM and MISC.BIN v3.2.1540.xx, but I didn’t yet find any for your DEV_4393 AMD RAID Controller.
By the way: SummoneR has written a very good guide about the use of CBROM. You can find it >here<.

Oh shit… It means that I will be forever stuck in 3.2…

I am not sure about that.
Tomorrow I will try to find a solution for this general problem.

I would greatly appreciate this. :slight_smile:

@ bobypf:

Meanwhile I have made some tests with your Mainboard BIOS. Unfortunately I couldn’t yet find a way how to properly insert an actual (compressed) v3.3.1540.xx MISC.BIN module into your AWARD BIOS, but I got some additional informations, which hopefully may help you and other users with an AWARD BIOS Mainboard to update their AMD RAID ROM incl. the associated MISC.BIN module.
Since SummoneR is an expert in AWARD BIOS modding, I have written >this< post into his Special AWARD BIOS thread.

@ Fernando:

Yes, man, I read it and I really appreciate your help. I can’t wait to see some resolution. :slight_smile:

By the way, I would like to ask for something else which is of utmost importance to me. After I started using my controller in RAID mode and the corresponding RAID drivers, I cannot use the “Safely remove hardware” function in Windows anymore. This is very annoying because I need to hot plug and unplug some of the hard drives without restarting the computer (not the ones in RAID of course, but the standalone ones). I think that AMD drivers suck. They’ve never supported hot plug in RAID mode and I am sure that it’s only a matter of drivers so that Windows will start seeing the hard drives as hot plug devices. It’s not possible that in AHCI all the hard drives work as hot plug and in RAID they can’t.

Fernando, do you think there is something it can be done with the drivers - some mod - so that they will report the hard drives as hot plug to Windows? Do you think this is possible?

Thank you very much!

AFAIK there is no chance to get the HOTPLUG feature by modifying the AMD RAID driver, but you may get the “Safely Remove Hardware” option by using a tool like HotSwap! You can get it >here<.

I tried to use cbrom 1.55 to read the contents of my original ROM, but it doesn’t show any of the HOLE categories, one of which contains misc.bin (UI850.bin). Does this mean that I cannot use version 1.55 and I am back to square 1?

The use of CBROM v155 only makes sense for the update of BIOS modules, which are listed before/above the sensitive modules (MEMINIT etc.), because this CBROM version doesn’t touch these sensitive modules. For all other BIOS modding operations it is recommended to use the latest CBROM v198. It will show you the HOLE, where the MISC.BIN module is stored.

@bobypf , use cbrom198 to make changes in HOLE2 (UI850.BIN) and follow @SummoneR guide, it’s not complicated to make the changes. Be careful to don’t forget to have enough space for you UI850. I updated UI750 and only use 54k but the changes on @Sumomoner increase the size of the HOLE2 to 64k, compare your HEX number form you HOLE2 to the HEX number from @SummoneR before any changes, because you have to have enough room for you newer version U850.

If your new UI850 don’t surpass the size 64k you don’t need to change anything but compare your HOLE2 to @SummonerR HOLE2 information, to make sure.

Thank you for this, @Ser2k2 . But my problem is that cbrom cannot inject the UI850 at all because it says:

Combine UI850.bin file to 88gmad22.f5…
UI850.bin doesn’t compress


Fernando confirmed this and says that apparently it cannot be done this way. I think I gave up already. It’s getting too complicated.

This seems to be a misleading message.
Here is an excerpt of SummoneR’s guide:

For further details please look >here<.

Sorry my bad, i didn’t know. Because i received the same message when i updated the UI750.bin for my BIOS 88GMUD2H.F8 and i didn’t have any problems with that. And i did it with cbrom198. I thought it will work for you. I’m sorry @bobypf.



Ha! But how come you received the error message and at the same time you managed to inject it? From what I understand, it seems that I must have the uncompressed version of UI850.bin in order to put it there which we don’t have…