GL504GW Bios Mod Gona Bad

Hi, @Lost_N_BIOS

I decided to open a thread here so it may help anyone in the future and i dont flood your inbox

I flashed my GL504GW , with a custom bios mod, and things didnt work very well, the notebook wont boot anymore
So i bought a ch341a with a Soic Clip, to read the bios from the chip, without have to unsolder it from the board

My chip model is a mx25l12873f, and for my lack of luck (again) it is a Wson model, So i cant use the soic clip on it

Tomorrow i ill have someone to unsolder the chip for me, (since i dont have any soldering skills),
and i ill dump the bios and upload in this thread

Thank you

@chadalu - I answered all this in PM, why are you making a thread now after 20+ messages back and forth already?
This will be very confusing, we’ll have to talk here, or in PM, but not both or my head will

WSON is major pain, especially since there are resistors all around it! Removing by hot air will be very tricky! If you have someone remove, be sure they put down kapton/polyimide tape all around it, to hold the resistors in place during removal.

Yes, you’d need WSON adapter for this, but much easier to just put in regular SOIC chip in it’s place (Such as W25Q128FV, W25Q128BV, W25Q128JV). But for that, we’d need to first update the FD/ME VSCC list, so more chips are compatible, unless you purchase MX25L12873F in SOIC package instead

Or, you can have person solder directly to programmer on back/bottom, and or SOIC8 test clip PCB in the SOIC8 / SOP8 location on it’s PCB
The part is similar to above, it’s the one you clip cable into, on the side of that is a SOIC8 mounting position, you can put WSON there
The middle contact on bottom does not matter for programming or function, this can be floated or connected to GND (it works either way)

If you want to replace that chip with same ID chip but SOIC8 instead, here is one for $6 for x1 or $13.50 for x3 - From New York -
Or x5 from China for $9 -

Thanks, Lets keep here the discussion here, sorry for that

The soic clip adapter comes with the same PCB adapter that you linked, but in blue color

I ill buy the soic8 model for future use, but since i live in brasil this ill take 1 month to arrive, so i ill have to stick with the wson for now
I use this notebook for work, so i need it asap

Im going right now to unsolder the chip, so i should be back with the dump in 1-2 hours


The first guy didnt manage to take the chip out of the board using hot air, looks like its soldered and glued

So tomorrow i ill take to other guy with more experience and pro tools, to do the job

I dont know if is a good ideia, or im asking too much,

But can you make 2 bios files for me?

One stock ,

And another with Overclock Menu,Thermal control, undervolt ,Xmp Profiles unlocked at bios menu

Ill try a mod again, if it fails, i ll flash back to stock,

It’s OK Please keep in mind, we have a LOT of posters here, so threads get buried quickly, and I am always behind. So if needed, bump your post once every day or so if I don’t reply, thanks
The adapter I linked is NOT the same, but similar, as I mentioned. The one I linked is made for WSON, due to the middle/bottom mounting/ground pad location, this is not on the usual SOIC8 mount locations.
But yes, as I said, you can mount WSON on that blue adapter, or the bottom of the programmer itself, both have SOIC8 mount location and it’s the same footprint and pin layout as the WSON uses

Yes, often that middle pad is either glued if not connected, or soldered in place and that is a large area, and with lead free solder it’s very tough to remove these.
You need to get it very hot (that will release the glue and lead free solder), ideally a bottom warming plate is suggested to bring the entire board up to a high temp, so added heat from air gun is not immediately absorbed and dispersed out into thee rest of the board.

I can make you a stock BIOS, but first I need a full dump of your chip, unless you just want me to use FD/ME from someone elses dump (it would be fine, if I have)
I can make you unlocked BIOS, that will not fail I’ve already unlocked this BIOS for users here - [Help] Problem showing menus for ASUS ROG GL504GW
And in the original thread you posted in at BIOS-mods -…4GW-Bios-Unlock

Finally i was able to dump the chip, could you check if the dump is ok?

Here it is Lost_N_BIOS…l504gw.bin/file

i dumped using ch341a 1.3

@chadalu - That is a bad dump, use software I mentioned and the ID I mentioned and dump it again - For MX25U12873F use the version in folder of package below named >> CH341A v1.31(1.4) (CH341AFree) Choose correct size (16MB) and type first (25)…213094641136166

This also looks like flashrom software dump, not 1.30 version dump too, but I could be wrong . I usually see this fake/incorrect padding at the end of flashrom dumps, which this has, so that’s why I said that.
But, it’s VERY corrupted, bad dump etc, so that could be there due to this too. Anyway, I can tell this is not the chips actual contents after FPT flash, so it’s a bad dump.

Ok, i ill dump again tomorrow,
the guy who unsolder the chip is a "little systematic", and didnt want me leave with the eprom chip from his workshop.
So tomorrow(its is 2 am here) i ill go there again and make new dumps using diferents versions of the programmer, as you said

But i think we should think in the possibility of using someones else FD/ME, do you have someone elses dump?
My notebook will work normally?


@chadalu - It’s your chip, why would he tell you that you can’t leave with it??
Yes, please use the exact version I mentioned above, the one in the CH341A v1.31(1.4) (CH341AFree) and before you read set Type “25” and Size “16MB”
He will need to do the write with this exact version too, erase first, then blank check, then open file, write/verify
Yes, I have other dump, and yes, it will work normally in your system

While you are there, also ask him if he has spare 16MB 3.0-3.3V SOIC8 chip he could (give you), or sell you, to put in place of this chip instead, good price would be $3-5
Brand does not matter, I will edit FD/ME to be compatible with whatever, if he has one to sell you instead of putting that one back on

The guy didnt work on saturday. so only monday i will have a new dump

Man, im having panic atacks and anxiety crisis,this waiting is killing me

If it is possible could you make the other guy dump for me?

if i cant make a decent dump on monday i ill flash it up.

Sorry to hear! I can’t make any BIOS for you until I have your dumped BIOS first, especially since this is not chip you can reprogram again easily at home to later fix your board details etc.
If you can’t make valid dump, you also can’t make a valid write, so that will be waste of time trying too. Since this guy is acting odd, it would be best if you can get him to solder a SOIC8 chip in this WSON’s place, that way you can then deal with things yourself at home later when/if needed with SOIC8 test clip

Ok, I’ll try tomorrow (today is holiday in brazil, )

i ill buy a 25q128fvsg eprom chip on local market,
this one i receive in 1 or 2 days,

He probably has a 16MB SOIC8 chip he could give/sell you, did you call him and ask? If not, yes, if you get W25Q128FV have him solder to board in place of WSON, then you can fix yourself with CH341A and SOIC8 test clip at home

Finally @Lost_N_BIOS
I’ve Made 3 dumps using 3 programmers
The Files Size is diferent from the previous dump and i can open all of them using UEFItool
And there is ME region on them, so i think everything is fine this time

Bios 1.bin -> CH341A v1.31(1.4) (CH341AFree)
Bios 2.bin -> Ch341a AsProgrammer_1.4.1
Bios 3.bin -> CH341 Programmer v1.1.1.32

I dont know if the W25Q128FV chips will arrive in time, So i ill stick with the original for now, and make everything works,
And when ill try to find a new guy, nicer and less problematic that this one to make the soldering for me

@chadalu - Those all match, so read from each is OK, but as I mentioned, write has only been confirmed with the CH341AFree version (not sure anyone ever tested Colibri and this chip though, so may be OK)
Maybe best to wait a day or two, so he can put the other chip on there for you instead, that way if needed later you can fix things easier from home.

Please confirm for me, the dump you sent me named “original.bin” MD5 >> 57119F69A9F0E4D65648B5C61CA12F9E
This was dumped with what software (FPT?), and this was when it was in working state, correct? If that is known OK, and software dumped BIOS, will use this to make you new BIOS so you can get booting again.
Then I will have you dump after a clean reflash using EZ Flash and stock BIOS 307, then I will redo the unlock for you

Fine, i Just make 3 of them to be sure , i ill use the CH341AFree version to flash

There is anything that must be made to change de eprom chip? or i can just flash it with the dump file and solder it on board?

Just checked the MD5 > 57119f69a9f0e4d65648b5c61ca12f9e , Its the same ! so this is my last working bios dumped using FTP (before unlocking bios using the setup_var…on uefi)

Everything is good to go!

Thank You! Pm me if you have an ETH address

@chadalu - No, I have to make you BIOS, the "original.bin" dump I am asking about is only a partial BIOS dump. What about Ethernet, do you need to know your MAC ID?
Do you need Chipset too, or just Overclock Performance Menu + Hidden advanced? If you need chipset too, I think I will just replace something inside hidden advanced for you, with the Overclock Performance menu

Yeah , that is what im talking about, with the BIOS that you gona make to me, can i just flash it on a W25Q128FV or a mx25l12873f , there is no compatibility problems??, or do you need to change something on BIOS file to make compatible with mx25l12873f or W25Q128FV ?

I dont think i ill need to know my MAC ID
If its possible, chipset menu would be great, I want to know what happens with my NVME, tried update drivers and eveything else at windows level,and can get only half speed on R/W (not a NVME problem, tried on other machine)

Yes, you will be able to program it to either chip, then you will be back at square one before the unlock/bad flash. I will change the chip compatibility list, adding support for the W25Q128FV, it’s not a problem/easy to do while I update/clean your ME FW during the rebuild
About MAC, yes, I was not sure what you meant, since you mentioned that in last post. I can find it for you if needed, but for now all will be back to original state once I make the BIOS, except for the flash chip ID changes and the clean/Updated ME FW>
Sorry I can’t do this right now, no time, but I will do first thing tonight when I get back in here, in about 5 hours from now.

OK, once up and running I will get you hidden advanced with Overclock performance inside there, and chipset too. If I have time tonight, I may just redo all this into the file I send you.
NVME may be you need to do proper clean install, or DMI link speed may need changed, I will look at that while I rebuild the BIOS.

No need to rush!
Tomorrow i ill have to travel, and should be back late , i ill not make in time to get the workshop open to resolder the bios on my notebook

A clean install? windows you mean? i’ve bought 6 months ago, already did a lot of cleans installs.
and it was one of the main reasons that i tried a bios mod.

Yes, I meant windows install, that may be the issue with your NVME. Did you clean install it initially? If yes, was it correct speeds then?
You can always do in-place repair/upgrade installs, this will be clean enough for these purposes and leave all your programs installed and files there too.

Did you ever check NVME lane width and speed with CrystalDiskInfo during your troubleshooting? Maybe it’s not at correct lane width (ie 2 instead of 4), or maybe only at PCIE 2.0 speed instead of 3.0?
Maybe it’s not possible to use PCIE 3.0 speed on this slot? Also, did you confirm the partition is aligned with AS SSD (download = tiny box at very bottom of page)?
We’ll have to look at all this once you’re up and running again


I checked DMI width and it’s set correctly in ME FW to x4 (3.0), however BIOS is set to Auto, which could possibly go Gen1, 2, or 3 and if it’s not going to 3 then that could cause this.
We’ll test later, once you’re on unlocked menu you can directly set Gen3 instead of Auto, see if that fixes it.