[Guide/Deprecated] Flashing modified AMI Aptio UEFI using AFU

AMI recently remastered their site so the link has changed. You can just edit CodeRush’s post and replace the link.

You are right - I have corrected the link.

Can not download : AMIBIOS_and_Aptio_AMI_Firmware_Update_Utility.zip

plz help

Yes, AMI’s website downloads are not working. This has been going on for days, how come they cannot see it? Anyway, found them from another source. It should be the latest or close to that (uploaded at 31/12/2014). Re-compressed file to make it smaller.

AMIBIOS_and_Aptio_AMI_Firmware_Update_Utility.rar (4.66 MB)

It works for me. Followed this link, clicked this one, reached here for “Click here…” button to start download.

Maybe they added a strict referrer or just the site changing?

They fixed it today, that’s why it is working for you. Up until some hours ago that I checked it was not working.

I Try to flash modified ROM file using AFU and receive this message…
"Secure flash function is not supported on this file"

when i flash with AMI ROM Tool AFU 5.05.04 the command "/GUN" doesnot work
when i Try to flash modified CAB file using AFU i receive the verification signature problems message…
someone try the AMIBCP V5.00 to mod CAB files with Capsule verification?
Another suggestion?

I’m about to write a guide on how to flash modded BIOS on ASUS Z97 Motherboards, may work for you too, you can stay tuned and see if my method works for you.

@ HotnikQ:
Welcome at Win-RAID Forum!

Dieter (alias Fernando)

@HotnikQ you can try this [Guide] How to Flash a Modded BIOS on a ASUS Z97 Motherboard

hi there, im not sure if im ok to post here if not ok then il delete it…i need a little help if u guys can help me? , i have an asus n750jk laptop and i want to unlock all menus in my bios, now iv followed this guide on how to backup my bios and modified it using AMIBCP and then flash bk the bios with afu by ami, below was my results i got bk after flashing i then shuddown and start bk up my laptop and there was no change to the bios, can someone help me and point me in the right direction if im doing somthing wrong, i wud also like to unlock my vbios too if i can…iv also attched my original bios from asus the bios is an AMI efi Aptio 4

many thanks

Reading flash … done
- FFS checksums … ok
Erasing Boot Block … done
Updating Boot Block … done
Verifying Boot Block … done
Erasing Main Block … done
Updating Main Block … done
Verifying Main Block … done
Erasing NCB Block … done
Updating NCB Block … done
Verifying NCB Block … done

not show if this helps but will post it too…

Platform: Intel(R) HM86 Express Chipset
Reading HSFSTS register… Flash Descriptor: Valid

— Flash Devices Found —
W25Q64BV ID:0xEF4017 Size: 8192KB (65536Kb)

— Flash Image Information –
Signature: VALID
Number of Flash Components: 1
Component 1 - 8192KB (65536Kb)
Descriptor - Base: 0x000000, Limit: 0x000FFF
BIOS - Base: 0x200000, Limit: 0x7FFFFF
ME - Base: 0x003000, Limit: 0x1FFFFF
GbE - Base: 0x001000, Limit: 0x002FFF
PDR - Not present
Master Region Access:
CPU/BIOS - ID: 0x0000, Read: 0x0B, Write: 0x0A
ME - ID: 0x0000, Read: 0x0D, Write: 0x0C
GbE - ID: 0x0118, Read: 0x08, Write: 0x08
Based on the Host Region FRACC the Host/CPU/BIOS has ( 0x00004A4B ) :
Read Write
Desc : Yes No
Host : Yes Yes
ME : No No
GbE : Yes Yes
PDR : No No

Total Accessable SPI Memory: 8192KB, Total Installed SPI Memory : 8192KB

FPT Operation Passed

N750JKAS203.zip (2.21 MB)

@carl1987 :
Welcome at Win-RAID Forum!

Since I am not an expert regarding your problem, I hope, that you will get support by CodeRush or someone else.

Dieter (alias Fernando)

AMIBCP v5.01
AMIBCP v5.01

Until today I could successfully flash my ASRock z87 Ex4 bioses with AFUDOS. Today when I try to flash latest bios (after moded) it hangs at "Erasing Boot Block" step. Any clues?

I can’t seem to get this to work. I’m trying to flash a modified version of the 6702 BIOS for my Asus P8B-E/4L AMI motherboard, but it simply refuses. The Asus EZ Flash tool within the BIOS itself is obviously not accepting it, but using the latest AFUDOS does not help either. I’m running into verification errors, even when using /P /B /K, and /GAN is not recognised as a command by neither the latest AFUDOS or AFUWINx64.

I tried to use UEFITools to extract the body into a *.rom file but then AFUDOS is starting to claim it lacks security information or something. So I’m still not able to flash it using EZ Flash, AFUDOS or AFUWINx64.

@ RamGuy:

Welcome at Win-RAID Forum!
I hope, that CodeRush is able to help you.

Dieter (alias Fernando)

Please buy a CH341H-based SPI programmer ($5 on Ebay) and forget about AFU /GAN method, because it doesn’t work for modern boards and BIOSes and will never work again.


I would like to thank you personally for this guide!!! I was able to successfully Backup/Modify/Flash my ASUS SL451LN VivoBook UEFI/BIOS in minutes… I had first tried using FTK (FTP) but the BIOS Lock prevented that method… AFU was successful with no issue whatsoever!!! Thx again CodeRush!!! I will post my results as well…

@Fernando @CodeRush

Here are my results for the BIOS Mod Success/Failure Chart

2. System Type = NB
3. North Bridge: Intel Haswell-ULT IMC (8 Series Chipset), South Bridge: Intel Lynx Point-LP
4. Intel EFI SataDriver v14.5.0.2241 (IRST iaStorA v14.6.0.1029)
5. Success: Yes
6. (optional:) Remarks: System is much snappier and responsive compared to any compination of v13.x SataDriver & IRST AHCI Drivers… SSD idle temps are about 2°C-5°C higher running on v13.x/14.x (27°-31°C Idle) compared to running original v12.7 EFI & or (22°-27°C Idle) I assume this is due to the Active UDMA Mode for v12.x IRST drivers is UDMA 5/Max 6 and running any IRST drivers v13.x and up the Active/Max UDMA Mode is 6/6… Also higher CrystalDiskMark and ATTO Benchmark speeds… Noticable in real-world copy/application & startup/shutdown by about 7 seconds…


and a screenshot of a fresh BIOS backup using AFU…


I don’t know if I done something wrong but I couldn’t get the backup to work properly with my asus z77 uefi. I made bootable afudos usb to run in dos and used command: afudos backup.rom /o

Also tried .cap, both of theses complete backup succesfully. But it seems to be missing something as the file size is smaller than the default and modified bios files I have. Is there a another switch command you must include to get full exact backup?

I have tried to manually update the EFI RST part of the latest BIOS file using UEFITool.
I use the Efi Module Intel RST(e) EFI "RaidDriver" v14.6.0.2285 GUID 91B4D9C1. Also tried with the pure efi module from UBU.
When I try to flash the BIOS using the modded file get an error that says invalid file. Gigabyte GZ-Z170X-Gaming5. Tried with dos eifliflash.exe as well as Q-Flash.
Also tried updating efi rst using UBU. It shows up as the right ver when checking modded bios. However get Invalid BIOS file error when flashing (DOS & QFlash).
Tried using @BIOS. Get BIOS file is incorrect error.